อาการ
เมื่อคุณพยายามรีเฟรชข้อมูลในเวิร์กบุ๊ก Microsoft Excel ที่ลิงก์ไปยังฐานข้อมูล Microsoft Access คุณอาจได้รับข้อความแสดงข้อผิดพลาดต่อไปนี้:
ไม่สามารถค้นหา ISAM ที่สามารถติดตั้งได้
ปัญหานี้เกิดขึ้นถ้าเวิร์กบุ๊กถูกเปิดและรีเฟรชก่อนหน้านี้ใน Excel เวอร์ชันที่ใหม่กว่า
สาเหตุ
เมื่อเวิร์กบุ๊ก Excel ที่ลิงก์ไปยังฐานข้อมูล Access จะเปิดขึ้นใน Excel เวอร์ชันที่ใหม่กว่าพารามิเตอร์อาจถูกเพิ่มลงในสตริงการเชื่อมต่อ ถ้า Excel เวอร์ชันก่อนหน้าไม่รู้จักพารามิเตอร์เหล่านี้จะทริกเกอร์ข้อความแสดงข้อผิดพลาด
การแก้ไข
เมื่อต้องการแก้ไขปัญหานี้ให้ลบพารามิเตอร์ใหม่จากสตริงการเชื่อมต่อ โดยทำตามขั้นตอนต่อไปนี้:
-
เปิดเวิร์กบุ๊ก Excel
-
บน ribbonข้อมูลให้คลิกปุ่มการเชื่อมต่อ
-
ในกล่องโต้ตอบการเชื่อมต่อเวิร์กบุ๊กให้เลือกการเชื่อมต่อไปยังฐานข้อมูล Access แล้วคลิกคุณสมบัติ
-
ในกล่องโต้ตอบคุณสมบัติการเชื่อมต่อให้คลิกแท็บคำนิยาม
-
ลบพารามิเตอร์ต่อไปนี้ออกจากสตริงการเชื่อมต่อ:
OLEDB OLEDB: เลี่ยงผ่านการตรวจสอบความถูกต้องของ UserInfo = False OLEDB OLEDB: จำกัด DB แคช = False OLEDB OLEDB: เลี่ยงผ่านการตรวจสอบความถูกต้องของ ChoiceField = False
-
ในกล่องโต้ตอบคุณสมบัติการเชื่อมต่อให้คลิกตกลง เมื่อจุดนี้ข้อมูลของคุณควรได้รับการรีเฟรช
-
ในกล่องโต้ตอบการ เชื่อมต่อเวิร์กบุ๊ก ให้คลิก ปิดจากนั้นบันทึกเวิร์กบุ๊กที่ได้รับการอัปเดต
ข้อมูลเพิ่มเติม
ถ้าคุณรีเฟรชและบันทึกเวิร์กบุ๊กใน Excel เวอร์ชันที่ใหม่กว่าปัญหาจะเกิดขึ้น