อาการ

คุณอาจพบอาการต่อไปนี้เมื่อคุณเข้าถึงหรือดาวน์โหลดจากไซต์ Windows Update ผ่านทางพร็อกซีเซิร์ฟเวอร์หรือไฟร์วอลล์:

  • คุณได้รับข้อความแสดงข้อผิดพลาด "ไม่สามารถแสดงหน้าได้" เมื่อคุณพยายามเข้าถึงการอัปเดตผลิตภัณฑ์

  • คุณได้รับข้อความแสดงข้อผิดพลาด "การดาวน์โหลดและการติดตั้งล้มเหลว" เมื่อคุณพยายามดาวน์โหลดคอมโพเนนต์ การดาวน์โหลดอาจไม่แสดงความคืบหน้าใดๆก่อนที่จะหยุดทำงาน

  • ไซต์หยุดการตอบสนองหลังจาก "โปรดรอ ..." หน้าต่างจะปรากฏขึ้นและไซต์พยายามเตรียมใช้งานแค็ตตาล็อกผลิตภัณฑ์

สาเหตุ

ปัญหานี้อาจเกิดขึ้นถ้าคุณกำลังใช้โปรแกรมซอฟต์แวร์ต่อไปนี้อย่างน้อยหนึ่งอย่างดังต่อไปนี้

  • ซอฟต์แวร์ WinProxy-Otitisมีข้อขัดแย้งน้อยลงกับ WinProxy ๓.๐ที่มี WinProxy เวอร์ชันก่อนหน้า มีข้อขัดแย้งน้อยกว่าที่มีพร็อกซีโปร่งใสแทนที่จะเป็นพร็อกซีคลาสสิก (นำไปใช้กับเวอร์ชัน๓.๐เท่านั้น) สำหรับข้อมูลเพิ่มเติมโปรดไปที่เว็บไซต์ WinProxy ต่อไปนี้:

    http://www.winproxy.net/

  • ทแม-Deerfield.com ข้อขัดแย้งส่วนใหญ่จะเกิดขึ้นกับเวอร์ชันที่เก่ากว่า3.0 สำหรับข้อมูลเพิ่มเติมโปรดไปที่เว็บไซต์ทแมต่อไปนี้:

    http://wingate.com

  • อินเทอร์เน็ตเกต-MaccaSoftMaccaSoft จัดจำหน่ายซอฟแวร์อินเทอร์เน็ตเกทผ่านทางด้านไมโคร, Inc. และ Indelible สีฟ้าแต่การสนับสนุนจะพร้อมใช้งานผ่าน MaccaSoft

ปัญหานี้อาจเกิดขึ้นเนื่องจากสาเหตุอย่างน้อยหนึ่งประการต่อไปนี้:

  • พร็อกซีเซิร์ฟเวอร์เก็บหน้าการอัปเดต Windows และไฟล์ที่เกี่ยวข้อง ลักษณะการทำงานนี้จะป้องกันไม่ให้การติดตั้งและการเตรียมใช้งานที่ถูกต้องของตัวควบคุม ActiveX ที่แค็ตตาล็อกผลิตภัณฑ์ Windows Update ใช้ในการสร้างบนคอมพิวเตอร์ไคลเอ็นต์

  • พอร์ต๘๐หรือ๔๔๓ถูกปิด การอัปเดต Windows จำเป็นต้องมีการเชื่อมต่อทั้ง HTTP และ HTTPS

  • คอมพิวเตอร์ไคลเอ็นต์ไม่ได้รับการกำหนดค่าให้อนุญาตการใช้งานสคริปต์ที่ใช้งานอยู่หรือการดาวน์โหลดและการเตรียมใช้งานตัวควบคุม ActiveX

การแก้ไข

เมื่อต้องการแก้ปัญหานี้ ให้ดำเนินการตามขั้นตอนเหล่านี้:

  1. ล้างแคชของพร็อกซีและกำหนดค่าให้ยกเว้นไซต์ Windows Update หมายเหตุ ดูเอกสารประกอบซอฟต์แวร์ของคุณหรือติดต่อผู้ผลิตซอฟต์แวร์ถ้าคุณต้องการความช่วยเหลือเกี่ยวกับพร็อกซีเซิร์ฟเวอร์หรือการกำหนดค่าซอฟต์แวร์ไฟร์วอลล์

  2. เปิดพอร์ต๘๐

  3. เพิ่มการอัปเดต Windows ลงในโซนไซต์ที่เชื่อถือได้

คุณต้องตั้งค่าการตั้งค่าความปลอดภัยใน Microsoft Internet Explorer เป็นปานกลางหรือต่ำกว่าสำหรับไฟล์ ActiveX เพื่อส่งผ่านไปยังคอมพิวเตอร์ของคุณอย่างถูกต้อง เมื่อคุณลดการตั้งค่าความปลอดภัยคุณจะมีผลกระทบต่อเว็บไซต์ที่แสดงอยู่ในโซนไซต์ที่เชื่อถือได้ของ Internet Explorer เท่านั้น การตั้งค่าความปลอดภัยปัจจุบันของคุณสำหรับเว็บไซต์อื่นๆทั้งหมดจะยังคงอยู่ในขณะนี้ได้รับการกำหนดค่าไว้ เมื่อต้องการตั้งค่าการตั้งค่าความปลอดภัยใน Internet Explorer ให้ทำตามขั้นตอนต่อไปนี้:

  1. ใน Internet Explorer ให้คลิกเครื่องมือแล้วคลิกตัวเลือกอินเทอร์เน็ตแล้วคลิกความปลอดภัย

  2. คลิกโซนไซต์ที่เชื่อถือได้แล้วคลิกไซต์

  3. ล้างกล่องกาเครื่องหมาย จำเป็นต้องมีการตรวจสอบเซิร์ฟเวอร์ (https:) สำหรับไซต์ทั้งหมดในโซนนี้ให้ เลือกกล่องกาเครื่องหมาย

  4. ในกล่องเพิ่มเว็บไซต์นี้ไปยังโซน:กล่องข้อความให้พิมพ์http://* microsoftแล้วคลิกเพิ่ม

  5. คลิก ตกลง

  6. คลิก ระดับแบบกำหนดเองแล้วคลิก เปิดใช้งาน สำหรับรายการต่อไปนี้:

    • ดาวน์โหลดตัวควบคุม ActiveX ที่เซ็นชื่อแล้ว

    • ดาวน์โหลดตัวควบคุม ActiveXที่ไม่ได้ลงทะเบียน

    • เตรียมใช้งานและสคริปต์ตัวควบคุม ActiveX ที่ไม่ได้ถูกทำเครื่องหมายว่าปลอดภัย

    • เรียกใช้ตัวควบคุม ActiveX และปลั๊กอิน

    • ตัวควบคุม ActiveX ของสคริปต์ที่มีการทำเครื่องหมายว่าปลอดภัยสำหรับการเขียนสคริปต์

  7. คลิก ตกลง สองครั้งเพื่อออกจากคุณสมบัติของอินเทอร์เน็ต

สำหรับข้อมูลเพิ่มเติมเกี่ยวกับการกำหนดค่าความปลอดภัยของ Internet Explorer ให้คลิกหมายเลขบทความต่อไปนี้เพื่อดูบทความในฐานความรู้ของ Microsoft:

๑๗๔๓๖๐ วิธีใช้โซนความปลอดภัยใน Internet Explorer

ต้องการความช่วยเหลือเพิ่มเติมหรือไม่

ต้องการตัวเลือกเพิ่มเติมหรือไม่

สํารวจสิทธิประโยชน์ของการสมัครใช้งาน เรียกดูหลักสูตรการฝึกอบรม เรียนรู้วิธีการรักษาความปลอดภัยอุปกรณ์ของคุณ และอื่นๆ

ชุมชนช่วยให้คุณถามและตอบคําถาม ให้คําติชม และรับฟังจากผู้เชี่ยวชาญที่มีความรู้มากมาย