อาการ
หลังจากติดตั้งการอัปเดตความปลอดภัยประจําเดือนมกราคม 2023 Exchange Server 2016 ในคอมพิวเตอร์ที่ใช้ Windows Server 2012 R2 บริการ Microsoft Exchange Server บางอย่างที่อยู่ในโหมดการเริ่มต้นโดยอัตโนมัติอาจไม่เริ่มทํางานหลังจากเริ่มเซิร์ฟเวอร์ใหม่ นอกจากนี้ อีเวนต์ต่อไปนี้จะได้รับการบันทึกในบันทึกเหตุการณ์ในแชนเนลระบบ:
ชื่อบันทึก: ระบบ
ที่มา: ตัวจัดการ
ควบคุมบริการ
วันที่: 1/19/2023 3:22:51 AM
รหัสเหตุการณ์: 7022
ประเภทงาน: ไม่มี
ระดับ: ข้อผิดพลาด
คําสําคัญ: คลาสสิก
ผู้ใช้: N/A
คอมพิวเตอร์: EXCHLAB01.contoso.com
คำ อธิบาย:
บริการโทโพโลยีของ Microsoft Exchange Active Directory ค้างเมื่อเริ่มทํางาน
สาเหตุ
ลักษณะการทํางานนี้เกิดขึ้นเนื่องจากปัญหาเกี่ยวกับเวลาที่มีอยู่ระหว่างบริการโทโพโลยี Microsoft Exchange Active Directory (MSExchangeADTopology) และบริการอะแดปเตอร์ประสิทธิภาพการทํางาน WMI (wmiApSrv) บน Windows Server 2012 R2
การแก้ไขปัญหา
เมื่อต้องการแก้ไขปัญหานี้ ให้ติดตั้งการอัปเดตความปลอดภัยต่อไปนี้:
วิธีแก้ไขปัญหา
เมื่อต้องการแก้ไขปัญหานี้ ให้ใช้วิธีใดวิธีหนึ่งต่อไปนี้
วิธีแก้ไขปัญหาชั่วคราว 1
เพิ่มบริการอะแดปเตอร์ประสิทธิภาพ WMI ไปยังบริการที่ขึ้นต่อกันของบริการโทโพโลยีของ Microsoft Exchange Active Directory เมื่อต้องการทําเช่นนี้ ให้เรียกใช้คําสั่ง PowerShell ต่อไปนี้:
-
$dependentServices = (Get-ItemProperty HKLM:\SYSTEM\CurrentControlSet\Services\MSExchangeADTopology) DependOnService
-
Set-ItemProperty -Name "DependOnService" -Path HKLM:\SYSTEM\CurrentControlSet\Services\MSExchangeADTopology -Value ($dependentServices + 'wmiApSrv')
วิธีแก้ไขปัญหาชั่วคราว 2
เริ่มบริการต่างๆ หลังจากคอมพิวเตอร์เริ่มระบบใหม่ เมื่อต้องการทําเช่นนี้ ให้เรียกใช้คําสั่ง PowerShell ต่อไปนี้:
-
Get-Service -DisplayName "Microsoft Exchange*" | Where-Object {$_. Starttype -eq "อัตโนมัติ" -และ $_. สถานะ -ne "กําลังเรียกใช้"} | Start-Service
หมายเหตุ คุณยังสามารถเรียกใช้คําสั่งโดยอัตโนมัติหลังจากเริ่มระบบใหม่โดยใช้ Windows Task Scheduler