อาการ
พิจารณาสถานการณ์ต่อไปนี้:
-
คุณสร้างคอลเลกชันแบบไดนามิกจํานวนมากบนเซิร์ฟเวอร์ไซต์ System Center Configuration Manager Service Pack 2 (SP2) โดยใช้กฎที่ยึดตามคิวรี ตัวอย่างเช่น คุณสร้างคอลเลกชันเหล่านี้หลายพันรายการ
-
ในคอนโซลConfiguration Manager คุณคลิก รีเฟรช เพื่อดูการเป็นสมาชิกล่าสุดในคอลเลกชันแบบไดนามิก
ในสถานการณ์สมมตินี้ คอนโซลConfiguration Managerจําเป็นต้องใช้เวลานานในการแสดงการเป็นสมาชิกล่าสุด การหน่วงเวลานี้จะใช้เวลาหลายนาทีถึงหลายชั่วโมง
สาเหตุ
ปัญหานี้เกิดขึ้นเนื่องจาก Collection Evaluator รักษาคิวก่อนออก (FIFO) เพื่อจัดการการร้องขอการประเมินคอลเลกชัน
เมื่อคุณคลิก รีเฟรช เพื่อดูการเป็นสมาชิกล่าสุดของคอลเลกชัน การร้องขอนี้จะถูกใส่ไว้ที่ส่วนท้ายของคิว FIFO หากคําขอก่อนหน้านี้มีขนาดใหญ่มาก Collection Evaluator ต้องใช้เวลานานในการดําเนินการคําขอก่อนหน้านี้ให้เสร็จสมบูรณ์ ดังนั้น การหน่วงเวลานานเกิดขึ้นก่อนที่คุณจะดูผลลัพธ์ที่อัปเดตในคอนโซลConfiguration Manager
การแก้ไข
หลังจากที่คุณติดตั้งโปรแกรมแก้ไขด่วนนี้ Collection Evaluator จัดลําดับความสําคัญของคิวเพื่อให้การร้องขอใดๆ จากส่วนติดต่อผู้ใช้ (UI) ลําดับความสําคัญสูง ดังนั้น คําขอ UI จะถูกจัดการในเวลาที่เหมาะสม แม้ว่าจะมีคําขอส่วนหลังจํานวนมากในคิวก็ตาม
ข้อมูลโปรแกรมแก้ไขด่วน
โปรแกรมแก้ไขด่วนที่ได้รับการสนับสนุนจาก Microsoft พร้อมใช้งานแล้ว อย่างไรก็ตาม โปรแกรมแก้ไขด่วนนี้มุ่งหวังเพื่อแก้ไขปัญหาที่อธิบายไว้ในบทความนี้เท่านั้น ใช้โปรแกรมแก้ไขด่วนนี้เฉพาะกับระบบที่พบปัญหาที่อธิบายไว้ในบทความนี้เท่านั้น โปรแกรมแก้ไขด่วนนี้อาจได้รับการทดสอบเพิ่มเติม ดังนั้น ถ้าคุณจะไม่ได้รับผลกระทบอย่างร้ายแรงจากปัญหานี้ เราขอแนะนําให้คุณรอการอัปเดตซอฟต์แวร์ถัดไปที่มีโปรแกรมแก้ไขด่วนนี้
หากโปรแกรมแก้ไขด่วนพร้อมให้ดาวน์โหลดแล้ว จะมีส่วน "โปรแกรมแก้ไขด่วนพร้อมให้ดาวน์โหลด" ที่ด้านบนของบทความฐานความรู้นี้ หากส่วนนี้ไม่ปรากฏ ให้ติดต่อฝ่ายบริการลูกค้าของ Microsoft และฝ่ายสนับสนุนเพื่อขอรับโปรแกรมแก้ไขด่วน
หมายเหตุ ถ้ามีปัญหาเพิ่มเติมเกิดขึ้น หรือถ้าการแก้ไขปัญหาใด ๆ ที่จําเป็น คุณอาจต้องสร้างการร้องขอบริการแยกต่างหาก ค่าใช้จ่ายในการสนับสนุนปกติจะใช้กับคําถามและปัญหาการสนับสนุนเพิ่มเติมที่ไม่มีคุณสมบัติสําหรับโปรแกรมแก้ไขด่วนนี้เฉพาะ สําหรับรายการทั้งหมดของหมายเลขโทรศัพท์ของฝ่ายบริการลูกค้าและฝ่ายสนับสนุนของ Microsoft หรือเมื่อต้องการสร้างการร้องขอบริการแยกต่างหาก โปรดเยี่ยมชมเว็บไซต์ต่อไปนี้ของ Microsoft:
http://support.microsoft.com/contactus/?ws=supportหมายเหตุ ฟอร์ม "โปรแกรมแก้ไขด่วนที่พร้อมใช้งาน" แสดงภาษาที่มีโปรแกรมแก้ไขด่วน หากคุณไม่เห็นภาษาของคุณ เป็นเพราะโปรแกรมแก้ไขด่วนไม่พร้อมใช้งานสําหรับภาษานั้น
ข้อกำหนดเบื้องต้น
เมื่อต้องการใช้โปรแกรมแก้ไขด่วนนี้ คุณต้องมี System Center Configuration Manager 2007 Service Pack 2 (SP2) ติดตั้งอยู่
คําแนะนําในการติดตั้ง
หมายเหตุ แพคเกจโปรแกรมแก้ไขด่วนต่อไปนี้สามารถติดตั้งบน System Center Configuration Manager 2007 SP2 site server ที่กําลังเรียกใช้ระบบปฏิบัติการรุ่น x86 หรือรุ่น x64 ของระบบปฏิบัติการ:
SCCM2007-SP2-KB982400-ENU.msi
ความต้องการในการเริ่มระบบใหม่
คุณไม่จําเป็นต้องเริ่มการทํางานของคอมพิวเตอร์ใหม่หลังจากที่คุณใช้โปรแกรมแก้ไขด่วนนี้
ข้อมูลการแทนที่โปรแกรมแก้ไขด่วน
โปรแกรมแก้ไขด่วนนี้ไม่แทนที่โปรแกรมแก้ไขด่วนที่ออกมาก่อนหน้านี้
ข้อมูลไฟล์
เวอร์ชันภาษาอังกฤษ (สหรัฐอเมริกา) ของโปรแกรมแก้ไขด่วนนี้จะติดตั้งแฟ้มที่มีแอตทริบิวต์ที่แสดงอยู่ในตารางต่อไปนี้ วันที่และเวลาสําหรับไฟล์เหล่านี้แสดงตามเวลามาตรฐานสากล (UTC) วันที่และเวลาสําหรับไฟล์เหล่านี้บนคอมพิวเตอร์เฉพาะที่ของคุณจะแสดงเวลาท้องถิ่นของคุณพร้อมกับความโน้มเอียงของเวลาตามฤดูกาล (DST) ปัจจุบันของคุณ นอกจากนี้ วันที่และเวลาอาจเปลี่ยนแปลงเมื่อคุณดําเนินการบางอย่างในไฟล์
บันทึกย่อข้อมูลไฟล์ของ System Center Configuration Manager 2007
ชื่อไฟล์ |
รุ่นของไฟล์ |
ขนาดไฟล์ |
วันที่ |
เวลา |
แพลตฟอร์ม |
---|---|---|---|---|---|
Colleval.dll |
4.0.6487.2135 |
102,248 |
01-ก.พ.-2553 |
11:50 |
x86 |
สถานะ
Microsoft ยืนยันว่าปัญหานี้เป็นปัญหาที่เกิดขึ้นกับผลิตภัณฑ์ของ Microsoft ซึ่งมีการระบุไว้ในส่วน "นำไปใช้กับ"
ข้อมูลเพิ่มเติม
สําหรับข้อมูลเพิ่มเติมเกี่ยวกับคําศัพท์เฉพาะของการปรับปรุงซอฟต์แวร์ ให้คลิกหมายเลขบทความต่อไปนี้เพื่อดูบทความใน Microsoft Knowledge Base:
824684 คําอธิบายเกี่ยวกับคําศัพท์มาตรฐานที่ใช้เพื่ออธิบายการอัปเดตซอฟต์แวร์ของ Microsoft