ข้ามไปที่เนื้อหาหลัก
การสนับสนุน
ลงชื่อเข้าใช้
ลงชื่อเข้าใช้ด้วย Microsoft
ลงชื่อเข้าใช้หรือสร้างบัญชี
สวัสดี
เลือกบัญชีอื่น
คุณมีหลายบัญชี
เลือกบัญชีที่คุณต้องการลงชื่อเข้าใช้

คำเตือน: แอปพลิเคชันเดสก์ท็อป Internet Explorer 11 ที่สิ้นสุดการสนับสนุนและสิ้นสุดการสนับสนุนได้ถูกปิดใช้งานอย่างถาวรผ่านการอัปเดต Microsoft Edge ใน Windows 10 บางเวอร์ชัน สําหรับข้อมูลเพิ่มเติม โปรดดู คําถามที่ถามบ่อยเกี่ยวกับวันสิ้นสุดการใช้งานแอป Internet Explorer 11 บนเดสก์ท็อป

อาการ

พิจารณาสถานการณ์สมมติต่อไปนี้:

  • คุณพัฒนาแอปพลิเคชัน 64 บิตที่โฮสต์ตัวควบคุม WebBrowser

  • Internet Explorer 11 หรือ Internet Explorer 10 และ Adobe Reader ติดตั้งอยู่ในคอมพิวเตอร์แล้ว

  • คุณพยายามเปิดเอกสาร PDF โดยใช้ตัวควบคุม WebBrowser ในแอปพลิเคชัน

ในสถานการณ์สมมตินี้ Adobe Reader ไม่เริ่มทํางาน แต่เว็บเพจในแอปพลิเคชันไม่สามารถโหลดตัวควบคุม ActiveX Adobe Reader และเว็บเพจแสดงเฉพาะหน้าสีขาวที่มีสัญลักษณ์ "X" สีดํา

สาเหตุ

ปัญหานี้เกิดขึ้นเนื่องจากตัวควบคุม ActiveX โปรแกรมอ่าน Acrobat ที่ใช้ในการจัดการกับเอกสาร PDF มีพร้อมใช้งานเป็นเวอร์ชัน 32 บิตเท่านั้น เนื่องจากไม่สามารถโหลด Add-on เวอร์ชัน 32 บิตในกระบวนการ 64 บิต เว็บเพจจะแสดงหน้าเปล่าพร้อมกับระบุว่าไม่สามารถโหลดตัวควบคุม ActiveX ได้

เมื่อตัวควบคุม WebBrowser ตรวจพบตัวควบคุม ActiveX แบบ 32 บิต ตัวควบคุมนั้นจะพยายามโหลดตัวควบคุมโดยใช้ Internet Explorer ในโหมดที่ได้รับการป้องกันขั้นสูง

การแก้ไขปัญหา

ข้อมูลการปรับปรุง

เมื่อต้องการแก้ไขปัญหานี้ ให้ติดตั้งการปรับปรุงความปลอดภัยแบบสะสมล่าสุดสําหรับ Internet Explorer เมื่อต้องการทําเช่นนี้ ให้ไปที่ Microsoft Update

สําหรับข้อมูลทางเทคนิคเกี่ยวกับการปรับปรุงการรักษาความปลอดภัยล่าสุดสําหรับ Internet Explorer ไปที่เว็บไซต์ของ Microsoft ต่อไปนี้:

http://www.microsoft.com/technet/security/current.aspxหมายเหตุ การอัปเดตนี้ถูกรวมไว้ใน 2969262 การอัปเดตความปลอดภัยเป็นครั้งแรก

2969262 MS14-035: การปรับปรุงความปลอดภัยแบบสะสมสําหรับ Internet Explorer: 10 มิถุนายน 2557

สถานะ

Microsoft ได้ยืนยันว่านี่เป็นปัญหาที่เกิดขึ้นกับผลิตภัณฑ์ของ Microsoft ที่แสดงไว้ในส่วน "นำไปใช้กับ"

แหล่งอ้างอิง

ดู คําศัพท์ที่ Microsoft ใช้เพื่ออธิบายการอัปเดตซอฟต์แวร์
 

ผลิตภัณฑ์ของบริษัทอื่นที่กล่าวถึงในบทความนี้ ผลิตโดยบริษัทที่ไม่เกี่ยวข้องกับ Microsoft Microsoft ไม่มีการรับประกันทั้งทางตรงหรือทางอ้อม เกี่ยวกับประสิทธิภาพการทำงานหรือความน่าเชื่อถือของผลิตภัณฑ์เหล่านี้

ต้องการความช่วยเหลือเพิ่มเติมหรือไม่

ต้องการตัวเลือกเพิ่มเติมหรือไม่

สํารวจสิทธิประโยชน์ของการสมัครใช้งาน เรียกดูหลักสูตรการฝึกอบรม เรียนรู้วิธีการรักษาความปลอดภัยอุปกรณ์ของคุณ และอื่นๆ

ชุมชนช่วยให้คุณถามและตอบคําถาม ให้คําติชม และรับฟังจากผู้เชี่ยวชาญที่มีความรู้มากมาย

ข้อมูลนี้เป็นประโยชน์หรือไม่

คุณพึงพอใจกับคุณภาพภาษาเพียงใด
สิ่งที่ส่งผลต่อประสบการณ์ใช้งานของคุณ
เมื่อกดส่ง คำติชมของคุณจะถูกใช้เพื่อปรับปรุงผลิตภัณฑ์และบริการของ Microsoft ผู้ดูแลระบบ IT ของคุณจะสามารถรวบรวมข้อมูลนี้ได้ นโยบายความเป็นส่วนตัว

ขอบคุณสำหรับคำติชมของคุณ!

×