Applies ToWindows Vista Enterprise Windows Vista Home Basic Windows Vista Home Premium Windows Vista Starter Windows Vista Ultimate Windows 7 Enterprise Windows 7 Home Basic Windows 7 Home Premium Windows 7 Professional Windows 7 Starter Windows 7 Ultimate

อาการ

คุณได้รับข้อผิดพลาด หรือไม่มีสิ่งใดที่เกิดขึ้นเมื่อคุณเริ่มการทำงาน แฟ้ม EXE ใน Windows 7 หรือ Windows Vista นอกจากนี้ คุณอาจได้รับข้อความแจ้งว่าคุณมีไวรัส

สาเหตุ

ปัญหานี้อาจเกิดขึ้นได้ถ้าไวรัส หรือโปรแกรมประยุกต์อื่นทำให้การตั้งค่ารีจิสทรีเริ่มต้นบางรายการเปลี่ยนแปลง หรือเสียหาย

การแก้ปัญหา

เมื่อต้องการแก้ไขปัญหานี้ คุณสามารถรีเซ็ตการตั้งค่ารีจิสทรีให้้เป็นการตั้งค่าเริ่มต้นได้ เมื่อต้องการทำเช่นนี้ ให้ทำตามขั้นตอนเหล่านี้

  1. คลิกเริ่มปุ่ม และพิมพ์regeditในกล่องค้นหา

  2. คลิกขวาRegedit.exeในรายการส่งคืน และคลิกเรียกใช้ในฐานะผู้ดูแล

  3. เรียกดูคีย์รีจิสทรีต่อไปนี้:HKEY_CLASSES_ROOT\.exe

  4. ด้วย.exeเลือก คลิกขวา(ค่าเริ่มต้น)แล้วคลิกปรับเปลี่ยน...

  5. การเปลี่ยนแปลงข้อมูลค่า:ถึงexefile

  6. เรียกดู และจากนั้น คลิกที่คีย์รีจิสทรีต่อไปนี้:HKEY_CLASSES_ROOT\exefile

  7. มีexefileเลือก คลิกขวา(ค่าเริ่มต้น)และคลิกปรับเปลี่ยน...

  8. การเปลี่ยนแปลงข้อมูลค่า:กับ"% 1 " % *

  9. เรียกดู และจากนั้น คลิกที่คีย์รีจิสทรีต่อไปนี้:KEY_CLASSES_ROOT\exefile\shell\open

  10. ด้วยเปิดเลือก คลิกขวา(ค่าเริ่มต้น)และคลิกปรับเปลี่ยน...

  11. การเปลี่ยนแปลงข้อมูลค่า:กับ"% 1 " % *

  12. ปิดตัวแก้ไขรีจิสทรี แล้วเริ่มการทำงานของพีซีของคุณ

ข้อมูลเพิ่มเติม

หากไม่สามารถแก้ปัญหาของคุณ หรือการคลิก แฟ้ม EXE เริ่มโปรแกรมประยุกต์ที่ไม่ถูกต้อง ดูบทความนี้:

เมื่อคุณเรียกใช้แฟ้ม.exe บนคอมพิวเตอร์ที่ใช้ Windows แฟ้มอาจเริ่มโปรแกรมอื่น

ต้องการความช่วยเหลือเพิ่มเติมหรือไม่

ต้องการตัวเลือกเพิ่มเติมหรือไม่

สํารวจสิทธิประโยชน์ของการสมัครใช้งาน เรียกดูหลักสูตรการฝึกอบรม เรียนรู้วิธีการรักษาความปลอดภัยอุปกรณ์ของคุณ และอื่นๆ

ชุมชนช่วยให้คุณถามและตอบคําถาม ให้คําติชม และรับฟังจากผู้เชี่ยวชาญที่มีความรู้มากมาย