ข้ามไปที่เนื้อหาหลัก
การสนับสนุน
ลงชื่อเข้าใช้
ลงชื่อเข้าใช้ด้วย Microsoft
ลงชื่อเข้าใช้หรือสร้างบัญชี
สวัสดี
เลือกบัญชีอื่น
คุณมีหลายบัญชี
เลือกบัญชีที่คุณต้องการลงชื่อเข้าใช้

อาการ

คุณใช้เวิร์กโฟลว์หลายเวิร์กโฟลว์ใน Microsoft Dynamics CRM 4.0 ตาราง AsyncOperationBase และ WorkflowLogBase มีขนาดใหญ่มาก และมีปัญหาด้านประสิทธิภาพการเกิดขึ้น

สาเหตุ

ปัญหานี้เกิดขึ้นเนื่องจาก เมื่อกฎเวิร์กโฟลว์ถูกเรียกใช้ อินสแตนซ์ของเวิร์กโฟลว์และระเบียนเวิร์กโฟลว์จะถูกสร้างขึ้นในตาราง AsyncOperationBase และ WorkflowLogBase ของฐานข้อมูล MSCRM อย่างไรก็ตาม เมื่ออินสแตนซ์ของเวิร์กโฟลว์เสร็จสมบูรณ์ ระเบียนเวิร์กโฟลว์จะยังคงอยู่ในฐานข้อมูล ดังนั้น ตาราง AsyncOperationBase และ WorkflowLogBase จึงขยายตัวต่อไป สุดท้าย ประสิทธิภาพลดลง

หมายเหตุ คุณสมบัติ AsyncOperationType ของระเบียนเหล่านี้ถูกตั้งค่าเป็น 10

การแก้ไข

ปัญหานี้ได้รับการแก้ไขแล้วใน Rollup การอัปเดตสะสมล่าสุดของ Microsoft Dynamics CRM 4.0
หากต้องการข้อมูลเพิ่มเติม โปรดคลิกที่หมายเลขบทความต่อไปนี้เพื่อดูบทความในฐานความรู้ของ Microsoft

949256 Microsoft Dynamics CRM 4.0 อัปเดตและการแก้ไขด่วนที่สําคัญส่วน วิธีการ หรืองานนี้มีขั้นตอนที่



บอกวิธีการปรับเปลี่ยนรีจิสทรี อย่างไรก็ตาม ปัญหาร้ายแรงอาจเกิดขึ้นถ้าคุณปรับเปลี่ยนรีจิสทรีอย่างไม่ถูกต้อง ดังนั้น ตรวจสอบให้แน่ใจว่าคุณได้ปฏิบัติตามขั้นตอนเหล่านี้อย่างระมัดระวัง เพื่อการป้องกันที่เพิ่มขึ้น ให้ย้อนกลับรีจิสทรีก่อนที่คุณจะปรับเปลี่ยน จากนั้นคุณสามารถคืนค่ารีจิสทรีถ้ามีปัญหาเกิดขึ้น For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:

322756 วิธีการย้อนกลับและคืนค่ารีจิสทรีใน Windows หลังจากที่คุณติดตั้งโปรแกรมแก้ไขด่วน เพื่อให้เราเปิดใช้งานการแก้ไขด่วนนี้ให้คุณ ให้ไปที่ส่วน " แก้ไขปัญหา

ให้ฉัน" ถ้าคุณต้องการเปิดใช้งานการแก้ไขด่วนด้วยตนเอง ให้ไปที่ส่วน "ให้ฉันแก้ไขด้วยตนเอง"

แก้ปัญหาให้ฉัน



เมื่อต้องการเปิดใช้งานการแก้ไขด่วนโดยอัตโนมัติ ให้คลิกปุ่ม หรือ ลิงก์ แก้ไข จากนั้นคลิกเรียกใช้ในกล่องโต้ตอบ ดาวน์โหลดไฟล์แล้วปฏิบัติตามขั้นตอนในตัวช่วยสร้างแก้ไข




หมายเหตุ

  • ตัวช่วยสร้างนี้อาจมีเฉพาะภาษาอังกฤษ อย่างไรก็ตาม การแก้ไขอัตโนมัติยังสามารถใช้ได้กับ Windows รุ่นภาษาอื่นด้วย

  • หากคุณไม่ได้อยู่กับคอมพิวเตอร์ที่มีปัญหา ให้บันทึกโซลูชันการแก้ไขปัญหาไว้ในแฟลชไดร์ฟหรือแผ่นซีดี แล้วจึงเรียกใช้ในคอมพิวเตอร์ที่มีปัญหา


จากนั้นไปที่ส่วน "วิธีนี้แก้ไขปัญหาได้หรือไม่"



ให้ฉันแก้ไขปัญหาเอง

เมื่อต้องการเปิดใช้งานการแก้ไขด่วนนี้ ให้ปฏิบัติตามขั้นตอนเหล่านี้:

  1. คลิกเริ่มคลิกเรียกใช้ พิมพ์ regedit
    แล้วคลิกตกลง

  2. ใน Registry Editor ให้ค้นหาซับคีย์ต่อไปนี้:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSCRM

  3. ระบุว่ามีรายการรีจิสทรี DWORD ที่ชื่อ AsyncRemoveCompletedWorkflows อยู่หรือไม่ ข้อมูลค่าของรายการรีจิสทรี AsyncRemoveCompletedWorkflows ต้องเป็น 1

  4. ถ้าไม่มีรายการรีจิสทรี AsyncRemoveCompletedWorkflows ให้เพิ่มรายการ เมื่อต้องการเพิ่ม ให้ปฏิบัติตามขั้นตอนเหล่านี้:

    1. คลิกขวาที่MSCRM ชี้ไปที่ใหม่
      คลิก ค่าDWORDแล้วพิมพ์
      AsyncRemoveCompletedWorkflows
      ในกล่องชื่อ

    2. ดับเบิลคลิกที่
      AsyncRemoveCompletedWorkflowsแล้วพิมพ์
      1 ในกล่องข้อมูลค่า

    3. คลิกเริ่ม
      คลิกเรียกใช้ พิมพ์ iisreset
      แล้วคลิกตกลง

      หมายเหตุ ถ้าค่าในกล่องข้อมูลค่าของ AsyncRemoveCompletedWorkflows ค่า DWORD แปลงกลับเป็น 0 Microsoft Dynamics CRM จะยังคงเก็บระเบียนเวิร์กโฟลว์ในฐานข้อมูลแม้ว่างานจะเสร็จสมบูรณ์

หมายเหตุ โปรแกรมแก้ไขด่วนนี้มีไว้เพื่อใช้งานในเชิงรุกเท่านั้น ดังนั้น เมื่อติดตั้งและเปิดใช้งานการแก้ไขด่วน เฉพาะระเบียนเวิร์กโฟลว์ใหม่เท่านั้นที่จะถูกลบโดยอัตโนมัติ ถ้าตาราง AsyncOperationBase และ WorkflowLogBase มีขนาดใหญ่อยู่แล้วเนื่องจากระเบียนเวิร์กโฟลว์เหล่านี้ คุณต้องล้างข้อมูลตารางเหล่านี้โดยใช้สคริปต์การล้างข้อมูล Microsoft SQL Server ที่รวมอยู่ในบทความฐานความรู้ของไมโครซอฟท์ต่อไปนี้:

968520 ประสิทธิภาพการคํานวณจะช้าถ้าตาราง AsyncOperationBase มีขนาดใหญ่เกินไปใน Microsoft Dynamics CRM 4.0

สามารถแก้ไขปัญหาได้หรือไม่

  • ตรวจสอบว่าปัญหานี้ได้รับการแก้ไขหรือไม่ หากแก้ไขปัญหาได้แล้ว คุณไม่ต้องดำเนินการใดๆ กับส่วนนี้อีก หากปัญหายังไม่ได้รับการแก้ไข คุณสามารถ ติดต่อฝ่ายสนับสนุน

  • เราขอขอบคุณที่ให้ข้อเสนอแนะของคุณ เมื่อต้องการให้ข้อคิดเห็นหรือรายงานปัญหาเกี่ยวกับโซลูชันนี้ โปรดใส่ข้อคิดเห็นบน "แก้ไขให้ฉัน" บล็อก หรือส่ง ข้อความอีเมล ถึงเรา

ข้อมูลเพิ่มเติม

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 รายละเอียดเกี่ยวกับศัพท์เฉพาะมาตรฐานที่ใช้เพื่ออธิบายการอัปเดตซอฟต์แวร์ของ Microsoft ดูข้อมูลเพิ่มเติมเกี่ยวกับโปรแกรมแก้ไขด่วนซอฟต์แวร์ Microsoft Business Solutions CRM และอัปเดตศัพท์เฉพาะของแพคเกจ คลิกหมายเลขบทความต่อไปนี้เพื่อดูบทความใน Microsoft Knowledge Base:

887283 การแก้ไขด่วนของซอฟต์แวร์ Microsoft Business Solutions CRM และอัปเดตมาตรฐานการตั้งชื่อแพคเกจ

ต้องการความช่วยเหลือเพิ่มเติมหรือไม่

ต้องการตัวเลือกเพิ่มเติมหรือไม่

สํารวจสิทธิประโยชน์ของการสมัครใช้งาน เรียกดูหลักสูตรการฝึกอบรม เรียนรู้วิธีการรักษาความปลอดภัยอุปกรณ์ของคุณ และอื่นๆ

ชุมชนช่วยให้คุณถามและตอบคําถาม ให้คําติชม และรับฟังจากผู้เชี่ยวชาญที่มีความรู้มากมาย

ข้อมูลนี้เป็นประโยชน์หรือไม่

คุณพึงพอใจกับคุณภาพภาษาเพียงใด
สิ่งที่ส่งผลต่อประสบการณ์ใช้งานของคุณ
เมื่อกดส่ง คำติชมของคุณจะถูกใช้เพื่อปรับปรุงผลิตภัณฑ์และบริการของ Microsoft ผู้ดูแลระบบ IT ของคุณจะสามารถรวบรวมข้อมูลนี้ได้ นโยบายความเป็นส่วนตัว

ขอบคุณสำหรับคำติชมของคุณ!

×