.NET Framework 4.6 Windows 8.1, RT 8.1 Windows ve Windows Server 2012 R2 yüklendikten sonra bilinen güvenlik güncelleştirmeleri 3098779 ve 3097997 ile ilgili bir sorun 4.5.1 ve 4.5.2 .NET Framework için

ÖNEMLİ: Bu makale, Microsoft Makine Çevirisi Düzenleme yazılımı tarafından tercüme edilmiş olup, yüksek olasılıkla profesyonel bir çevirmen yerine CTF teknolojisi kullanılarak, Microsoft Topluluğu tarafından düzenlenmiştir. Microsoft, Bilgi Bankamız içindeki tüm makaleleri kendi dilinizde okuyabilmeniz için size hem profesyonel çevirmenler tarafından tercüme edilen hem de makine tarafından tercüme edildikten sonra Topluluk tarafından kontrol edilen makaleler sunar. Bununla birlikte, makine tarafından tercüme edilen, hatta Topluluk tarafından kontrol edilen bir makale bile her zaman mükemmel dil kalitesinde olmayabilir. Makalede dilinizi konuşan yabancı birisinin yapabileceği türden sözcük, söz dizimi veya dilbilgisi hataları bulunabilir. Microsoft, içeriğin hatalı tercümesinin veya müşterilerimiz tarafından kullanımının doğurabileceği olası yanlış anlamalar, hatalar veya zararlardan sorumlu değildir. Öte yandan Microsoft, Makine Çevirisi Düzenleme işlemini geliştirmek amacıyla Makine Çevirisi Düzenleme yazılımını ve araçlarını sık sık güncelleştirmektedir.

Makalenin İngilizcesi aşağıdaki gibidir: 3118750
Özet
Kimin için .NET Framework 4.6 .NET Framework'ten 4.5.1 veya 4.5.2 yükseltiyorsanız veya bunlar güncelleştirmeleri yükledikten sonra Visual Studio 2015 kimin yüklüyorsanız müşteriler 3098779 ve 3097997 .NET Framework uygulamaları çalıştırıldıklarında, sorunlarla karşılaşabilirsiniz.

Ayrıca, .NET Framework uygulamaları çalıştırıldıklarında, kimin el ile güvenlik güncelleştirmeleri 3098779 ve 3097997 4.5.1 ve 4.5.2 Windows 8.1, RT 8.1 Windows ve Windows Server 2012 R2 üzerinde Microsoft .NET Framework için geçerlidir ve Microsoft olan .NET Framework 4.6 yüklü olan bir sistem kullanan müşterilerin sorunlarla karşılaşabilirsiniz.

Not: 3098779 ve 3097997 güvenlik güncelleştirmeleri için geçerli değildir, çünkü .NET Framework 4.5.1 veya 4.5.2 yüklü olan eski işletim sistemleri bu sorundan etkilenmez.
Belirtiler

Senaryo 1

  • .NET Framework 4.5.1 veya 4.5.2 Windows 8.1, Windows RT 8.1 veya Windows Server 2012 R2 kullanıyorsunuz.
  • .NET Framework 4.5.1 ve 4.5.2 tüm en son güncelleştirmeleri yüklediniz. Bu güncelleştirmeleri içerir 3098779 ve 3097997.
  • Karşıdan yükleyin ve kurun .NET Framework 4.6 veya Microsoft Visual Studio 2015 yükleyin.
Bu senaryoda, .NET Framework 4.6 bazı bileşenlerinin beklendiği şekilde yükseltilmiyor veya bazı .NET Framework uygulamaları başlatılmaz veya düzgün çalışmıyor.

Senaryo 2

  • .NET Framework 4.6 Windows 8.1, Windows RT 8.1 veya Windows Server 2012 R2 kullanıyorsunuz.
  • Güncelleştirmeleri el ile uygulayın 3098779 ve 3097997 veya .NET Framework 4.5.1 ve 4.5.2 amacı, bu güncelleştirmeler olsa da, .NET Framework 4.6 için hedeflenmemiş güncelleştirme.

    NotBu desteklenmeyen bir senaryodur. Microsoft .NET Framework güncelleştirmesi için doğru uygulama belirleme hakkında daha fazla bilgi için bkz: Microsoft Bilgi Bankası makalesi 3136092.
Bu senaryoda, bazı .NET Framework uygulamaları başlatılmaz veya düzgün çalışmıyor.
Çözüm

Senaryo 1 için çözüm

Müşteriler, bu sorunları aşağıdaki Microsoft Download Center Web sitelerinden gelen .NET Framework 4.6.1 yükselterek çözebilirsiniz:

Alternatif olarak, müşteriler için .NET Framework 4.6 sistemlerini yükselttikten veya Visual Studio 2015 3098779 ve 3097997 yüklü güncelleştirmeleri içeren bir tam olarak güncelleştirilmiş .NET 4.5.1 veya 4.5.2 sisteminden yüklediğiniz güncelleştirmeleri 3098779 ve 3097997 kaldırabilirsiniz.

Müşteriler sonra Windows Update'i yeniden taramak ve güncelleştirmeleri karşıdan yükleyip 3098785 ve 3098000. Bunlar karşılık gelen Microsoft Güvenlik Bülteni MS15-118 .NET Framework 4.6 Windows 8.1, Windows RT 8.1 veya Windows Server 2012 R2 için güncelleştirmeler. Bu eylem, sürüm uyuşmazlığı düzeltecektir.

Senaryo 2 için çözüm

.NET Framework 4.6 yüklü olduğu sistemlerde 3098779 ve 3097997 güncelleştirmeleri el ile uygulamanız müşteriler bunun desteklenen bir senaryo olmadığını bilmelisiniz. Bu güncelleştirmeler için .NET Framework 4.6 uygulanmaz.

Bu nedenle, .NET Framework 4.6 kullanan müşteriler 3098779 ve 3097997 güncelleştirmelerini kaldırmanız gerekir. Müşteriler Windows Update yeniden taramak ve .NET Framework 4.6 için uygulanan güncelleştirmeleri yüklemeniz gerekir. Bu eylem, sürüm uyuşmazlığı düzeltecektir.

Benzer şekilde, 4.5.1 veya 4.5.2 .NET kullanan müşterilerin sistemlerinde yüklü tüm .NET Framework sürümü için geçerli olan herhangi bir güncelleştirme olduğundan emin olmanız gerekir. Örneğin, .NET Framework 4.6 için tasarlanmış güncelleştirmeler 4.5.1 veya 4.5.2 yüklü .NET sistemlerine uygulanmamalıdır. Nasıl hakkında daha fazla bilgi için doğru uygulama seeMicrosoftKnowledge Bankası makalesi 4.6 ve 4.6.1 Microsoft olan .NET Framework güncelleştirmeleri belirlemek. 3136092.
Durum
Microsoft bu sorunun "Aşağıdakilere Uygulanır" bölümünde listelenen Microsoft ürünlerinde bulunduğunu onaylamıştır.

Şunun için geçerlidir:

Bu makale şunlar için geçerlidir:

  • Microsoft olan .NET Framework ile birlikte kullanıldığında 4.6:

    • Windows Server 2012 R2
    • Windows 8.1
    • Windows RT 8.1
  • Microsoft .NET Framework ile birlikte kullanıldığında 4.5.2:

    • Windows Server 2012 R2
    • Windows 8.1
    • Windows RT 8.1
  • Microsoft .NET Framework ile birlikte kullanıldığında 4.5.1:

    • Windows Server 2012 R2
    • Windows 8.1
    • Windows RT 8.1

Uyarı: Bu makalenin çevirisi otomatik olarak yapılmıştır

Özellikler

Makale No: 3118750 - Son İnceleme: 01/15/2016 09:46:00 - Düzeltme: 4.0

Microsoft .NET Framework 4.6, Microsoft .NET Framework 4.5.2, Microsoft .NET Framework 4.5.1

  • atdownload kbbug kbexpertiseinter kbfix kbsecbulletin kbsecurity kbsecvulnerability kbmt KB3118750 KbMttr
Geri bildirim