İNDİS işlevi, tablo veya aralığın içindeki bir değeri veya değerin başvurusunu döndürür.

Tarayıcınız video desteklemiyor. Microsoft Silverlight, Adobe Flash Player veya Internet Explorer 9’u yükleyin.

İNDİS işlevini kullanmanın iki yolu vardır:

  • Belirli bir hücre veya hücre dizisinin değerini döndürmek için Dizi biçimi konusuna bakın.

  • Belirli hücrelere başvuru döndürmek istiyorsanız Başvuru formu konusuna bakın.

Dizi biçimi

Açıklama

Tabloda veya dizide bulunan öğenin değerini, satır ve sütun sayısı indisleriyle seçerek verir.

İNDİS işlevinin birinci bağımsız değişkeni bir dizi sabitiyse, dizi biçimini kullanın.

Söz dizimi

İNDİS(dizi, satır_sayısı, [sütun_sayısı])

İNDİS işlevinin dizi biçiminde aşağıdaki bağımsız değişkenler bulunur:

  • dizi Gerekli. Bir hücre aralığı veya dizi sabitidir.

    • Dizi yalnızca tek bir satır veya sütun içeriyorsa, ilgili satır_sayısı veya sütun_sayısı bağımsız değişkeni isteğe bağlıdır.

    • Dizinin birden çok satırı ve birden çok sütunu varsa ve satır_sayısı ve sütun_sayısı bağımsız değişkenlerinden yalnızca biri kullanılırsa, İNDİS işlevi dizideki tüm satır veya sütuna ilişkin bir dizi verir.

  • satır_sayısı    sütun_sayısı olmadığı sürece gereklidir. Dizinin içinden değeri verilecek satırı seçer. satır_sayısı belirtilmezse, sütun_sayısı gereklidir.

  • sütun_sayısı    İsteğe bağlı. Dizinin içinden değeri verilecek sütunu seçer. sütun_sayısı belirtilmezse, satır_sayısı gereklidir.

Açıklamalar

  • satır_sayısı ve sütun_sayısı bağımsız değişkenlerinin ikisi de kullanılırsa İNDİS işlevi, satır_sayısı ve sütun_sayısı bağımsız değişkenlerinin kesişimindeki hücrenin değerini verir.

  • satır_sayısı ve sütun_sayısı dizideki bir hücreyi göstermelidir, tersi durumda İNDİS işlevi #BAŞV! hata değerini verir. hatası oluşur.

  • satır_sayısı veya sütun sayısı değerini 0 (sıfır) olarak belirtirseniz, İNDİS sırasıyla tüm sütuna veya satıra ilişkin değerlerin dizisini verir. Dizi olarak döndürülen değerleri kullanmak için İNDİS işlevini dizi formülü olarak girin.

    Not: Güncel bir Microsoft 365 sürümünüz varsa formülü doğrudan çıkış aralığının sol üst hücresine girebilir ve sonra ENTER tuşuna basarak formülün bir dinamik dizi formülü olduğunu onaylayabilirsiniz. Aksi takdirde, öncelikle çıkış aralığı seçilip çıkış aralığının sol üst hücresine formül girilerek ve sonra bunu doğrulamak için CTRL+SHIFT+ENTER tuşlarına basılarak formülün bir eski dizi formülü olarak girilmesi gerekir. Excel sizin için formülün başına ve sonuna küme ayraçları ekler. Dizi formülleri hakkında daha fazla bilgi için bkz. Dizi formülleriyle ilgili yönergeler ve örnekler.

Örnekler

Örnek 1

Bu örneklerde, bir satır ve sütunun buluştuğu kesişen hücredeki değeri bulmak için İNDİS işlevi kullanılmaktadır.

Aşağıdaki tabloda yer alan örnek verileri kopyalayın ve yeni bir Excel çalışma sayfasının A1 hücresine yapıştırın. Formüllerin sonuçları göstermesi için, bunları seçin, F2 tuşuna ve sonra da Enter tuşuna basın.

Veri

Veriler

Elma

Limon

Muz

Armut

Formül

Açıklama

Sonuç

=İNDİS(A2:B3,2,2)

Aralıktaki ikinci satırın ve ikinci sütunun kesişimindeki değer A2:B3.

Armutlar

=İNDİS(A2:B3,2,1)

Aralıktaki ikinci satırın ve birinci sütunun kesişimindeki değer A2:B3.

Muzlar

Örnek 2

Bu örnekte, 2x2 dizisinde belirtilen iki hücredeki değerleri bulmak için bir dizi formülü içinde İNDİS işlevi kullanılmaktadır.  

Not: Güncel bir Microsoft 365 sürümünüz varsa formülü doğrudan çıkış aralığının sol üst hücresine girebilir ve sonra ENTER tuşuna basarak formülün bir dinamik dizi formülü olduğunu onaylayabilirsiniz. Aksi takdirde, öncelikle iki boş hücre seçilip çıkış aralığının sol üst hücresine formül girilerek ve sonra bunu doğrulamak için CTRL+SHIFT+ENTER tuşlarına basılarak formülün bir eski dizi formülü olarak girilmesi gerekir. Excel sizin için formülün başına ve sonuna küme ayraçları ekler. Dizi formülleri hakkında daha fazla bilgi için bkz. Dizi formülleriyle ilgili yönergeler ve örnekler.

Formül

Açıklama

Sonuç

=İNDİS({1,2;3,4},0,2)

Dizide ilk satırdaki ikinci sütunda bulunan değer. Dizi; ilk satırda 1 ve 2'yi, ikinci satırda 3 ve 4'ü içerir.

2

İkinci satırda bulunan değeri ikinci sütundaki bir dizi (yukarıdaki gibi aynı dizi).

4

Sayfanın Başı


Başvuru biçimi

Açıklama

Belirli bir satır ve sütunun kesişimindeki hücrenin başvurusunu verir. Başvuru bitişik olmayan seçimlerden oluşuyorsa, araştırılacak olan seçimi alabilirsiniz.

Söz dizimi

İNDİS(başvuru, satır_sayısı, [sütun_sayısı], [alan_sayısı])

İNDİS işlevinin başvuru biçiminde aşağıdaki bağımsız değişkenler bulunur:

  • başvuru    Gerekli. Bir ya da daha fazla hücre aralığına bir başvurudur.

    • Başvuru için bitişik olmayan bir aralık giriyorsanız, başvuruyu ayraç içine alın.

    • Başvurudaki her alan yalnızca bir satır ya da sütun içeriyorsa, satır_sayısı ya da sütun_sayısı bağımsız değişkeni isteğe bağlıdır. Örneğin, tek bir satır başvurusu için, İNDİS(başv; sütun_sayısı) işlevini kullanın.

  • satır_sayısı    Gerekli. İçinden bir başvuru verilecek olan başvurudaki satırın sayısıdır.

  • sütun_sayısı    İsteğe bağlı. İçinden bir başvuru verilecek olan başvurudaki sütunun sayısıdır.

  • alan_sayısı    İsteğe bağlı. Başvuruda, satır_sayısı ile sütun_sayısı değerlerinin kesişiminin döndürüleceği bir aralık seçer. Seçilen ya da girilen ilk alana 1 numarası verilir, ikinci alan 2 olur, vb. alan_sayısı belirtilmezse, İNDİS 1. alanı kullanır.  Burada listelenen alanların tümü tek sayfada yer almalıdır.  Hepsi aynı sayfada olmayan alanlar belirtirseniz, bu durum #DEĞER! hatasının döndürülmesine neden olur.  Birbirinden farklı sayfalarda yer alan aralıklar kullanmanız gerekiyorsa, İNDİS işlevinin dizi biçimini kullanmanız ve diziyi oluşturan aralığı hesaplamak için başka bir işlevi kullanmanız önerilir.  Örneğin, hangi aralığın kullanılacağını hesaplamak için ELEMAN işlevini kullanabilirsiniz.

Örneğin, Başvuru (A1:B4;D1:E4;G1:H4) hücrelerini tanımlıyorsa alan_sayısı 1 A1:B4 aralığına; alan_sayısı 2 D1:E4 aralığına ve alan_sayısı 3 G1:H4 aralığına karşılık gelir.

Açıklamalar

  • Başvuru ve alan_sayısı belirli bir aralığı seçtikten sonra, satır_sayısı ve sütun_sayısı belirli bir hücre seçer: satır_sayısı 1, aralıktaki ilk satırdır; sütun_sayısı 1 ilk sütundur vb. İNDİS işlevinin verdiği başvuru, satır_sayısı ve sütun_sayısı değerlerinin kesişimidir.

  • satır_sayısı ya da sütun_sayısı değerini sıfır (0) olarak ayarlarsanız, İNDİS işlevi sırasıyla tüm sütun ya da tüm satırın başvurusunu verir.

  • satır_sayısı, sütun_sayısı ve alan_sayısı başvuru içindeki bir hücreye işaret etmelidir; aksi halde, İNDİS işlevi #BAŞV! hata değerini verir. hatası oluşur. satır_sayısı ve sütun_sayısı belirtilmezse İNDİS işlevi, alan_sayısı ile belirtilen başvurudaki alanı verir.

  • İNDİS işlevinin sonucu bir başvurudur ve başka formüller tarafından başvuru olarak yorumlanır. Formüle bağlı olarak, İNDİS işlevinin sonuç değeri bir başvuru ya da bir değer olarak kullanılabilir. Örneğin, HÜCRE("en";İNDİS(A1:B2;1;2)) formülü, HÜCRE("en";B1) formülünün eşdeğeridir. HÜCRE işlevi, İNDİS işlevinin sonuç değerini bir hücre başvurusu olarak kullanır. Öte yandan, 2*İNDİS(A1:B2;1;2) gibi bir formül İNDİS işlevinin sonuç değerini B1 hücresindeki sayıya çevirir.

Örnekler

Aşağıdaki tabloda yer alan örnek verileri kopyalayın ve yeni bir Excel çalışma sayfasının A1 hücresine yapıştırın. Formüllerin sonuçları göstermesi için, bunları seçip F2 tuşuna basın ve sonra Enter tuşuna basın.

Meyve

Fiyat

Sayı

Elma

0,69 TL

40

Muz

0,34 TL

38

Limon

0,55 TL

15

Portakal

0,25 TL

25

Armut

0,59 TL

40

Badem

2,80 TL

10

Mahun

3,55 TL

16

Fıstık

1,25 TL

20

Ceviz

1,75 TL

12

Formül

Açıklama

Sonuç

=İNDİS(A2:C6, 2, 3)

A2:C6 aralığında, ikinci sıranın ve üçüncü sütunun C3 hücresinin içeriğini oluşturan kesişimi.

38

=İNDİS((A1:C6, A8:C11), 2, 2, 2)

A8:C11'in ikinci alanında, ikinci satır ve ikinci sütunun B9 hücresinin içeriğini oluşturan kesişimi.

1,25

=TOPLA(İNDİS(A1:C11, 0, 3, 1))

A1:C11 aralığının birinci alanındaki üçüncü sütunun C1:C11'nın toplamına karşılık gelen toplamı.

216

=TOPLA(B2:İNDİS(A2:C6, 5, 2))

B2'de başlayan ve A2:A6 aralığının beşinci sırasının ve ikinci sütununun kesişiminde sona eren aralığın B2:B6'nın toplamına karşılık gelen toplamı.

2,42

Sayfanın Başı

Ayrıca Bkz:

DÜŞEYARA işlevi

KAÇINCI işlevi

DOLAYLI işlevi

Dizi formülleriyle ilgili yönerge ve örnekler

Arama ve başvuru işlevleri (başvuru)

Daha fazla yardıma mı ihtiyacınız var?

Yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Insider'Microsoft Office katılın

Bu bilgi yararlı oldu mu?

Dil kalitesinden ne kadar memnunsunuz?
Deneyiminizi ne etkiledi?

Geri bildiriminiz için teşekkürler!

×