Bir sayıyı istediğiniz ondalık basamak sayısına yuvarlama

Bir sayıyı istediğiniz ondalık basamak sayısına yuvarlama

Hücrelerde ###### simgelerinin görünmesine neden olduğu için gereksiz ondalık basamaklar istemiyorsanız veya mikrokolojik düzeyden doğru doğru bir doğruluk gerekliliği yoksa, istediğiniz ondalık basamak sayısını elde etmek için hücre biçimini değiştirebilirsiniz.

S numarayı en yakın ana birime yuvarlama

S numarayı en yakın ana üniteye (binler, yüzler, onlar veya tekrarlar gibi) yuvarlamak için formülde bir işlev kullanın, şu adımları izleyin:

Düğme kullanarak:

  1. Biçimlendirmek istediğiniz hücreleri seçin.

  2. Giriş sekmesinde, ondalık ayırıcıdan sonra daha fazla veya daha az basamak göstermek için Ondalık Artır veya Ondalık Azalt'a tıklayın.

Yerleşik bir sayı biçimi uygulayarak:

  1. Giriş sekmesindeki Sayı grubunda, sayı biçimleri listesinin yanındaki oku ve ardından Tüm Sayı Biçimleri'ni tıklatın.

Giriş sekmesindeki Sayı grubu

  1. Kategori listesinde, sahip bulunduğunuz verilerin türüne bağlı olarak Para Birimi ,Finansal ,Yüzde veyaBilimsel 'e tıklayın.

  2. Ondalık basamak sayısı kutusuna, görüntülenmesini istediğiniz ondalık basamak sayısını girin.

Formülde işlev kullanarak:

YUVARLA işlevini kullanarak sladırı istediğiniz basamak sayısına yuvarlayın. Bu işlevin yalnızca iki bağımsız değişkeni vardır (bağımsız değişkenler formülün çalışması için gereken veri parçalarıdır).

  • İlk bağımsız değişken yuvarlamak istediğiniz sayıdır; bu bir hücre başvurusu veya sayı olabilir.

  • İkinci bağımsız değişken, sddeyi yuvarlamak istediğiniz basamak sayısıdır.

A1 hücresinde 823,7825 olduğunu varsayalım. S numarayı en yakın sayıya yuvarlamak için:

  • Bin s

    • =YUVARLA(A1,-3) yazın ve 1,00 0'aeşittir

    • 823,7825, 0'dan 1.000'e daha yakın (0, 1.000'in katlarıdır)

    • Burada negatif bir sayı kullanın, çünkü yuvarlamanın ondalık virgülden solunda olmasını istediğinizden. Aynı şey yüzlerce ve onlara yuvarlanan sonraki iki formül için de geçerlidir.

  • Yüzlerce

    • =YUVARLA(A1,-2) ve 800'e eşit yazın

    • 800, 823,7825'e 900'e yakın. Fikri şu anda an an an almakta olduğunu düşünüyoruz.

  • Onlar

    • =YUVARLA(A1,-1) eşittir 820 yazın

  • Bire bir

    • =YUVARLA(A1,0) eşittir 824 yazın

    • S numarayı en yakın tek haneye yuvarlamak için sıfır kullanın.

  • Onuncu

    • =YUVARLA(A1,1) eşittir 823,8 yazın

    • Burada, sayıyı belirttiğiniz ondalık basamak sayısına yuvarlamak için pozitif bir sayı kullanın. Aynı şey yüzlere ve binlere yuvarlanan sonraki iki formül için de geçerlidir.

  • 100.000

    • =YUVARLA(A1,2) eşittir 823,78 yazın

  • Binler

    • Tür = YUVARLA(A1,3) eşittir 823,783

AİYARA işlevini kullanarak sladırı yukarı yuvarlar. YUVARLA ile aynı şekilde çalışır, ancak slaydı her zaman yukarı yuvarlar. Örneğin, 3,2'ye ondalık basamak olacak şekilde yukarı yuvarlamak istiyorsanız:

  • =AİYARA(3,2;0) eşittir 4

AYIRLA işlevini kullanarak sladırı aşağı yuvarlar. YUVARLA ile aynı şekilde çalışır, ancak slaydı her zaman aşağı yuvarlar. Örneğin, 3,14159'ü üç ondalık basamağa yuvarlamak istiyorsanız:

  • =ARITMA(3,14159,3) eşittir 3,141

İpucu:  Daha fazla örnek almak ve bir çalışma kitabında örnek verilerle Excel Online için YUVARLA ,AYIYSA VE AYIRLA makalesine bakın.

  1. Boş bir hücreye tıklayın.

  2. Formüller sekmesindeki İşlev'in altında Formül Oluşturucu'ya tıklayın.

  3. Aşağıdakilerden birini yapın:

    Kullanım amacı

    Formül Oluşturucu'da,

    Bağımsız Değişkenler'in altında

    Sayıyı yukarı yuvarlama

    ROUNDUP

    Sayı kutusuna,yukarı yuvarlamak istediğiniz sladırı yazın. En num_digits, sladırı en yakın tamsayıya yukarı yuvarlamak için 0 yazın.

    Sayıyı aşağı yuvarlama

    ARITMA

    Sayı kutusuna,aşağı doğru yuvarlamak istediğiniz sladırı yazın. En num_digits, sladırı en yakın tamsayıya yukarı yuvarlamak için 0 yazın.

    Yukarı doğru bir sayıya yuvarlama

    EVEN

    Sayı kutusuna,yuvarlanacak sladırı yazın.

    Yukarı doğru tek bir sayıya yuvarlama

    TEK

    Sayı kutusuna,yuvarlanacak sladırı yazın.

    S numarayı, başka bir say ın en yakın 4'lerine yuvarlama

    KAMERUN

    Birden çok öğesinin yanındaki kutuyatıklayın ve ardından en yakın 500 kat için istediğiniz numarayı yazın.

  4. RETURN tuşuna basın.

Excel Seçenekleri'de sayılar için varsayılan bir ondalık ayırıcı belirtebilirsiniz.

  1. Seçenekler'e (Excel 2010'dan Excel 2016'ya) veya Excel Seçenekleri' düğme resmi > (Excel 2007) Microsoft Office Düğmesi'ne tıklayın.

  2. Gelişmiş kategorisindeki Düzenleme seçenekleri'nin altındaOndalık ayırıcıyı otomatik olarak ekle onay kutusunu seçin.

  3. Basamaklar kutusunda, ondalık noktasının sağındaki basamaklar için pozitif bir sayı girin ya da ondalık noktasının solundaki basamaklar için negatif bir sayı girin.

    Not: Örneğin, Yerler kutusuna 3 girer ve daha sonra hücreye 2834 girersiniz, değer 2,834 olur. Yerler kutusuna -3girer ve daha sonra hücreye 283 girersiniz, değer 283000 olur.

  4. Tamam'a tıklayın.

    Durum çubuğunda Sabit ondalık göstergesi görünür.

  5. Çalışma sayfasında, bir hücreyi tıklatın ve istediğiniz sladırı yazın.

    Not: Sabit ondalık onay kutusunu seçtikten önce yazarak verilerinizi etkilenmez.

  • Sabit ondalık seçeneğini geçici olarak geçersiz kılmak için, sayıyı yazarken bir ondalık virgül yazın.

  • Sabit onluklarla önceden girdiğiniz sayılardan ondalık basamakları kaldırmak için, şunları yapın:

    1. Seçenekler'e (Excel 2010'dan Excel 2016'ya) veya Excel Seçenekleri' düğme resmi > (Excel 2007) Microsoft Office Düğmesi'ne tıklayın.

    2. Gelişmiş kategorisindeki Düzenleme seçenekleri'nin altındaOtomatik olarak ondalık ayırıcı ekle onay kutusunu temizleyin.

    3. Boş bir hücreye, kaldırmak istediğiniz ondalıkbasamak sayısına bağlı olarak 10 , 100 veya 1000gibi bir sayı yazın.

      Örneğin, sayıların iki ondalık basamak içermesi ve bunları tam sayılara dönüştürmek istediğiniz varsa, hücreye 100 yazın.

    4. Giriş sekmesinin Pano grubunda Metni Kopyala'ya tıklayın düğme görüntüsü CTRL+C tuşlarına basın.

    5. Çalışma sayfasında, değiştirmek istediğiniz ondalık basamakları olan sayıları içeren hücreleri seçin.

    6. Giriş sekmesinin Pano grubunda Yapıştır'ın yanındaki oku tıklatın ve sonra da Özel Yapıştır'ı tıklatın.

    7. Özel Yapıştır iletişim kutusundaki İşlem'in altında Çarp'a tıklayın.

Daha fazla yardım mı gerekiyor?

Sorularınızı Excel Teknoloji Topluluğu’ndaki uzmanlara sorabilir, Yanıt topluluğu’ndan destek alabilir ya da Excel için UserVoice platformuna yeni bir özellik veya iyileştirme önerisi sunabilirsiniz.

Ayrıca Bkz:

Slanı yuvarlama

Bir sayı neden yuvarlanmış olarak görünüyor?

Daha fazla yardıma mı ihtiyacınız var?

Office yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

Görüşleriniz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×