İpucu: DÜŞEYARA'nın herhangi bir yönde çalışan ve varsayılan olarak tam eşleşmeleri döndüren geliştirilmiş bir sürümü olan ve öncül sürümünden daha kolay ve kullanışlı olan yeni DÜŞEYARA işlevini kullanmayı deneyin.

Bir tablo veya aralıkta satıra göre şeyler bulmaniz gerekirken DÜŞEYARA işlevini kullanın. Örneğin, parça numarasına göre bir otomobil parçasının fiyatını bulabilir veya çalışan kimliğine göre çalışan adını bulabilirsiniz.

En basit biçimiyle, DÜŞEYARA işlevi şunu söyler:

=DÜŞEYARA(Ne görmek istediğiniz, nerede arama yapmak istediğiniz, aralıkta sonuç olarak değeri içeren sütun numarası, 1/DOĞRU veya 0/YANLIŞ olarak gösterilen Yaklaşık veya Tam eşleşme verir).

Tarayıcınız video desteklemiyor.

İpucu: DÜŞEYARA'nın sırrı, verilerinizi düzenlemektir; böylece, size gereken değer (Meyve) bulmak istediğiniz dönüş değerinin (Tutar) sol tarafından gelir.

Tabloda bir değeri aramak için DÜŞEYARA işlevini kullanın.

Söz dizimi 

DÜŞEYARA(aranan_değer, tablo_dizisi, sütun_indis_sayısı, [aralık_bak])

Örneğin:

  • =DÜŞEYARA(A2,A10:C20,2,DOĞRU)

  • =DÜŞEYARA("Fontana",B2:E7,2,YANLIŞ)

  • =DÜŞEYARA(A2,'İstemci Ayrıntıları'! A:F,3,YANLIŞ)

Bağımsız değişken adı

Açıklama

aranan_değer    (gerekli)

Aramak istediğiniz değer. Arama yapmak istediğiniz değer, bağımsız değişkende belirttiğiniz hücre aralığının ilk sütununda yer table_array gerekir.

Örneğin, tablo-dizi B2:D7 hücrelerine yayılmışsa, lookup_value B sütununda yer alıyor olabilir.

Lookup_value değer veya bir hücreye başvuru olabilir.

tablo_dizisi    (gerekli)

DÜŞEYARA işlevinin aranan_değeri ve dönüş değerini bulmak için arama yapacağı hücre aralığı. Adlandırılmış aralık veya tablo kullanabilir ve bağımsız değişkende hücre başvuruları yerine adları kullanabilirsiniz. 

Hücre aralığındaki ilk sütun ilk sütununsütun lookup_value. Hücre aralığı, bulmak istediğiniz dönüş değerini de içermeli.

Çalışma sayfasında aralıkları seçmeyi öğrenin.

sütun_indis_sayısı    (gerekli)

Dönüş değerini içeren sütun numarası (en sol sütun için 1 table_array ile başlayarak).

aralık_bak    (isteğe bağlı)

DÜŞEYARA işlevinin yaklaşık eşleşme mi yoksa tam eşleşme mi bulmasını istediğinizi belirten mantıksal değer:

  • Yaklaşık eşleşme - 1/DOĞRU, tablodaki ilk sütunun sayısal veya alfabetik olarak sıra olduğunu varsayarak en yakın değeri aratır. Yöntem belirtmezseniz, varsayılan yöntem olarak bu kullanılır. Örneğin, =DÜŞEYARA(90,A1:B100,2,DOĞRU).

  • Tam eşleşme - 0/YANLIŞ, ilk sütunda tam değeri arar. Örneğin, =DÜŞEYARA("Demir",A1:B100,2,YANLIŞ).

Nasıl başlanır

DÜŞEYARA söz dizimini oluşturmak için dört ayrı bilgiye ihtiyacınız vardır:

  1. Arama değeri olarak da adlandırılan, aramak istediğiniz değer.

  2. Arama değerinin yer aldığı aralık. DÜŞEYARA işlevinin düzgün çalışması için, arama değeri her zaman aralıktaki ilk sütunda olmalıdır. Örneğin, arama değeriniz C2 hücresindeyse aralığınız C ile başlamalıdır.

  3. Aralıkta, dönüş değerini içeren sütunun numarası. Örneğin, aralık olarak B2:D11 belirtirsanız, B'yi ilk sütun, C'yi ikinci sütun olarak saymalı ve bu şekilde devam gerekir.

  4. İsteğe bağlı olarak, dönüş değerine yönelik yaklaşık bir eşleşme elde etmek için DOĞRU, tam eşleşme elde etmek için YANLIŞ değerini belirtebilirsiniz. Hiçbir şey belirtmezseniz, varsayılan değer her zaman için DOĞRU veya yaklaşık eşleşme olur.

Yukarıda açıklananları şu şekilde toparlayabiliriz:

=DÜŞEYARA(arama değeri, arama değerini içeren aralık, aralıkta dönüş değerini içeren sütun numarası, Yaklaşık eşleşme (DOĞRU) veya Tam eşleşme (YANLIŞ)).

Örnekler

DÜŞEYARA işlevinin bazı örnekleri:

Örnek 1

=DÜŞEYARA (B3,B2:E7,2,YANLIŞ)

DÜŞEYARA, B2:E7 sütunun ilk sütununda (B sütunu) Fontana'yı table_array, sütunun ikinci sütunundan (C sütunu) Olivier'i table_array.  False tam eşleşmeyi döndürür.

Örnek 2

=DÜŞEYARA (102,A2:C7,2,YANLIŞ)

DÜŞEYARA, A2:C7 aralığındaki ikinci sütunda (B sütunu) 102 (lookup_value) için soyadın tam eşleşmeyi (YANLIŞ) olarak görüntüler ve Fontana'yı döndürür.

Örnek 3

=EĞER(DÜŞEYARA(103,A1:E7,2,YANLIŞ)="Souse","Bulunan","Bulunamadı")

EĞER IŞLEVI, DÜŞEYARA'nın A1:E7'de (üç ay) 103'e (lookup_value) döndüren çalışanın soyadı olarak Sousa'yı döndürüp döndürüp döndür table_array. 103'e karşılık gelen soyadı Leal olduğundan, EĞER koşulu yanlış ve Bulunamadı görüntülenir.

Örnek 4

=TİPİ(YIRAC(TARIH(2014,6,30),DÜŞEYARA(105,A2:E7,5,FLASE),1))

DÜŞEYARA, A2:E7 aralığında (lookup_value) 109'a (lookup_value) karşılık gelen çalışanın doğum tarihini table_array) ve 04.03.1955'i döndürür. Ardından, YEARFRAC bu doğum tarihini 6/2014/30'dan çıkarır ve tam sayı 59'a dönüştürülen bir değer döndürür.

Örnek 5

EĞER(EYM(DÜŞEYARA(105,A2:E7,2,FLASE))=DOĞRU,"Çalışan bulunamadı",DÜŞEYARA(105,A2:E7,2,YANLIŞ))

EĞER işlevi DÜŞEYARA işlevinin B sütunundaki soyadı için 105 (GÜN) değeri döndürüp döndür lookup_value. DÜŞEYARA soyadı bulursa EĞER soyadı görüntülenir, aksi halde EĞER işlevi Çalışan bulunamadı adını döndürür. EYMİ, DÜŞEYARA işlevi #N/A döndürürse, hatanın yerini Çalışan bulunamadı/A#N alır.



Bu örnekte dönüş değeri, 105'e karşılık gelen soyadı olan Burke'tir.

Tablolardan birinin diğerleriyle ortak alanları olduğu sürece birden çok tabloyla birden çok tablo arasında ortak bir alan olduğu sürece, DÜŞEYARA'nın kullanabilirsiniz. Bu özellik, birden çok tabloyla veri kaynağı olarak veri özelliklerini desteklemeen Excel'in daha eski sürümlerine sahip kullanıcılarla çalışma kitabı paylaşmanız gerekirse, bu çalışma kitabını tek bir tabloda bir araya getiren ve veri özelliğinin veri kaynağını yeni tabloyla değiştirerek, bu özellik daha eski Excel sürümlerinde kullanılabilir (veri özelliğinin kendisinin eski sürüm tarafından destek olması sağlanmıştır).

Diğer tablolardan veri almak için DÜŞEYARA'nın sütunlarını içeren çalışma sayfası

Burada, A-F ve H sütunlarında yalnızca çalışma sayfasındaki değerleri kullanan değerler veya formüller vardır ve sütunların kalanlarında DÜŞEYARA ve diğer tablolardan veri almak için A sütunu (İstemci Kodu) ve B sütunu (Avukat) değerleri kullanılır.

  1. Ortak alanları olan tabloyu yeni bir çalışma sayfasına kopyalayın ve bir ad girin.

  2. İlişkileri Yönet > için veri > Araçları Ve İlişkiler'i tıklatın.

    İlişkileri Yönet iletişim kutusu
  3. Listelenen her ilişki için aşağıdakilere dikkat edin:

    • Tabloları (iletişim kutusunda parantez içinde listelenmiş) bağlar alan. DÜŞEYARA lookup_value en uygun formül burasıdır.

    • İlgili Arama Tablosu adı. DÜŞEYARA table_array formülde bu bir hatadır.

    • İlişkili Arama Tablosunda yeni sütunda istediğiniz verileri içeren alan (sütun). Bu bilgiler İlişkileri Yönet iletişim kutusunda gösterilmez; almak istediğiniz alanı görmek için İlişkili Arama Tablosu'nda aramaniz gerekir. Sütun numarasını (A=1) not almak istiyor, ancak formül col_index_num sayısıdır.

  4. Yeni tabloya alan eklemek için, 3. adımda toplanmış bilgileri kullanarak DÜŞEYARA formülünü ilk boş sütuna girin.

    Örneğimizde, G sütunundaki G sütununda, =DÜŞEYARA([@Attorney],tbl_Attorneys,4,YANLIŞ) formülü ile birlikte, Avukatlık çalışma sayfası tablosundan (table_array col_index_num= 4) Fatura Oranı verilerini almak için Avukat (lookup_value ) kullanılır.

    Formül bir hücre başvurusu ve aralık başvurusu da kullanabilir. Örneğimizde, =DÜŞEYARA(A2,'Avukatlar'! A:D,4,YANLIŞ).

  5. Size gereken tüm alanları ekleyene kadar alanları eklemeye devam edersiniz. Birden çok tablo kullanan veri özellikleri içeren bir çalışma kitabını hazırlamaya çalışıyorsanız, veri özelliğinin veri kaynağını yeni tabloyla değiştirebilirsiniz.

Sorun

Nerede sorun çıktı?

Yanlış değer verdi

Aralık_bak değeri DOĞRU ise veya boş bırakılmışsa, ilk sütunun alfabetik veya sayısal olarak sıralanması gerekir. İlk sütun sıralanmamışsa, verilen değer beklenmedik bir şey olabilir. İlk sütunu sıralayın veya tam eşleşme için YANLIŞ değerini kullanın.

Hücrede #YOK değeri

  • Aralık_bak değeri DOĞRU ise, aranan_değer bağımsız değişkenindeki değer tablo_dizisi’nin ilk sütunundaki en küçük değerden daha küçük olduğunda #YOK hata değerini alırsınız.

  • Aralık_bak YANLIŞ ise, #YOK hata değeri tam sayının bulunamadığını gösterir.

DÜŞEYARA işlevindeki #YOK hatalarını düzeltme hakkında daha fazla bilgi için bkz. DÜŞEYARA işlevindeki #YOK hatasını düzeltme.

Hücrede #BAŞV! değeri

Sütun_indis_sayısı değeri tablo-dizisi içindeki sütunların sayısından büyükse, #BAŞV! hata değerini alırsınız.

Sorunları çözme hakkında daha fazla #REF! hatalarını görmek için bkz. #REF düzeltme.

Hücrede #DEĞER! değeri

Tablo_dizisi 1’den küçükse, #DEĞER! hata değerini alırsınız.

Sorunları çözme hakkında daha fazla #VALUE! hatalarını görmek için bkz. DÜŞEYARA işlevinde #VALUE! hatasını düzeltme.

Hücrede #AD? değeri

#AD? hata değeri, çoğunlukla formülde tırnak işaretlerinin eksik olduğu anlamına gelir. Bir kişinin adını aramak için, formüldeki adda tırnak işaretlerini kullandığınızdan emin olun. Örneğin, =DÜŞEYARA("Fontana",B2:E7,2,YANLIŞ) içinde adı "Fontana" olarak girin.

Daha fazla bilgi için bkz. Hata #NAME düzeltme.

Excel’de #SPILL! var

Bu özel #SPILL! hatası genellikle formül ifadenizin arama değerinin örtülü kesişimini kullanıyor olduğu ve başvuru olarak sütunun tamamını kullanıyor olduğu anlamına gelir. Örneğin, =DÜŞEYARA(A:A,A:C,2,YANLIŞ). Arama başvurularını @ işlecine şu şekilde sabitlersiniz:=DÜŞEYARA( @A:A,A:C,2,YANLIŞ). Alternatif olarak, geleneksel DÜŞEYARA yöntemini kullanabilir ve sütunun tamamı yerine tek bir hücreye başvurebilirsiniz: =DÜŞEYARA(A2,A:C,2,YANLIŞ).

Bunu yapın

Neden?

Aralık_bak için mutlak başvurular kullanın

Mutlak başvurular kullanmak, formülü her zaman tam olarak aynı arama aralığına bakacak şekilde aşağı doğru doldurmanıza olanak tanır.

Mutlak hücre başvurularının nasıl kullanıldığını öğrenin.

Sayı veya tarih değerlerini metin olarak depolamayın.

Sayı veya tarih değerlerini ararken tablo_dizisinin ilk sütunundaki verilerin metin değerleri olarak depolanmamış olduğundan emin olun. Yoksa, DÜŞEYARA yanlış veya beklenmeyen bir değer verebilir.

İlk sütunu sıralayın

aralık_bak değeri DOĞRU olduğunda, DÜŞEYARA’yı kullanmadan önce tablo_dizisi değerinin ilk sütununu sıralayın.

Joker karakterler kullanın

YANLIŞ range_lookup ve lookup_value metinse, lookup_value'te soru işareti (?) ve yıldız işareti (*) gibi joker karakterler kullanabilirsiniz. YANLIŞ'sa ve aranan_değer metinse, aranan_değer’de joker karakterler, soru işareti (?) ve yıldız işareti (*) kullanabilirsiniz. Yıldız işareti bir dizi karakteri eşleştirir. Gerçek bir soru işaretini veya yıldız işaretini bulmak istiyorsanız, karakterden önce bir tilde işareti (~) koyun.

Örneğin, =DÜŞEYARA("Fontan?",B2:E7,2,YANLIŞ) son harfi değişen tüm Fontana örneklerini aratır.

Verilerinizde hatalı karakterler kullanılmadığından emin olun.

İlk sütundaki metin değerlerini ararken, ilk sütunda metnin başında boşluklar, sonunda boşluklar, tutarsız kullanılmış düz ( ' veya " ) ya da kıvrımlı ( ‘ veya “) tırnak işaretleri veya yazdırılamayan karakterler bulunmadığından emin olun. Bunlar varsa, DÜŞEYARA beklenmeyen bir değer verebilir.

Doğru sonuçlar almak için, hücrede tablo değerlerini izleyen sondaki boşlukları kaldırmak üzere TEMİZ işlevini veya KIRP işlevini kullanmayı deneyin.

Daha fazla yardım mı gerekiyor?

Sorularınızı Excel Teknoloji Topluluğuuzmanlarına sorabilir veya Yanıt topluluğu içinden destek alabilirsiniz.

Ayrıca Bkz:

Hızlı Başvuru Kartı: DÜŞEYARA yenileme
Hızlı Başvuru Kartı: DÜŞEYARA sorun giderme ipuçları
DÜŞEYARA işlevi #VALUE! hatasını düzeltme
DÜŞEYARA işlevinde #N/A hatasını düzeltme
Excel'daki formüllere genel Excel
Bozuk formülleri önleme
Formüllerde hataları algılama
Excel (alfabetik)
Excel (kategoriye göre)
DÜŞEYARA (ücretsiz önizleme)

Daha fazla yardıma mı ihtiyacınız var?

Yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Insider'Microsoft Office katılın

Bu bilgi yardımcı oldu mu?

Çeviri kalitesinden ne kadar memnunsunuz?
Deneyiminizi ne etkiledi?

Geri bildiriminiz için teşekkür ederiz!

×