Formüller bazen hatalı değerler verdiği gibi istenmeyen sonuçlar da döndürebilir. Aşağıda, bu hataların nedenlerini bulmak, araştırmak ve çözümlerini saptamak için kullanabileceğiniz bazı araçlar verilmiştir.

Not: Bu konu, formül hatalarını düzeltmenize yardımcı olacak teknikler içerir. Bu, olası tüm formül hatalarını düzeltme yöntemlerini içeren çok kapsamlı bir liste değildir. Belirli hatalarla ilgili yardım için, Excel Topluluk Forumu’nda sizinkine benzeyen soruları arayabilir veya kendiniz bir soru gönderebilirsiniz.

Excel Topluluk Forumu'nun bağlantısı

Basit bir formül girmeyi öğrenme

Formüller, çalışma sayfanızdaki değerler üzerinde hesaplamalar yapan denklemlerdir. Formül eşittir işaretiyle (=) başlar. Örneğin aşağıdaki formül 3 ile 1'i toplar.

=3+1

Bir formül, şunların herhangi birini veya tümünü de içerebilir: işlevler, başvurular, işleçler ve sabitler.

Formülün bölümleri

Formülün parçaları

  1. İşlevler: Excel’le birlikte sağlanan işlevler, belirli hesaplamalar gerçekleştirmek üzere kurulmuş formüllerdir. Örneğin, Pİ() işlevi Pİ sayısını döndürür: 3,142...

  2. Başvurular: Tek tek hücrelere veya hücre aralıklarına karşılık gelir. A2 başvurusu, A2 hücresindeki değeri döndürür.

  3. Sabitler: Formüle doğrudan girilen, 2 gibi sayılar veya metin değerleridir.

  4. İşleçler: ^ (şapka karakteri) işleci sayıyı bir kuvvete yükseltir ve * (yıldız işareti) işleci çarpar. Değerleri toplamak ve çıkarmak için + ve – , bölmek için de / kullanın.

    Not: Bazı işlevlere bağımsız değişkenler olarak adlandırılan öğeler gerekir. Bağımsız değişkenler, bazı işlevlerin hesaplama yapmak için kullandıkları değerlerdir. Gerektiğinde, bağımsız değişkenler işlevin parantezleri () içine yerleştirilir. Pİ işlevi hiçbir bağımsız değişken gerektirmediğinden parantezler boştur. Bazı işlevlere bir veya birden çok bağımsız değişken gerekir ve ek bağımsız değişkenler için yer bırakabilir. Konum ayarlarınıza bağlı olarak, bağımsız değişkenleri birbirinden ayırmak için virgül veya noktalı virgül (;) kullanmanız gerekir.

Örneğin, TOPLA işlevine tek bir bağımsız değişken gerekir, ancak toplamda 255 bağımsız değişkeni olabilir.

TOPLA işlevi

=TOPLA(A1:A10), tek bağımsız değişken örneğidir.

=TOPLA(A1:A10, C1:C10), birden çok bağımsız değişken örneğidir.

Aşağıdaki tabloda, kullanıcının formül girerken yapabileceği en yaygın hatalar özetlenir ve bunların nasıl düzeltileceği açıklanır:

Şundan emin olun

Daha fazla bilgi

Tüm işlevlere eşittir işaretiyle (=) başlayın

Eşittir işaretini atlarsanız, yazdıklarınız metin veya tarih olarak görüntülenebilir. Örneğin, TOPLA(A1:A10) yazarsanız, ExcelTOPLA(A1:A10) metin dizesini görüntüler ve hesaplamayı yapmaz. 11/2 yazarsanız, Excel 11'i 2'ye bölmek yerine 2- Kas (hücre biçiminin Genel olduğu varsayıldığında) tarihini görüntüler.

Tüm açma ve kapatma parantezlerini eşleştirin

Tüm ayraçların, eşleşen bir çiftin parçası olduğundan emin olun (açma ve kapatma ayracı). Formülde işlev kullandığınızda tüm ayraçların doğru konumda olması işlevin düzgün çalışması için önemlidir. Örneğin, =EĞER(B5<0),"Geçerli değil",B5*1,05) formülü iki kapatma parantezi olduğundan ve yalnızca bir tane açık parantez olduğundan çalışmayacak. Doğru formül şöyle olmalıdır: =EĞER(B5<0;"Geçerli değil";B5*1,05).

Aralık belirtmek için iki nokta üst üste işaretini kullanın

Bir hücre aralığına başvuruda bulunurken, aralıktaki ilk hücrenin başvurusunu aralıktaki son hücrenin başvurusundan ayırmak için iki nokta üst üste (:) kullanın. Örneğin, =TOPLA(A1:A5)=TOPLA(A1 A5) girerseniz #BOŞ! hatası döndürülebilir.

Gerekli tüm bağımsız değişkenleri girin

Bazı işlevlere bağımsız değişkenler gerekir. Ayrıca, çok fazla bağımsız değişken girmediğinizden de emin olun.

Doğru türde bağımsız değişkenler girin

TOPLA gibi bazı işlevlere yalnızca sayısal bağımsız değişkenler gerekir. DEĞİŞTİR gibi diğer işlevlere, bağımsız değişkenlerinin en az biri için bir metin değeri gerekir. Bağımsız değişken olarak yanlış veri türü kullanırsanız, Excel beklenmeyen sonuçlar döndürebilir veya hata görüntüleyebilir.

64 işlevden fazlasını iç içe yerleştirmeyin

Bir işlevin içine 64 düzeyden fazla işlev girmeyin veya iç içe yerleştirmeyin.

Diğer sayfa adlarını tek tırnak içine alın

Formül, diğer çalışma sayfası veya çalışma kitaplarındaki değerlere veya hücrelere başvuruda bulunuyorsa ve diğer çalışma kitabı veya çalışma sayfasının adı alfabetik olmayan bir karakter veya boşluk içeriyorsa, bu adı tek tırnak ( ' ) içine almalısınız. Örneğin, ='Üç Aylık Veriler'!D3 veya =‘123’!A1.

Formülde başvurduğunuzda çalışma sayfası adının sonuna bir ünlem işareti (!) koyun

Örneğin, aynı çalışma kitabındaki Çeyrek Verileri çalışma sayfasında yen alan D3 hücresinden veri getirmek için şu formülü kullanın: ='Çeyrek Verileri'!D3.

Dış çalışma kitaplarının yolunu belirtin

Her dış başvurunun, bir çalışma kitabı adını ve çalışma kitabının yolunu içerdiğinden emin olun.

Çalışma kitabı başvurusunda çalışma kitabının adı bulunur ve bunun köşeli parantez ([Çalışmakitabıadı.xlsx]) içine alınması gerekir. Başvuruda çalışma kitabındaki çalışma sayfası adının da olması gerekir.

Başvuruda bulunmak istediğiniz çalışma kitabı Excel'de açık olmasa bile buna yine de formülde başvuru ekleyebilirsiniz. Dosyanın tam yolunu verin; örneğin: =SATIRSAY('C:\Belgelerim\[Q2 Operasyonlar.xlsx]Satış'!A1:A8). Bu formül, diğer çalışma kitabında A1 - A8 arası hücreleri içeren aralıktaki satırların sayısını (8) döndürür.

Not: Tam yolda önceki örnekte olduğu gibi boşluk karakterleri varsa yolu tek tırnak içine almanız gerekir (yolun başlangıcına ve çalışma sayfasının hemen arkasına, ünlem işaretinden önce).

Sayıları biçimlendirmeden girin

Formüllere girerken sayıları biçimlendirmeyin. Örneğin, girmek istediğiniz değer 1,000 TL ise, formüle 1000 girin. Sayının parçası olarak virgül girerseniz, Excel bunu ayırıcı karakter olarak kabul eder. Sayıların binlik veya milyonluk ayırıcılarla ya da para birimi simgeleriyle gösterilmesini istiyorsanız, sayıları girdikten sonra hücreleri biçimlendirin.

Örneğin, A3 hücresindeki değere 3100 eklemek ister ve =TOPLA(3,100,A3) formülünü girerseniz, Excel (=TOPLA(3100,A3 formülüyle yapacağı gibi) 3100 ile A3 hücresindeki değeri toplamak yerine, 3 ve 100 sayılarını toplar ve toplamın sonucunu A3 hücresindeki değere ekler. Öte yandan, =MUTLAK(-2,134) formülünü girerseniz, Excel hata görüntüler çünkü MUTLAK işlevi tek bir bağımsız değişken kabul eder: =MUTLAK(-2134).

Formüllerdeki hataları denetlemek için bazı kurallar uygulayabilirsiniz. Bu kurallar çalışma sayfanızda hata olmamasını garanti etmese de, yaygın hataları bulmanıza çok yardımcı olabilir. Bu kurallardan istediklerinizi tek tek açabilir veya kapatabilirsiniz.

Hatalar iki yolla işaretlenebilir ve düzeltilebilir: bir kerede bir hata (yazım denetleyicisi gibi) veya siz çalışma sayfasında verileri girerken oluştukları anda.

Excel'in görüntülediği seçenekleri kullanarak hatayı düzeltebilir veya Hatayı Yoksay'a tıklayarak yoksayabilirsiniz. Belirli bir hücredeki hatayı yoksayarsanız, bundan sonraki hata denetimlerinde o hücredeki hata gösterilmez. Bununla birlikte, daha önce yoksayılan tüm hataları sıfırlayarak, bunların yeniden gösterilmesini de sağlayabilirsiniz.

  1. Formüller Excel için Windows Seçenekleri'ne > Formüller'>tıklayınveya
    Mac Excel'te tercihler ve Hata Excel için > > tıklayın. 

    Excel 2007’de Microsoft Office düğmesi Office düğmesi resmi> Excel Seçenekleri > Formüller’e tıklayın.

  2. Hata Denetimi'nin altında Arka planda hata denetimini etkinleştir’i işaretleyin. Bulunan her hata, hücrenin sol üst köşesinde bir üçgenle işaretlenir.

    Formül sorunu olan hücre
  3. Hatanın oluştuğu yeri işaretleyen üçgenin rengini değiştirmek için, Hataları bu rengi kullanarak göster kutusunda istediğiniz rengi seçin.

  4. Excel denetleme kuralları'nın altında, aşağıdaki kurallardan istediklerinizin onay kutularını seçin veya temizleyin:

    • Hatayla sonuçlanacak formüllerin bulunduğuhücreler: Formül beklenen söz dizimi, bağımsız değişkenler veya veri türlerini kullanmayacak. Hata değerleri #DIV 0!, #N/A, #NAME?, #NULL!, #NUM!, #REF!, ve #VALUE!. Bu hata değerlerinden her biri farklı nedenleri vardır ve farklı şekillerde çözülür.

      Not: Hata değerini doğrudan bir hücreye girerseniz, o hata değeri olarak depolanır ancak hata olarak işaretlenmez. Bununla birlikte, başka bir hücredeki formül o hücreye başvuruyorsa, formül o hücredeki hata değerini döndürür.

    • Tablolarda tutarsız hesaplanansütun formülü : Hesaplanan sütun, ana sütun formülünden farklı tek tek formüller içerebilir; bu da bir özel durum oluşturur. Hesaplanmış sütun özel durumları aşağıdakilerden birini yaptığınızda oluşur:

      • Hesaplanan sütun hücresindeki formülden farklı bir veri yazma.

      • Hesaplanan sütun hücresine bir formül yazın ve Ctrl+Z tuşlarını kullanın veya Hızlı Erişim Araç Çubuğu'Geri Al düğmesi geri al 'a tıklayın.

      • Önceden bir veya daha fazla özel durumu olan hesaplanmış sütuna yeni formül yazma.

      • Hesaplanan sütun formülüyle eşleşmeyen hesaplanan sütuna veri kopyalama. Kopyalanan veride formül varsa, bu formül hesaplanan sütundaki verilerin üzerine yazar.

      • Hesaplanan sütundaki satırlardan birinin başvurduğu başka bir çalışma sayfası alanındaki hücreyi taşıma veya silme.

    • Hücreler 2 basamaklı olarak gösterilen yılları içeriyor: Hücre, formüllerde kullanıldığında yanlış yüzyıl olarak algılanacak bir metin tarihine sahiptir. Örneğin, formüldeki tarih =YIL("1/1/31") 1931 veya 2031 olabilir. Bu kuralı, belirsiz metin tarihlerini denetlemek için kullanın.

    • Metin olarak biçimlendirilmiş veya başında kesme işareti olan sayılar: Hücre, metin olarak depolanmış sayılar içermektedir. Bu durum normalde başka kaynaklardan veri alındığında ortaya çıkar. Metin olarak depolanan sayılar beklenmeyen sıralama sonuçlarına neden olduğundan, en iyisi bunları sayıya dönüştürmektir. ‘=TOPLA(A1:A10).

    • Bölgedeki diğer formüllerle tutarsız olan formüller:Formül, yakınındaki diğer formüllerin deseniyle eş eş düzende değil. Çoğu durumda, diğer formüllere bitişik olan formüller yalnızca kullanılan başvurularda farklılık gösterir. Aşağıdaki dört bitişik formülde yer alan örnekte, Excel D4 hücresinde =TOPLA(A10:C10) formülünün yanında bir hata görüntüler; çünkü bitişikteki formüller bir satır, bir satır artarak 8 satır artırım; Excel =TOPLA(A4:C4) formülünü bekler.

      Bir formül, bitişiğindeki formüllerin deseniyle eşleşmiyorsa, Excel hata görüntüler

      Formülde kullanılan başvurular bitişik formüllerdekilerle tutarlı değilse, Excel hata görüntüler.

    • Bölgedeki hücreleri yok silenformüller : Formül otomatik olarak, özgün veri aralığıyla formülü içeren hücre arasına ekley istediğiniz verilere başvuru eklemez. Bu kural formüldeki başvuruyu formülün bulunduğu hücrenin bitişiğindeki gerçek veri aralığıyla karşılaştırır. Bitişikteki hücreler ek veriler içeriyorsa ve boş değilse, Excel formülün yanında bir hata gösterir.

      Örneğin, bu kural uygulandığında Excel =TOPLA(D2:D4) formülünün yanına hata ekler; bunun nedeni, D5, D6 ve D7 hücrelerinin formülde başvuruda bulunulan hücrelere ve formülü içeren hücreye (D8) bitişik olması ve söz konusu hücrelerin formülde başvuruda bulunulması gereken verileri içeriyor olmasıdır.

      Formül bir aralıktaki hücreleri atlıyorsa, Excel hata görüntüler
    • Formül içeren kilitlenmedi hücreler: Formül koruma için kilitlenmedi. Varsayılan olarak, çalışma sayfası korumalı durumdayken çalışma sayfasındaki tüm hücreler kilitlidir ve değiştirilemez. Bu, yanlışlıkla formülleri silme veya değiştirme gibi yanlışlıkla yapılan hataları önlemeye yardımcı olabilir. Bu hata, hücrenin kilidi açık olarak ayarlandı ancak sayfa korunmamış olduğunu gösterir. Hücrenin kilitli olup olmadığını kontrol edin.

    • Boş hücrelere başvuran formüller: Formül, boş bir hücreye başvuru içeriyor. Bu durum, aşağıdaki örnekte gösterildiği gibi, istenmeyen sonuçlara yol açabilir.

      Aşağıdaki hücre sütununda yer alan sayıların ortalamasını hesaplamak istediğinizi varsayalım. Üçüncü hücre boş bırakılırsa, hesaplamaya katılmaz ve sonuç 22,75 olur. Üçüncü hücrede 0 varsa, sonuç 18,2 olur.

      Formül boş hücrelere başvurduğunda Excel hata görüntüler
    • Tabloya girilen veri geçersiz: Tabloda doğrulama hatası vardır. Veri sekmesi > Veri Araçları grubu > Veri Doğrulama’ya gidip hücrenin doğrulama ayarını denetleyin.

  1. Hata denetimi yapmak istediğiniz çalışma sayfasını seçin.

  2. Çalışma sayfası el ile hesaplanıyorsa, yeniden hesaplamak için F9'a basın.

    Hata Denetimi iletişim kutusu görüntülenmiyorsa, Formüller sekmesi > Formül Denetleme > Hata Denetimi düğmesine tıklayın.

  3. Daha önce herhangi bir hatayı yoksaydıysanız, şu işlemi yaparak bu hataların yeniden denetlenmesini sağlayabilirsiniz: Dosya > Seçenekler > Formüller’e tıklayın. Mac Excel'te tercihler ve Hata Excel için >'> tıklayın.

    Hata Denetimi bölümünde Yoksayılan Hataları Sıfırla > Tamam'a tıklayın.

    Hata Denetimi

    Not: Yoksayılan hatalar sıfırlandığında, etkin kitabın tüm çalışma sayfalarındaki hataların tümü sıfırlanır.

    İpucu:  Hata Denetimi iletişim kutusunu formül çubuğunun hemen altına taşımanız yararlı olabilir.

    Hata Denetimi kutusunu Formül Çubuğu’nun altına taşıma
  4. İletişim kutusunun sağ tarafındaki eylem düğmelerinden birine tıklayın. Kullanılabilen eylemler hatanın türüne göre değişir.

  5. İleri'yi tıklatın.

Not:  Hatayı Yoksay seçeneğine tıklarsanız, hata sonraki her denetimde yok sayılmak üzere işaretlenir.

  1. Hücrenin yanında gösterilen Hata Denetimi düğmesine Hata Denetimi simgesi tıklayın ve ardından istediğiniz seçeneğe tıklayın. Kullanılabilen komutlar hatanın türüne göre değişir ve ilk girdi hatayı açıklar.

    Hatayı Yoksay seçeneğine tıklarsanız, hata bundan sonraki her denetimde yok sayılmak üzere işaretlenir.

    Hata Denetimi kutusunu Formül Çubuğu’nun altına taşıma

Formül sonucu doğru değerlendire Excel, #####, #DIV/0!, #N/A, #NAME?, #NULL!, #NUM!, #REF! ve #VALUE! gibi bir hata değeri görüntüler. Her hata türünün farklı nedenleri ve farklı çözümleri vardır.

Aşağıdaki tabloda, bu hataların ayrıntılı olarak açıklandığı makalelerin bağlantıları ve başlangıç yapmak için kısa bir açıklama verilmektedir.

Konu

Açıklama

#### hatasını düzeltme

Excel, sütun hücredeki karakterlerin tümünü görüntülemek için yeterli genişlikte olmadığında ya da hücre negatif tarih veya saat değerleri içerdiğinde bu hatayı görüntüler.

Örneğin, =15/06/2008-01/07/2008 gibi gelecekteki bir tarihi geçmişteki bir tarihten çıkaran bir formül sonuçta negatif tarih değeri verir.

İpucu: Sütun başlıklarının arasına çift tıklayarak hücreyi otomatik sığdırmayı deneyin. Excel karakterlerin tümünü görüntüleyemediği için ### görüntüleniyorsa, bu işlem bunu düzeltir.

# hatası

#BÖL/0! hatasını düzeltme

Bir sayı sıfıra (0) veya değer içermeyen bir hücreye bölündüğünde Excel bu hatayı görüntüler.

İpucu: Aşağıdaki =EĞER(C2,B2/C2,0) örneğinde olduğu gibi bir hata işleyicisi ekleyin.

Hataları işlemek için EĞER gibi bir hata işleme işlevi kullanılabilir

#YOK hatasını düzeltme

İşlevin veya formülün bir değeri sağlanmadığında Excel bu hatayı görüntüler.

DÜŞEYARA gibi bir işlev kullanıyorsanız, aramak için yazdığınız öğenin arama aralığında bir eşleşmesi var mı? Çoğunlukla yoktur.

#YOK hatasını engellemek için EĞERHATA kullanmayı deneyin. Bu durumda aşağıdakini kullanabilirsiniz:

=EĞERHATA(DÜŞEYARA(D2,$D$6:$E$8,2,DOĞRU),0)

#YOK hatası

#AD? hatasını düzeltme

Excel formüldeki metni tanımazsa bu hata görüntülenir. Örneğin, bir aralık adı veya işlevin adı yanlış yazılmış olabilir.

Not: İşlev kullanıyorsanız, işlevin adının doğru yazıldığından emin olun. Bu örnekte TOPLA yanlış yazılmıştır. "m" harfini kaldırın, Excel bunu düzeltecektir.

İşlev adında yazım hatası olduğunda Excel #AD? hatasını görüntüler

#BOŞ! hatasını düzeltme

Kesişmeyen iki alanın kesişimini belirttiğinizde Excel bu hatayı görüntüler. Kesişim işleci, formüldeki başvuruları ayıran bir boşluk karakteridir.

Not: Aralıkların birbirinden doğru bir şekilde ayrıldığından emin olun; C2:C3 ve E4:E6 aralıkları kesişmmektedir, dolayısıyla =TOPLA(C2:C3 E4:E6) formülü girilmişsa #NULL! hatası verir. C ve E aralıkları arasına virgül koyarak bunu düzeltebilirsiniz: =TOPLA(C2:C3,E4:E6)

#BOŞ! hatası

#SAYI! hatasını düzeltme

Formülde veya işlevde geçersiz sayısal değerler bulunduğunda Excel bu hatayı görüntüler.

İÇ_VERİM_ORANI veya FAİZ_ORANI gibi yinelenen bir işlev mi kullanıyorsunuz? Bu durumda, #SAYI! hatasının nedeni büyük olasılıkla işlevin bir sonuç bulamamasıdır. Çözüm adımları için yardım konusuna bakın.

#BAŞV! hatasını düzeltme

Hücre başvurusu geçersiz olduğunda Excel bu hatayı görüntüler. Örneğin, başka formüllerin başvurduğu hücreleri silmiş veya başka formüllerin başvurduğu hücrelerin üstüne hücreler yapıştırmış olabilirsiniz.

Yanlışlıkla bir satır veya sütun mu sildiniz? Bu formülde (=TOPLA(A2,B2,C2)) biz B sütunun sildik ve bakın ne oldu.

Geri Al’ı (Ctrl+Z) kullanarak silme işlemini geri alın, formülü yeniden oluşturun veya =TOPLA(A2:C2) gibi bir sürekli hücre başvurusu kullanın. B sütunu silindiğinde hücre başvurusu otomatik olarak güncelleştirilebilir.

Hücre başvurusu geçersiz olduğunda Excel #BAŞV! hatasını görüntüler

#DEĞER! hatasını düzeltme

Formülünüzde farklı veri türleri içeren hücreler varsa Excel bu hatayı görüntüleyebilir.

Farklı veri türleriyle birlikte Matematik işleçleri (+, -, *, /, ^) mi kullanıyorsunuz? Öyleyse, onun yerine işlev kullanmayı deneyin. Bu örnekte, =TOPLA(F2:F5) işlevi sorunu çözebilir.

#DEĞER! hatası

Çalışma sayfasında hücreler görünür olmadığında, bu hücreleri ve onların formüllerini Gözcü Penceresi araç çubuğunda izleyebilirsiniz. Gözcü Penceresi, büyük çalışma sayfalarındaki formül hesaplamalarını ve sonuçlarını incelemeyi, denetlemeyi veya onaylamayı kolaylaştırır. Gözcü Penceresi'ni kullandığınızda, tekrar tekrar sayfayı kaydırmanız veya çalışma sayfanızın farklı bölümlerine gitmeniz gerekmez.

İzleme Penceresi çalışma sayfasında kullanılan formüllerin kolayca izlenebilmesini sağlar

Bu araç çubuğu, aynı diğer araç çubukları gibi taşınabilir ve sabitlenebilir. Örneğin, bunu pencerenin en altına sabitleyebilirsiniz. Araç çubuğu aşağıdaki hücre özelliklerini izler: 1) Çalışma kitabı, 2) Sayfa, 3) Ad (hücreye karşılık gelen bir Adlandırılmış Aralık varsa), 4) Hücre adresi, 5) Değer ve 6) Formül.

Not: Hücre başına tek bir gözcünüz olabilir.

Gözcü Penceresi'ne hücreleri ekleme

  1. İzlemek istediğiniz hücreleri seçin.

    Çalışma sayfasında formül içeren tüm hücreleri seçmek için, Giriş sekmesinin Düzenleme grubunda Bul ve Seç’e tıklayın (ya da Ctrl+G veya Mac bilgisayarda Control+G tuşlarını kullanabilirsiniz). Özel > Formüller’e gidin.

    Özel Git iletişim kutusu
  2. Formüller sekmesinin Formül Denetimi grubunda Gözcü Penceresi'ne tıklayın.

  3. Gözcü Ekle'ye tıklayın.

    Elektronik tablonuza gözcü eklemek için Gözcü Ekle’ye tıklayın
  4. İzlemek istediğiniz tüm hücreleri seçtiğinizden emin olun ve Ekle’ye tıklayın.

    Gözcü Ekle’de, izlenecek hücre aralığını girin
  5. Bir Gözcü Penceresi sütununun genişliğini değiştirmek için sütun başlığının sağ kısmındaki sınırı sürükleyin.

  6. Gözcü Penceresi araç çubuğundaki bir girdinin başvurduğu hücreyi görüntülemek için, girdiye çift tıklayın.

    Not: Diğer çalışma kitaplarına dış başvurular içeren hücrelerin Gözcü Penceresi araç çubuğunda görüntülenmesi için, diğer çalışma kitaplarının açık olması gerekir.

Gözcü Penceresi'nden hücreleri kaldırma

  1. Gözcü Penceresi görüntülenmiyorsa, Formüller sekmesinin Formül Denetimi grubunda Gözcü Penceresi'ne tıklayın.

  2. Kaldırmak istediğiniz hücreleri seçin.

    Birden çok hücre seçmek için, CTRL tuşunu basılı tutarak hücrelere tıklayın.

  3. Gözcü Sil'e tıklayın.

    Gözcü Sil

Bazı durumlarda, iç içe bir formülün sonucu nasıl hesapladığını anlamak zor olabilir çünkü bazı ara hesaplamalar ve mantıksal sınamalar vardır. Bununla birlikte, Formülü Değerlendir iletişim kutusunu kullanarak iç içe formülün farklı bölümlerinin formülde hangi sırayla hesaplandığını görebilirsiniz. Örneğin, aşağıdaki ara sonuçları görebildiğinizde =EĞER(ORTALAMA(D2:D5)>50,TOPLA(E2:E5),0) formülünü daha kolay anlayabilirsiniz:

Formül Değerlendir, iç içe formüllerin farklı parçalarının nasıl değerlendirileceğini görmenize yardımcı olur

Formül Değerlendir iletişim kutusunda

Açıklama

=EĞER(ORTALAMA(D2:D5)>50,TOPLA(E2:E5),0)

Başlangıçta iç içe formül görüntülenir. ORTALAMA işlevi ve TOPLA işlevi, EĞER işlevinin içine yerleştirilmiştir.

D2:D5 hücre aralığı 55, 35, 45 ve 25 değerlerini içerir; dolayısıyla ORTALAMA(D2:D5) işlevinin sonucu 40'tır.

=EĞER(40>50,TOPLA(E2:E5),0)

D2:D5 hücre aralığı 55, 35, 45 ve 25 değerlerini içerir; dolayısıyla ORTALAMA(D2:D5) işlevinin sonucu 40'tır.

=EĞER(Yanlış,TOPLA(E2:E5),0)

40 sonucu 50'den büyük olmadığından, EĞER işlevinin ilk bağımsız değişkenindeki ifade (mantıksal_sınama bağımsız değişkeni) Yanlış'tır.

EĞER işlevi üçüncü bağımsız değişkenin (eğer_yanlışsa_değer bağımsız değişkeni) değerini döndürür. TOPLA işlevi hesaplanmaz çünkü bu EĞER işlevinin ikinci bağımsız değişkenidir (eğer_doğruysa_değer bağımsız değişkeni) ve ancak ifade Doğru olduğunda sonucu döndürülür.

  1. Hesaplamak istediğiniz hücreyi seçin. Bir kerede tek bir hücre hesaplanabilir.

  2. Formüller sekmesi > Formül Denetleme > Formülü Değerlendir’i seçin.

  3. Altı çizili başvurunun değerini incelemek için Değerlendir’e tıklayın. Değerlendirme sonucu italik yazıyla gösterilir.

    Formülün altı çizili bölümü başka bir formüle başvuruysa Değerlendirme kutusundaki başka diğer formülü görüntülemek için İçeri Adımla’ya tıklayın. Önceki hücre ve formüle geri dönmek için Dışarı Adımla’ya tıklayın.

    Başvuru formülde ikinci kez görünüyorsa ya da formül başka bir çalışma kitabındaki hücreye başvuruyorsa, başvuru için İçeri Adımla düğmesi sağlanmaz.

  4. Formülün tüm kısımları değerlendirilene kadar Değerlendir’e tıklamaya devam edin.

  5. Hesaplamayı yeniden görmek için, Yeniden Başlat'a tıklayın.

  6. Hesaplamayı sona erdirmek için Kapat'a tıklayın.

Notlar: 

  • EĞER ve ELEMAN işlevlerini kullanan formüllerin bazı bölümleri hesaplanmaz; bu gibi durumlarda, Değerlendirme kutusunda #YOK değeri görüntülenir.

  • Başvuru boşsa, Değerlendirme kutusunda sıfır değeri (0) görüntülenir.

  • Aşağıdaki işlevler, çalışma sayfası her değiştiğinde yeniden hesaplanır ve Formülü Değerlendir iletişim kutusunun hücrede gösterilenden farklı sonuçlar vermesine neden olabilir: S_SAYI_ÜRET, ALANSAY, İNDİS, KAYDIR, HÜCRE, DOLAYLI, SATIRSAY, SÜTUNSAY, ŞİMDİ, BUGÜN, RASTGELEARADA.

Daha fazla yardım mı gerekiyor?

Sorularınızı Excel Teknoloji Topluluğuuzmanlarına sorabilir veya Yanıt topluluğu içinden destek alabilirsiniz.

Ayrıca Bkz.

Formüller ve hücreler arasındaki ilişkileri görüntüleme

Bozuk formülleri önleme

Daha fazla yardıma mı ihtiyacınız var?

Yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Microsoft Insider 'a katılın

Bu bilgi yardımcı oldu mu?

Çeviri kalitesinden ne kadar memnunsunuz?
Deneyiminizi ne etkiledi?

Geri bildiriminiz için teşekkür ederiz!

×