TOPLA işlevi hakkında daha fazla bilgi

Bir hücre aralığının Toplamını hızlıca almak istiyorsanız aralığı seçip Excel penceresinin sağ alt kısmına bakmanız yeterlidir.

Bir hücre aralığı seçip Durum Çubuğu’na bakma ekran görüntüsü


Bu, Durum Çubuğu'dur ve ister tek bir hücre ister birden fazla hücre olsun, seçtiğiniz hücreyle ilgili bilgileri görüntüler. Durum Çubuğu’na sağ tıklarsanız belirleyebileceğiniz tüm seçeneklerin gösterildiği bir özellik iletişim kutusu açılır. Öznitelikleri işaretlediyseniz seçtiğiniz aralığın değerleri de gösterilir. 

Çalışma sayfanıza bir TOPLA formülü eklemenin en kolay yolu Otomatik Toplam Sihirbazı’nı kullanmaktır. Toplamak istediğiniz aralığın hemen üst veya altındaki boş bir hücreyi seçin ve Şerit’teki Giriş veya Formül sekmelerinde Otomatik Toplam > Toplam’a basın. Otomatik Toplam Sihirbazı toplanacak aralığı otomatik olarak algılar ve sizin yerinize formülü oluşturur. Toplanacak aralığın sol veya sağındaki bir hücreyi seçtiğinizde yatay olarak da çalışabilir. Bu işlev bitişik olmayan aralıklarda çalışmaz ancak bu konuyu sonraki bölümde ele alacağız.

Otomatik olarak bir Topla formülü oluşturmak için Otomatik Toplam Sihirbazı’nı kullanabilirsiniz.  Aralığın üstünden/altından veya solundan/sağından toplamak için bir aralık seçin ve Şerit’teki Formül sekmesine gidip Otomatik Toplam ve TOPLAM’ı seçin.


Otomatik Tamamlama iletişim kutusu aşağıdakiler gibi diğer yaygın işlevleri de seçmenize olanak sağlar:

Dikey Otomatik Toplam

B6 hücresinde Otomatik Toplam Topla formülü gösterilir: =TOPLA(B2:B5)

Otomatik Toplam Sihirbazı, toplanacak aralık için otomatik olarak B2:B5 hücrelerini algıladı. Onaylamak için Enter tuşuna basmanız yeterlidir. Daha fazla hücre eklemeniz/hariç tutmanız gerekirse istediğiniz seçimi yapana kadar Shift Tuşu > istediğiniz ok tuşuna basılı tutun ve işiniz bitince Enter tuşuna basın.

Intellisense işlev kılavuzu: TOPLA(sayı1,[sayı2], ...) İşlevin altındaki kayan etiket, Intellisense kılavuzudur. TOPLA veya işlev adına tıklarsanız mavi bir köprüye dönüşecek ve bu işlem sizi söz konusu işlevin Yardım konusu haline gelecektir. Tek tek işlev öğelerine tıklarsanız, formülde işlev öğelerinin temsili parçaları vurgulanır. Bu durumda, bu formülde yalnızca bir sayı başvurusu olduğu için yalnızca B2:B5 vurgulanır. Herhangi bir işlev için IntelliSense etiketi görüntülenir.

Yatay Otomatik Toplam

D2 hücresinde Otomatik Toplam Topla formülü gösterilir: =TOPLA(B2:C2)

Bitişik olmayan aralıklarla TOPLA işlevini kullanma.  C8 hücresindeki formül: =TOPLA(C2:C3,C5:C6). Formülün =TOPLA(Hafta1,Hafta2) olması için Adlandırılmış Aralıklar da kullanabilirsiniz.

Otomatik Toplam Sihirbazı genel olarak yalnızca bitişik aralıklarda çalışır; dolayısıyla toplam aralığınıza boş satırlar veya sütunlar Excel aralıkta durur. Bu durumda tek tek aralıkları tek tek ekley yeri olan seçime göre TOPLA'nıza gerek vardır. Bu örnekte B4 hücresinde verileriniz varsa, Excel bir aralık tanıması için =TOPLA(C2:C6) üretmesi gerekir.

Ctrl+SolTıklama ile bitişik olmayan birden çok aralığı hızla seçebilirsiniz. İlk olarak "=TOPLA(" girin, ardından farklı aralıklarınızı seçin Excel aralığın arasına virgül ayırıcısını otomatik olarak ekler. Bitirin ve Enter tuşuna basın.

İpucu: TOPLA işlevini bir hücreye hızla eklemek için ALT+ = kullanabilirsiniz. Ardından tek gereken aralıklarınızı seçmektir.

Not: Farklı işlev aralıklarını Excel renkle vurgulu olduğunu ve renklerin formülün kendisiyle nasıl eş olduğunu fark edersiniz; yani C2:C3 bir renk, C5:C6 başka bir renktir. Excel bir çalışma sayfasında veya başka bir çalışma kitabında olmadığı sürece, başvurulan aralık tüm işlevler için bunu yapar. Yardımcı teknolojiyle daha iyi bir erişilebilirlik için "Hafta1", "Hafta2" gibi Adlandırılmış Aralıklar kullanabilir ve ardından formülde onlara başvurabilirsiniz:

=TOPLA(Hafta1,Hafta2)

  1. TOPLA işlevini diğer işlevlerin tamamıyla kullanabilirsiniz. Aşağıda aylık ortalamayı hesaplayan bir örnek verilmiştir:

    TOPLA işlevini diğer işlevlerle kullanma.  M2 hücresindeki formül: =TOPLA(A2:L2)/BAĞ_DEĞ_DOLU_SAY(A2:L2).  Not: Mayıs-Kasım sütunları anlaşılırlık için gizlenmiştir.
    • =TOPLA(A2:L2)/BAĞ_DEĞ_DOLU_SAY(A2:L2)

  2. A2:L2 TOPLAMINI A2:L2’deki boş olmayan hücre sayısına böler (Mayıs ile Aralık arası boştur).

  1. Bazen birden fazla çalışma sayfasındaki belirli bir hücreyi toplamanız gerekir. Her sayfaya ve hücreye tıklayarak hücre değerlerini toplamak için yalnızca “+” kullanmak isteyebilirsiniz, ancak bu işlem yorucudur ve hata eğilimlidir.

    • =Sayfa1!A1+Sayfa2!A1+Sayfa3!A1

    Bunu bir 3B veya 3 Boyutlu TOPLA ile çok daha kolay gerçekleştirebilirsiniz:

    3B Topla - D2 hücresindeki formül: =TOPLA(Sayfa1:Sayfa3!A2)
    • =TOPLA(Sayfa1:Sayfa3!A1)

    Bu formül Sayfa 1’den Sayfa 3’e kadar tüm sayfalardaki A1 hücrelerini toplar.

    Bu özellikle her ay için bir sayfanız varsa (Ocak-Aralık) ve değerleri bir özet sayfasında toplamanız gerekiyorsa yararlıdır.

    Adlandırılmış Sayfalardaki 3B TOPLA işlevi.  D2 hücresindeki formül: =TOPLA(Ocak:Aralık!A2)
    • =TOPLA(Ocak:Aralık!A2)

    Bu formül Ocak’tan Aralık’a kadar tüm sayfalardaki A2 hücresini toplar.

    Notlar: Çalışma sayfalarında adlarında boşluklar varsa (bunun yerine "Ocak Satışları" gibi) formülde sayfa adlarına başvururken kesme işareti kullan gerekir. İlk çalışma sayfası adının ÖNCEİ ve son çalışma sayfasından SONRAİ kesme işaretine dikkat eden.

    • =TOPLA(‘Ocak Satışları:Aralık Satışları’!A2)

    3B yöntemi ORTALAMA, MİN ve MAK gibi diğer işlevlerle de çalışır:

    • =ORTALAMA(Sayfa1:Sayfa3!A1)

    • =MIN(Sayfa1:Sayfa3!A1)

    • =MAK(Sayfa1:Sayfa3!A1)

İşlemin kendisini yaparak ve TOPLA gibi Excel işlevlerini kullanarak Matematik işlemlerini Excel ile kolayca gerçekleştirebilirsiniz. Aşağıdaki tablo ilgili işlevlerle birlikte, kullanabileceğiniz işleçleri listeler. İşleçleri klavyenizdeki sayıların bulunduğu sıradan veya varsa 10 sayı bulunan tuş takımından girebilirsiniz. Örneğin Shift+8 çarpma işlemi için yıldız işaretini (*) girer.

İşleç

İşlem

Örnekler

+

Toplama

=1+1

=A1+B1

=TOPLA(A1:A10)+10

=TOPLA(A1:A10)+B1

-

Çıkarma

=1-1

=A1-B1

=TOPLA(A1:A10)-10

=TOPLA(A1:A10)-B1

*

Çarpma

=1*1

=A1*B1

=TOPLA(A1:A10)*10

=TOPLA(A1:A10)*B1

=ÇARPIM(1,1) - ÇARPIM işlevi

/

Bölme

=1/1

=A1/B1

=TOPLAM(A1:A10)/10

=TOPLAM(A1:A10)/B1

=BÖLÜM(1,1) - BÖLÜM işlevi

^

Üs

=1^1

=A1^B1

=TOPLA(A1:A10)^10

=TOPLA(A1:A10)^B1

=KUVVET(1,1) - KUVVET işlevi

Daha fazla bilgi için, bkz. Excel'i hesap makineniz olarak kullanma.

Diğer örnekler

  1. Topladığınız hücre aralığına bir Yüzde İndirimi uygulamak istediğinizi varsayalım.

    TOPLA ile İşleçleri kullanma.  B16 hücresindeki formül =TOPLA(A2:A14)*-%25.  -%25, =TOPLA(A2:A14)*E2 gibi bir hücre başvurusu olsaydı formül düzgün oluşturulurdu
    • =TOPLA(A2:A14)*-%25

    Bu size toplanacak aralığın %25'ini verse de bu şekilde formüle %25'i sabit kodlar ve daha sonra değiştirmek zorunda olacağınız oldu. %25'i bir hücreye koymanız ve bunun yerine hücrenin açıkta olduğunu ve kolayca değiştirdiğini ifade etmek çok daha iyi olur:

    • =TOPLA(A2:A14)*E2

    Çarpmak yerine bölmek için “*” simgesini “/” ile değiştirmeniz yeterlidir: =TOPLA(A2:A14)/E2

  2. Bir TOPLA işlevine değer eklemek veya işlevden değer çıkarmak

    i. + veya - kullanarak bir Topla işlevine kolayca değer ekleyebilir veya işlevden değer çıkartabilirsiniz, örneğin:

    • =TOPLA(A1:A10)+E2

    • =TOPLA(A1:A10)-E2

TOPLA işlevi

Daha fazla yardıma mı ihtiyacınız var?

Yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Microsoft Insider 'a katılın

Bu bilgi yardımcı oldu mu?

Çeviri kalitesinden ne kadar memnunsunuz?
Deneyiminizi ne etkiledi?

Geri bildiriminiz için teşekkür ederiz!

×