Bu makalenin geçerli olduğu ürünleri görüntüleyin.

Önemli

, Bu güvenlik güncelleştirmesini Önerildi değil, uyumlu olmayan virüsten koruma yazılımı çalıştıran ve yazılım satıcısına başvurmanız gerekir. Tüm müşterilere olabildiğince çabuk Ocak Windows Güvenlik güncelleştirmeleri aldığınızdan emin olmak için virüsten koruma yazılımı ortakları ile yakından çalışmaktayız. Daha fazla bilgi için https://support.microsoft.com/en-us/help/4072699/january-3-2018-windows-security-updates-and-antivirus-software ve bu makalenin "Bu güvenlik güncelleştirmesi hakkında ek bilgi" bölümüne bakın.

Özet

Bu güvenlik güncelleştirmesi Microsoft .NET Framework ve .NET çekirdek bileşenleri sertifikaları tümüyle doğrulamaması olduğunda, bir güvenlik özelliği bypass güvenlik açığını giderir. Bu güvenlik güncelleştirmesi, .NET Framework ve .NET çekirdek bileşenleri tamamen sertifikaları doğrulamak emin olmak için yardımcı olarak bir güvenlik açığını giderir. Bu güvenlik açığı hakkında daha fazla bilgi için bkz: Microsoft Ortak Güvenlik Açıkları ve Etkilenmeler CVE-2018-0786.

Ayrıca, bu güvenlik güncelleştirmesini .NET Framework ve .NET çekirdek bileşenleri düzgün XML belgelerini işlemek, varolan bir hizmet reddi güvenlik açığını giderir. Bu güncelleştirme, .NET Framework ve .NET çekirdek bileşeni uygulamaları XML belge işleme nasıl işleneceğini düzelterek güvenlik açığını giderir. Bu güvenlik açığı hakkında daha fazla bilgi için bkz: Microsoft Ortak Güvenlik Açıkları ve Etkilenmeler CVE-2018-0764.

Önemli

  • 4.6, 4.6.1, 4.6.2, 4.7 ve 4.7.1 .NET Framework için tüm güncelleştirmeleri d3dcompiler_47.dll yüklenmesini gerektirir. Bu güncelleştirmeyi uygulamadan önce gelen d3dcompiler_47.dll yüklemenizi öneririz. D3dcompiler_47.dll hakkında daha fazla bilgi için bkz: KB 4019990.

  • Bu güncelleştirmeyi yükledikten sonra bir dil paketi yüklerseniz, bu güncelleştirmeyi yeniden yüklemeniz gerekir. Bu nedenle, bu güncellemeyi yüklemeden önce ihtiyacınız olan dil paketlerini yüklemeniz önerilir. Daha fazla bilgi için bkz: Windows için dil paketleri ekleme.

Bu güvenlik güncelleştirmesi hakkında ek bilgi

  • Gelişmiş anahtar kullanımı (EKU) RFC 5280 bölümünde 4.2.1.12'deaçıklanmıştır. Bir veya daha fazla amacıyla sertifikalı ortak anahtar kullanılabilir için ek olarak ya da anahtar kullanımı uzantısı içinde belirtilmiş olan temel amaçları yerine bu uzantı belirtir. Örneğin, bir sunucu için istemci kimlik doğrulaması için kullanılan sertifika, istemci kimlik doğrulaması için yapılandırılmalıdır. Benzer şekilde, bir sunucu kimlik doğrulaması için kullanılan sertifika, sunucu kimlik doğrulaması için yapılandırılmalıdır. Bu değişikliği uygun istemci/sunucu EKU sertifikalar gerektiren yanı sıra, kök sertifikayı devre dışıysa, sertifika zinciri doğrulaması başarısız olur.

    Kimlik doğrulaması için sertifikalar kullanıldığında, kimlik doğrulayıcısı sertifikayı uzak bitiş noktası tarafından sağlanır ve uygulama ilkeleri uzantılarında doğru amaç nesnesi tanımlayıcısını arar inceler. İstemci kimlik doğrulama için sertifika kullanıldığında, istemci kimlik doğrulaması için nesne tanımlayıcısı sertifikanın, EKU uzantılarında bulunmalıdır veya kimlik doğrulaması başarısız olur. İstemci kimlik doğrulaması için nesne tanımlayıcısı 1.3.6.1.5.5.7.3.2'dir. Benzer şekilde, sunucu kimlik doğrulaması için sertifika kullanıldığında, sunucu kimlik doğrulaması için nesne tanımlayıcısı sertifikanın, EKU uzantılarında bulunmalıdır veya kimlik doğrulaması başarısız olur. Sunucu kimlik doğrulaması için nesne tanımlayıcısı 1.3.6.1.5.5.7.3.1'dir. EKU uzantısı olmayan sertifikalar kimlik doğrulaması doğru devam edin.

    İlk olarak, doğru EKU OID öznitelikleri kullanma ve doğru güvenli olduğundan emin olmak için bileşenin sertifikalarını değişiklik yapmayı düşünün. Geçici olarak doğru şekilde yeniden yayımlanan sertifikalar erişemiyorsanız, içinde veya dışında herhangi bir bağlantı etkileri önlemek için güvenlik değişikliği kabul etmek seçebilirsiniz. Bunu yapmak için aşağıdaki appsetting yapılandırma dosyasında belirtin:

    <appSettings>
        <add key="wcf:useLegacyCertificateUsagePolicy" value="true" />
    </appSettings>

    Not: "True" değerine ayarlanması, yetersiz güvenlik değişiklikleri opt.

  • Tek tek ürün sürümleri için ilgili olarak aşağıdaki makaleleri bu güvenlik güncelleştirmesi hakkında ek bilgi içerir.

    • 4054176 yalnızca güvenlik güncelleştirmesi için .NET Framework 3.5.1 Windows 7 SP1 ve Windows Server 2008 R2 SP1 (KB 4054176)

    • 4054172 yalnızca güvenlik güncelleştirmesi 4.5.2 .NET Framework için Windows 7 SP1, Windows Server 2008 R2 SP1 ve Windows Server 2008 SP2 (KB 4054172)

    • 4054183 güvenlik yalnızca güncelleştirmesi 4.6, 4.6.1, 4.6.2, 4.7 ve 4.7.1 .NET Framework için Windows 7 SP1 ve Windows Server 2008 R2 SP1 ve .NET Framework 4.6 Windows Server 2008 SP2 (KB 4054183)

  • 10 Windows, Windows 8.1, Windows Server 2012 R2 ve Windows Server 2016 müşterileri

    Tüm müşteriler virüsten koruma yazılımı çalışan uyumludur ve desteklenen aygıtlarını korumanızı öneririz. Müşteriler yerleşik virüsten koruma Windows Defender virüsten koruma, Windows 8.1 ve Windows 10 aygıtların veya uyumlu bir üçüncü taraf virüsten koruma uygulaması yararlanabilirsiniz. Virüsten koruma yazılımı "Ayarı Ocak 2018 güvenlik güncelleştirmeleri almak için anahtarında" konusunda açıklandığı gibi bir kayıt defteri anahtarını ayarlamalıdır.

    Windows 7 SP1 ve Windows Server 2008 R2 SP1 müşteriler

    Windows 7 SP1 veya Windows Server 2008 R2 SP1 Varsayılan yüklemede, müşterilerin yüklü bir virüsten koruma uygulaması yoktur. Bu gibi durumlarda, Microsoft Security Essentials gibi desteklenen ve uyumlu virüsten koruma uygulaması veya bir üçüncü taraf virüsten koruma uygulaması yükleme olan öneririz. Virüsten koruma yazılımı Ocak 2018 güvenlik güncelleştirmelerini almak için "ayar kayıt defteri anahtarında" konusunda açıklandığı gibi bir kayıt defteri anahtarını ayarlamanız gerekir.

    Müşterilerin virüsten koruma olmadan

    Müşteriler yükleyemez veya virüsten koruma yazılımını çalıştırmanızı Ocak 2018 güvenlik güncelleştirmelerini almak için "ayar kayıt defteri anahtarında" açıklandığı şekilde kayıt defteri anahtarını el ile ayarlama öneririz.

    Kayıt defteri anahtarı ayarı

    Dikkat Yanlış Kayıt Defteri Düzenleyicisi'ni kullanarak, işletim sisteminizi yeniden yüklemenizi gerektirebilecek ciddi sorunlara neden olabilir. Microsoft, Kayıt Defteri Düzenleyicisi'nin yanlış kullanımından kaynaklanan sorunların çözülebileceğini garanti etmemektedir. Kayıt Defteri Düzenleyicisi'ni kullanmak kendi sorumluluğunuzdadır. Kayıt defterini düzenleme hakkında bilgi kayıt defteri Düzenleyicisi'nde "anahtarları ve değerleri değiştirme" Yardım konusuna bakın veya "Ekle ve Sil bilgileri kayıt defterinde" görüntüleyin ve Yardım konuları Regedt32.exe dosyasındaki "kayıt defteri verilerini düzenleme".

    Not: (Veya art arda güvenlik güncelleştirmeleri) Ocak 2018 güvenlik güncelleştirmelerini almaz ve üzere virüsten koruma yazılım satıcılarına aşağıdaki kayıt defteri anahtarını ayarlar sürece güvenlik açıklarından korumalı olmayan müşteriler:

    Key="HKEY_LOCAL_MACHINE" Subkey="SOFTWARE\Microsoft\Windows\CurrentVersion\QualityCompat" Value="cadca5fe-87d3-4b96-b7fb-a231484277cc" Type="REG_DWORD”
    Data="0x00000000”

Yardım ve Destek bu güvenlik güncelleştirmesi nasıl elde edilir

Şunun için geçerlidir:

Bu makale şunlar için geçerlidir:

  • Microsoft .NET Framework 3.5.1, 4.5.2, 4.6, 4.6.1, 4.6.2, 4.7 ve 4.7.1 ile kullanıldığında:

    • Windows Server 2008 R2 Service Pack 1

    • Windows 7 Service Pack 1

Daha fazla yardıma mı ihtiyacınız var?

Yeteneklerinizi geliştirin

Eğitimleri keşfedin >

Yeni özellikleri ilk olarak siz edinin

Microsoft Insider’a katılın >

Bu bilgi yararlı oldu mu?

Dil kalitesinden ne kadar memnunsunuz?
Deneyiminizi ne etkiledi?

Geri bildiriminiz için teşekkürler!

×