Важливо
Підтримка Microsoft InfoPath 2013 завершилася 14 липня 2026 р. Радимо перенести наявні форми та робочі цикли InfoPath до підтримуваних рішень Microsoft 365. Дізнайтеся більше про припинення підтримки InfoPath.
Створивши різні подання у формі, можна запропонувати користувачам різні способи перегляду даних залежно від типу форми, яку потрібно створити, або типу користувача, якому вона використовується. Наприклад, у кількох поданнях можна:
- Спростіть довгу та складну форму, таку як довге опитування, розділивши її на кілька сторінок, натискаючи кнопки "Далі " та " Назад ".
- Показуйте різні версії форми різним користувачам залежно від їхньої ролі в організації, наприклад мати подання страхувальника, агента та оцінювача під час обробки страхових вимог.
- Створіть зрозуміле для друку подання форми.
Усі подання в одній формі InfoPath використовують однакові дані. У результаті, якщо форма має два подання, одне з яких містить текстове поле з адресою електронної пошти, це текстове поле можна скопіювати до другого подання. Якщо користувач введе свою адресу електронної пошти в одному поданні, вона автоматично відобразиться в іншому.
У цій статті
Загальні відомості про подання
Взаємодія з користувачем
За замовчуванням користувачі форми можуть переходити між поданнями, вибираючи потрібне подання в групі " Подання подань/сторінок " на стрічці. Кожне подання буде перелічено за його іменем, а активне подання буде виділено. Буде перелічено всі подання, крім тих подань, для яких знято прапорець "Відображати в меню "Вигляд" під час заповнення цієї форми.
Якщо в жодному з подань не встановлено прапорець "Відображати в меню "Вигляд" під час заповнення цієї форми , група " Подання сторінки " на вкладці "Основне " не відображатиметься. Це корисно в сценаріях, коли не потрібно, щоб користувачі мали доступ до інших подань, окрім тих, які вони мають заповнити. Наприклад, з формою, яка використовується для збору відгуків про претендентів на роботу, може бути пов'язано три різні ролі користувача: одна для роботодавців, одна для тих, хто проводить співбесіди, і одна для керівників з найму. Для кожної ролі користувача можна створити дещо інше подання форми.
Примітка.
Можливість приховувати свої погляди від користувачів не належить до функцій безпеки. Користувачі можуть переглядати дані, якщо знають, як отримати доступ до самих XML-даних.
Щоб запобігти переходу учасників співбесіди до подання роботодавця або керівника з працевлаштування, створюючи подання роботодавця та керівника з працевлаштування, можна відкрити діалогове вікно "Властивості подання " та зняти прапорець "Відображати в меню "Вигляд" під час заповнення цієї форми .
Примітка.
У параметрах форми можливість переключатися між поданнями може бути вимкнута для користувачів, які заповнюють форму в браузері. Перейдіть на вкладку Файл , послідовно виберіть елементи Відомості, пункт Параметри форми, а потім у розділі Браузери зніміть прапорець Подання .
Щоб настроїти перехід між поданнями, додайте кнопки перемикання до форми, як описано далі в цій статті.
Питання дизайну
Під час розробки нового подання зазвичай потрібно виконувати такі завдання:
- Сплануйте подання.
Сплануйте кожен погляд і те, як вони працюватимуть разом, звертаючи увагу на такі міркування:
- Яке з подань має відображатися під час першого відкриття форми?
- Чи потрібно користувачам використовувати кілька подань? Як вони будуть переміщатися між ними?
- Чи мають подання бути доступні лише для читання?
- Чи доцільно надрукувати будь-які подання з форми InfoPath?
- Заповнити подання.
Під час додавання нового подання до форми використовується шаблон макета сторінки. Тут можна додати макетні таблиці із вкладки "Вставлення" стрічки, щоб структурувати форму, і додати елементи керування з вкладки "Основне" в групі "Елементи керування".
Також можна додати до нового подання елементи керування з однаковим полем, що й елементи керування, що використовуються в інших поданнях, перетягнувши відповідне поле з області завдань "Поля ".
- Налаштуйте інтерфейс навігації.
Як користувачі зможуть переміщатися у формі? Чи знає користувач, що означають команди за промовчанням для переключення подань? Чи достатньо команд за промовчанням, чи потрібно допомагати користувачам переключатися між поданнями, натискаючи кнопку, яка з'являється безпосередньо у формі? Якщо користувач натискатиме кнопку, чи будете ви використовувати інтерфейс користувача із вкладками чи кнопки «Назад» і «Далі»? Що потрібно робити з поданнями друку: одночасно чи лише активне?
Група «Подання» на вкладці «Макет сторінки»
На вкладці " Макет сторінки " стрічки в групі "Подання " можна додавати та видаляти подання, а також переключатися між різними поданнями. Щоб настроїти параметри та поведінку вибраного подання, натисніть кнопку «Властивості », щоб відкрити діалогове вікно «Властивості подання ».
Також можна створити й пов'язати подання друку з наявним поданням, спочатку створивши подання друку, щоб воно відображалося під час друку подання форми, а потім призначивши його наявному поданню в діалоговому вікні властивостей подання . Крім того, у діалоговому вікні "Властивості подання" на вкладках "Параметри друку" та "Параметри сторінки" можна також указати настроювані параметри друку для подання друку, наприклад колонтитули та поля сторінки.
Додавання подання
Щоб додати інші подання до форми, дотримуйтеся наведених нижче вказівок.
- Перейдіть на вкладку "Макет сторінки ", а потім у групі "Подання " натисніть кнопку "Створити подання".
- Введіть ім'я подання та натисніть кнопку "OK".
- Щоб відкрити діалогове вікно " Властивості подання ", перейдіть на вкладку " Макет сторінки ", а потім у групі "Подання " виберіть пункт "Властивості".
- У діалоговому вікні "Властивості подання" змініть або вкажіть потрібні параметри для подання, а потім натисніть кнопку "OK".
- Спроектуйте подання в робочій області, додавши до нього макетні таблиці та елементи керування.
Якщо ви хочете створити макет нового подання на основі наявного подання, відкрийте наявне подання, натисніть сполучення клавіш Ctrl+A , щоб виділити все у поданні, і натисніть сполучення клавіш CTRL+C , щоб скопіювати вибране до буфера обміну. Виберіть нове подання у списку Подання у групі Подання на вкладці Макет сторінки , видаліть попередньо заповнений вміст у поданні та натисніть клавіші Ctrl+V, щоб вставити виділений фрагмент у нове подання.
Видалення подання
Відновити видалене подання неможливо. Якщо видалити стандартне подання у формі, яка має лише одне подання, програма InfoPath автоматично створить нове подання за замовчуванням. Якщо видалити стандартне подання у формі з кількома поданнями, програма InfoPath призначить стан подання за замовчуванням наступному поданню в списку подань, що відображається на вкладці " Макет сторінки " в групі " Подання " у списку "Подання ".
- У списку "Подання" на вкладці "Макет сторінки" в групі "Подання" виберіть подання, яке потрібно видалити.
- На вкладці " Макет сторінки " в групі "Подання " натисніть кнопку "Видалити".
- Коли з'явиться запит на видалення подання, натисніть кнопку "Так".
Змінення подання за промовчанням
Кожна форма має подання за замовчуванням. Користувачі побачать це подання, коли відкриють форму, створену на основі вашої форми. Якщо для форми створено настроювані подання, можна вибрати, яке з доступних подань буде стандартним для користувачів.
- У списку "Подання" вкладки "Макет сторінки" в групі "Подання" виберіть подання, яке потрібно зробити стандартним.
- На вкладці " Макет сторінки " в групі "Подання " натисніть кнопку "Властивості".
- Установіть прапорець "Використовувати подання за промовчанням" і натисніть кнопку "OK".
Якщо форма має лише одне подання, воно автоматично призначається поданням за замовчуванням.
Перейменування подання
- У списку "Подання" на вкладці "Макет сторінки" в групі "Подання" виберіть подання, яке потрібно перейменувати.
- На вкладці " Макет сторінки " в групі "Подання " натисніть кнопку "Властивості".
- У діалоговому вікні "Властивості подання" введіть нову назву вкладки в текстове поле "Ім'я подання" та натисніть кнопку "OK".
Примітка.
Якщо перейменувати подання, пов'язане з настроюваним кодом, код може не працювати належним чином. Щоб вирішити цю проблему, потрібно знайти всі посилання на стару назву подання в коді та оновити їх новим ім'ям.
Додавання кнопки для переходу між поданнями
Подання часто призначені для роботи із правилами. Правила дають змогу автоматизувати певні завдання у відповідь на події або дії, ініційовані особою, яка заповнює форму. Наприклад, можна вставити кнопку у форму та створити правило, яке переключатиме подання в разі натискання кнопки. Вставивши кнопку у форму, можна зв'язати правило з кнопкою, щоб воно змінювало подання в разі натискання кнопки користувачем.
Зокрема, у формі страхової вимоги можна створити кнопку "Відобразити зведення ", натискання якої відкриває загальне подання даних про претензії. Після цього в поданні зведення користувачі можуть натиснути кнопку "Докладно", щоб повернутися до докладнішого подання. Аналогічно, якщо у вас дуже довга форма, ви можете розбити її на кілька подань і додати кнопки "Далі" й "Назад" або навігацію на вкладках , щоб користувачі могли переходити формою.
- Вставлення кнопки в кожному поданні.
Щоб виконати наведені нижче дії, потрібно мати форму з двома наявними поданнями.
- У списку "Подання" на вкладці "Макет сторінки" у групі "Подання" виберіть подання, до якого потрібно додати кнопку.
- Розмістіть курсор у формі, де потрібно вставити кнопку.
- On the Home tab, in the Controls group, select Button.
- Under Control Tools, click the Properties tab in the ribbon .
- У полі "Надпис" введіть назву кнопки та натисніть кнопку "OK".
Створіть правило, яке перемикає подання.
- Натисніть кнопку.
- У розділі " Знаряддя для керування" на вкладці "Властивості " в групі "Правила " натисніть кнопку "Додати правило".
- Виберіть пункт Після натискання цієї кнопки та виберіть пункт Переключення подань зі списку дій .
- У текстовому полі "Подання" виберіть подання, яке буде відображатися після натискання кнопки, а потім натисніть кнопку "OK".
Повторіть кроки 1 і 2, щоб створити додаткові кнопки та відповідні правила для кожного подання.
Додавши кнопки до подань і створивши необхідні правила, ми радимо перевірити форму, щоб переконатися, що вона працює належним чином.
На вкладці " Основне " в групі "Форма " натисніть кнопку "Попередній перегляд".
Натискайте кнопки, щоб переконатися, що ви можете переключатися між поданнями належним чином.
Подання, у якому ви працювали нещодавно, відображатиметься у вікні попереднього перегляду, якщо не створено правило, яке переключає подання залежно від ролі користувача під час завантаження форми.
Примітка.
У поданнях, доступних лише для читання, кнопки недоступні. Для навігації в поданнях лише для читання, наприклад у поданні відображення у формі списку SharePoint, скористайтеся кнопкою з зображенням і зніміть прапорець Приховати зображення в поданнях, доступних лише для читання , у діалоговому вікні властивостей елемента керування на вкладці " Властивості " стрічки.
Відображення подання за допомогою правила завантаження форми
Коли користувач відкриває форму, подання може бути специфічним для цього користувача або відповідати іншим умовам. Наприклад, якщо ви розробляєте форму, яка містить кілька ролей користувача та кілька подань, може бути корисно відобразити подання на основі призначеної користувачу ролі користувача. Зокрема, за допомогою правила можна відображати подання, коли користувач, призначений на певну роль користувача, відкриває форму, створену на основі вашої форми.
Ролі користувача можна використовувати лише у формах, розроблених для заповнювача InfoPath. Щоб переключити подання на основі участі у групі для веб-форм, варто створити правило завантаження форми , яке використовує метод getUserMemberships веб-служби профілю користувача для визначення членства користувачів.
Ця процедура передбачає, що у вас є роль, визначена у формі. Якщо у формі немає жодної ролі користувача, додайте її на вкладці "Дані ", перш ніж почати цю процедуру.
- На вкладці " Дані " в групі "Правила " натисніть кнопку "Завантаження форми".
- Клацніть елементи Створити, Дія, а потім у текстовому полі Докладно введіть ім'я правила.
- Щоб форма завантажила подання на основі ролі користувача, виберіть посилання в розділі "Умова ". У першому списку виберіть поточну роль користувача, а потім виберіть її.
Ви можете вибрати інші параметри залежно від умов, які мають вплинути на спосіб завантаження форми.
- Натисніть кнопку OK.
- Натисніть кнопку "Додати ", а потім виберіть "Переключити подання".
- У списку "Подання" виберіть потрібне подання та натисніть кнопку "OK".