Причини
Розглянемо таку ситуацію:
-
Ввімкнення спільного доступу до файлів cookie через масив членів в Microsoft Forefront Threat Management Gateway (TMG) 2010.
-
Веб-сайти, по Forefront TMG публікації.
У випадку наявних клієнтів, які вже є файл cookie для автентифікації не вдається отримати доступ до ресурсів, опубліковані і з'являється таке повідомлення про помилку:
1413 Неприпустимий індекс.
Примітка. Ця проблема стосується головним чином Exchange ActiveSync користувачів під час їх мобільний пристрій продовжує використання старий файл cookie пристрою перезавантаження або очищення на сервері.
Причина
Файл cookie, спільного доступу до файлів через масив членів, використовує новий формат файлів cookie та ідентифікаційний файл cookie, що надається наявних клієнтів не видаляється належним чином після того, як засіб спільного доступу до файлів cookie увімкнено.
Вирішення
Щоб вирішити цю проблему, інсталюйте на поточних 5 для Forefront Threat Management Gateway (TMG) 2010 з пакетом оновлень 2.
Виправлення помилок
Щоб вирішити цю проблему, перейменувати файл cookie, визначена на веб-прослуховувач. Щоб це зробити, виконайте такі дії:
-
Відкрийте консоль керування Forefront-TMG і клацніть Політика брандмауера.
-
На вкладці панель елементів у правій області вікна, розгорніть Об'єкти в мережі.
-
Розширення Веб-прослуховувачіпротоколу, який використовувався для публікування проблеми на веб-сайти, клацніть правою кнопкою миші та виберіть пункт Властивості.
-
На вкладці " форми " натисніть кнопку " Додатково".
-
В імені Файлу Cookie введіть окремий файл cookie як cadata2.
Примітка. За промовчанням це поле пусте та файлів cookie ім'я за промовчанням, який використовується, є cadata. -
Натисніть кнопку ОКі натисніть кнопку "OK" знову для того, щоб закрити діалогові вікна.
-
Натисніть кнопку Застосувати , щоб зберегти зміни.
Зачекайте, доки зміни на синхронізацію з Forefront TMG службу брандмауера. Для цього клацніть моніторингі виберіть конфігурацію. Клієнти, слід мати доступ до опублікованого веб-сайтів у всіх серверів, відображення стану Synced.
Або запитайте клієнти перезавантаження їх мобільного пристрою або закрийте всі вікна свої браузери. Це, видалення старого файлу cookie.
Стан
Корпорація Майкрософт підтвердила існування цієї неполадки у продуктах Майкрософт, перелічених у розділі "Застосовується до".
Посилання
Відомості про термінологію , яку використовує корпорація Майкрософт для опису оновлень програмного забезпечення.