Microsoft Business Solutions-Navision 4.0 і Microsoft Navision 4.0 тепер входять до складу Microsoft Dynamics NAV 4.0. Усі посилання на Microsoft Business Solutions-Navision або Microsoft Navision 4.0 стосуються Microsoft Dynamics NAV.
Ознаки
Під час спроби ввійти до клієнта Microsoft Dynamics NAV або microsoft Dynamics NAV власного сервера бази даних, з'являється таке повідомлення про помилку:
Операційна система повернула помилку (183):Не вдалося створити файл, якщо цей файл уже існує.
Примітка. Помилка 183 – це стандартне повідомлення про помилку операційної системи. Ця проблема виникає в таких продуктах:
-
Microsoft Dynamics NAV 5.0 із пакетом оновлень 1
-
Microsoft Dynamics NAV 5.0
-
Microsoft Dynamics NAV 4.0 із пакетом оновлень 3
-
Microsoft Dynamics NAV 4.0 із пакетом оновлень 2
-
Microsoft Dynamics NAV 4.0 із пакетом оновлень 1
-
Microsoft Dynamics NAV 4.0
-
Microsoft Business Solutions-Navision 3.7
Причина
Ця проблема виникає тому, що Microsoft Dynamics NAV створює тимчасові файли під час запуску Microsoft Dynamics NAV. Однак тимчасові файли не можна зберігати, якщо виконується одна з таких умов:
-
У файлах баз даних запущено антивірусне програмне забезпечення або програму безпеки.
-
Програмне забезпечення для резервного копіювання працює одночасно з вбудованим сервером баз даних Microsoft Dynamics NAV.
Спосіб вирішення
Щоб вирішити цю проблему, скористайтеся одним або кількома з наведених нижче способів.
-
Перезапустіть сервер бази даних Microsoft Dynamics NAV.
-
Переконайтеся, що в каталозі, у якому розташовано файли бази даних, не запущено жодного антивірусного програмного забезпечення та жодної програми безпеки.
-
Зупиніть службу Microsoft Dynamics NAV Server. Потім видаліть усі файли "_TEMP_.*" у папці інсталяції сервера Microsoft Dynamics NAV. Після цього перезапустіть Microsoft Dynamics NAV.Примітка. Переконайтеся, що видалено всі .dmp файли.
-
Надайте дозвіл "Повне читання" та "Повний запис" користувачу Microsoft Dynamics NAV у папці інсталяції Microsoft Dynamics NAV і в папці настройок документа, у якій зберігається файл ZUP. Примітка Microsoft Dynamics NAV створює тимчасові файли в цих папках. Видаліть файли .zup і всі файли _TEMP_.*" у цих папках. Після цього перезапустіть Microsoft Dynamics NAV.