Microsoft Business Solutions-Navision 4.0 і Microsoft Navision 4.0 тепер входить до складу Microsoft Dynamics NAV 4.0. Усі посилання на Microsoft Business Solutions-Navision або Microsoft Navision 4.0 посилаються на Microsoft Dynamics NAV.

Ознаки

Під час спроби ввійти у клієнт Microsoft Dynamics NAV або на сервер власної бази даних Microsoft Dynamics NAV з'являється таке повідомлення про помилку:

Операційна система повернула помилку (183): Не вдається створити файл, якщо такий файл уже існує.

Примітка. Помилка 183 – це повідомлення про помилку стандартної операційної системи. Ця проблема виникає в таких продуктах:

  • Microsoft Dynamics NAV 5.0 із пакетом оновлень 1

  • Microsoft Dynamics NAV 5.0

  • Microsoft Dynamics NAV 4.0 із пакетом оновлень 3

  • Microsoft Dynamics NAV 4.0 із пакетом оновлень 2

  • Microsoft Dynamics NAV 4.0 із пакетом оновлень 1

  • Microsoft Dynamics NAV 4.0

  • Microsoft Business Solutions-Navision 3.7

Причина

Ця проблема виникає, тому що Microsoft Dynamics NAV створює тимчасові файли під час запуску Microsoft Dynamics NAV. Однак тимчасові файли не можна зберігати за однієї з наведених нижче умов.

  • Антивірусне програмне забезпечення або програму безпеки запущено для файлів баз даних.

  • Резервне копіювання програмного забезпечення працює одночасно з сервером власної бази даних Microsoft Dynamics NAV.

Спосіб вирішення

Щоб вирішити цю проблему, скористайтеся одним із наведених нижче способів.

  • Перезапустіть сервер бази даних Microsoft Dynamics NAV.

  • Переконайтеся, що антивірусне програмне забезпечення не запущено, а в каталозі, де розташовано файли баз даних, не запущено жодну програму безпеки.

  • Зупиніть службу Microsoft Dynamics NAV Server. Потім видаліть усі файли "_TEMP_.*" у папці інсталяції сервера Microsoft Dynamics NAV. Потім перезапустіть Microsoft Dynamics NAV.Примітка. Переконайтеся, що ви видалили всі файли DMP.

  • Надайте дозвіл "Повне читання" та "Повне записування" користувачу Microsoft Dynamics NAV у папці інсталяції Microsoft Dynamics NAV і в папці параметрів документа, у якій зберігається ZUP-файл. Примітка. Microsoft Dynamics NAV створює тимчасові файли в цих папках. Видаліть ZUP-файл і всі" файли _TEMP_.*" з цих папок. Потім перезапустіть Microsoft Dynamics NAV.

Потрібна додаткова довідка?

Потрібні додаткові параметри?

Ознайомтеся з перевагами передплати, перегляньте навчальні курси, дізнайтесь, як захистити свій пристрій тощо.