Під час інсталяції Бізнес-порталу 5.1 для Microsoft Dynamics GP 2010 відображається повідомлення про помилку "Не вдалося викликати службу каталогу бізнес-даних. Переконайтеся, що служби запущено, і спробуйте ще раз".
Ознаки
Служба підключення до бізнес-даних не існує.
Причина
Виконайте наведені нижче кроки, щоб вирішити цю проблему:
1. Натисніть кнопку Пуск, наведіть вказівник миші на пункт Усі програми, виберіть пункт Продукти Microsoft SharePoint 2010 і клацніть SharePoint 2010 Центру адміністрування. 2. Клацніть Керування програмами. 3. В області Service Applications (Програми-служби) клацніть Manage Service Applications (Керування застосунками-службами). 4. Якщо в стовпці Тип немає застосунку-служби підключення до бізнес-даних, перейдіть до кроку 5. 5. Натисніть кнопку Створити, а потім виберіть пункт Служба підключення до бізнес-даних. 6. В області Ім'я застосунку-служби введіть ім'я програми-служби підключення до бізнес-даних. Наприклад, "BDC". 7. В області База даних перевірте, Microsoft SQL Server в області Сервер бази даних і прийміть стандартне значення для області Ім'я бази даних. Прийміть стандартну автентифікацію бази даних. 8. Прийміть значення за замовчуванням для області Failover Server (Сервер відновлення після відмови). 9. В області Пул застосунків виберіть або використайте наявний пул програм, або створіть новий пул програм. 10. Клацніть OK. 11. Переконайтеся, що стовпець Стан указує на те, що застосунок служби підключення до бізнес-даних запущено. 12. Клацніть Керування програмами. 13. В області Service Applications (Програми-служби) виберіть Manage Services On Server (Керування службами на сервері). 14. Переконайтеся, що служба підключення до бізнес-даних указує, що її запущено під стовпцем Стан, якщо ні, клацніть посилання Почати під стовпцем Дія служби, щоб запустити службу. 15. Знову запустіть інсталяцію бізнес-порталу.