Ознаки
Після інсталяції Microsoft Exchange Server 2019 сукупний пакет оновлень 13 (CU13), клієнтські пошуки в Microsoft Outlook, які використовують веб-служби Exchange (EWS), повертають неповні результати пошуку та код помилки "HTTP 503". Також може з'явитися таке повідомлення про помилку:
Не вдалося отримати результати із сервера.
Причина
Ця проблема зазвичай виникає після того, як ви надсилаєте повідомлення електронної пошти, яке містить параметри голосування та увімкнуто відстеження, або якщо в поштовій скриньці є елементи голосової пошти.
Тимчасове вирішення
Щоб вирішити цю проблему, виконайте пошук за допомогою Outlook в онлайновому режимі або інтернет-версія Outlook (OWA). Щоб перевірити, чи виникла у вас ця проблема, знайдіть відповідь "HTTP 503" на запит EWS для поштової скриньки, у якій виконується пошук. Потім виконайте вказівки на сервері в наступному розділі.
Додаткові відомості
Щоб переконатися, що користувачі стикаються з цією проблемою, адміністратори можуть використовувати оболонку керування Exchange (EMS) на сервері, на якому підключено базу даних користувача. Щоб спочатку перевірити сервер, виконайте таку команду:
Get-MailboxDatabaseCopyStatus (Get-Mailbox "AffectedUserAlias").Database.Name | ? {$_. Стан –eq "Підключено"}
Сервер буде визначено у форматі <DatabaseName\ServerName>. Потім на цьому ж сервері виконайте такі команди:
$EXSCRIPTS компакт-дисків
. .\ManagedStoreDiagnosticFunctions.ps1
$MBX = Get-Mailbox "MailboxNameHere"
$DB = $MBX.Database.Name
$Display = $MBX. Коротке ім'я
$MailboxNumber = Get-StoreQuery -Database $DB -Query "SELECT MailboxNumber,DisplayName FROM Mailbox" -Unlimited | ? {$_. DisplayName –like $Display}
$Result = Get-StoreQuery -Database $DB -Query "SELECT MessageClass,FolderID,p10800003 FROM message WHERE MailboxNumber=$($MailboxNumber.MailboxNumber) AND
(p10800003=258 OR p10800003=259 OR p10800003=260 OR p10800003=263 OR p10800003=264 OR p10800003=266 OR p10800003=270 OR p10800003=283 OR p10800003=284 OR p10800003=304)" -Unlimited
Якщо змінна $Result повертає будь-які результати, ця проблема виникає у вас (або користувача). У цьому випадку відкрийте запит зі службою підтримки Microsoft і додайте до заголовка інциденту слово "PR_ICON_INDEX", щоб отримати допомогу з цієї відомої проблеми.