Перейти до основного
Підтримка
Вхід
Вхід за допомогою облікового запису Microsoft
Увійдіть або створіть обліковий запис.
Вітаємо,
Виберіть інший обліковий запис.
У вас є кілька облікових записів
Виберіть обліковий запис, за допомогою якого потрібно ввійти.

Причини

Розгляньмо такий випадок.

  • Принтер інсталяції за допомогою вбудовані драйвер на комп'ютері під керуванням ОС Windows 7 або Windows Server 2008 R2.

  • Новий або оновлений драйвер, який містить оновлення для файлу Unidrv.dll інсталяції.

  • Ви намагаєтеся змінити властивості черги друку, який має драйвер у вікні.

У цій ситуації, провідник Windows і з'являється таке повідомлення про помилку:

Windows Explorer перестав працювати

Windows можна перевіряти наявність спосіб вирішення проблеми та спробуйте перезавантажити програму.


Примітка. Ця проблема може виникати, у деяких ситуаціях, коли процес оновлення, Unidrv.dll. Наприклад, інсталяції пакета оновлень для Windows, зведеного або драйвер сторонніх виробників.

Причина

Ця проблема виникає, тому що новішу версію Unidrv.dll, викликає оновлення наявні черги друку. Процес оновлення, ініціює оновлення драйверів, додає параметр реєстру до черги друку, що використовує драйвер у вікні.

Вирішення

Important
Виконуйте дії, описані в цьому розділі, обережно. Неправильне внесення змін до реєстру може викликати серйозні проблеми. Перш ніж вносити такі зміни, резервної копії реєстру для відновлення на випадок, якщо виникають проблеми.

Щоб вирішити цю проблему, перейдіть до розділу ",Автоматичне виправлення". Щоб вирішити цю проблему самостійно, перейдіть до розділу ",виправити вручну".


Виправити для себе

Щоб вирішити цю проблему, натисніть кнопку на Автоматичне або посилання під нею. Натисніть запустити у діалоговому вікні Завантаження файлу і дотримуйтесь інструкцій майстра Fix it .



  • Цей майстер може бути лише англійською мовою. Проте автоматичне виправлення працює також для інших мовних версій Windows.

  • Якщо ви не на комп'ютері, на якому виявлено неполадку, збережіть рішення для виправлення на флеш-пам'ять або компакт-диск, а потім запустіть на комп'ютері, на якому виявлено неполадку.

  • Будемо вдячні за ваш відгук. Щоб надіслати відгук або повідомити про будь-які проблеми з цим рішенням, залиште коментар у блозі ",Автоматичне виправлення" або надіслати повідомлення електронної пошти .



Щоб вирішити цю проблему, видаліть, запис реєстру, який додається під час оновлення для драйвера. Щоб це зробити, виконайте такі дії:

  1. Відкрийте пристрої та принтери і потім, визначити ім'я принтера черги друку проблему.

    У цьому прикладі ми визначити, чи проблема принтера "HP лазерний Jet 4100 серії PCL6".


  2. Відкрийте редактор реєстру. Для цього натисніть кнопку Пуск, введіть regedit.exe , у полі пошуку та натисніть клавішу Enter.

  3. Знайдіть і розгорніть такий розділ реєстру:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Printers

  4. Розгорніть підрозділ реєстру, який має ім'я принтер проблему виявлено на кроці 1 і клацніть PrinterDriverData.


  5. Резервне копіювання PrinterDriverData підрозділу реєстру. Щоб це зробити, виконайте такі дії:

    • PrinterDriverData, клацніть правою кнопкою миші та виберіть експортувати.

    • У полі Ім'я файлу , введіть ім'я для експортованого розділ реєстру.

    • Натисніть кнопку на збереження для експорту та зберегти вибраний розділ реєстру.

  6. Параметр реєстру DMCExist , на правій панелі, клацніть правою кнопкою миші та виберіть Видалити. Натисніть так , коли буде запропоновано, щоб підтвердити видалення.

    Примітка. Якщо проблема виникає більше однієї черги, повторіть ті ж самі процедури, для цих принтерів.

  7. Закрийте редактор реєстру.

  8. Зупиніть та перезапустіть спулер друку. Для цього скористайтеся одним із наведених нижче способів.

    Спосіб 1: Використання консолі служб:

    1. Натисніть кнопку Пуск, введіть Services. msc , у полі пошуку та натисніть клавішу Enter.

    2. Відкрийте "Спулер друку"Stopта виберіть клацніть запустити.

    Спосіб 2: Використання, у командному рядку:

    1. Відкрийте командний рядок у режимі адміністратора.

    2. Запустіть таку команду, щоб припинити спулер друку:

      Net Stop Spooler

    3. Запустіть таку команду, щоб запустити спулер друку:

      Net Start Spooler

  9. Перевірте, щоб підтвердити, що проблему вирішено.


Продукти сторонніх виробників, які розглядаються в цій статті, розроблені компаніями, що не залежать від корпорації Майкрософт. Корпорація Майкрософт не надає жодних гарантій, неявних або інших, стосовно продуктивності або надійності цих продуктів.

Потрібна додаткова довідка?

Потрібні додаткові параметри?

Ознайомтеся з перевагами передплати, перегляньте навчальні курси, дізнайтесь, як захистити свій пристрій тощо.

Спільноти допомагають ставити запитання й відповідати на них, надавати відгуки та дізнаватися думки висококваліфікованих експертів.

Чи ця інформація була корисною?

Наскільки ви задоволені якістю мови?
Що вплинуло на ваші враження?
Натиснувши кнопку "Надіслати", ви надасте свій відгук для покращення продуктів і служб Microsoft. Ваш ІТ-адміністратор зможе збирати ці дані. Декларація про конфіденційність.

Дякуємо за відгук!

×