疑難排解 Microsoft Security Essentials  的更新問題

注意

  • Windows 7 的支援服務已於 2020 年 1 月 14 日終止。
  • 建議您移至 Windows 11 電腦,以便繼續接收 Microsoft 的安全性更新。

Microsoft Security Essentials 會搭配 Microsoft Update 自動運作,以確保您的病毒及間諜軟體定義會保持最新狀態。

症狀

以下是一些關於自動更新的常見問題︰

  • 您看到表示更新已失敗的錯誤訊息。
  • 當您檢查更新時,您收到錯誤訊息,表示無法檢查、下載或安裝病毒及間諜軟體定義更新。
  • 即使已連線到網際網路,仍無法更新。
  • 更新未依排程自動安裝。

原因

產生更新問題的最常見原因是網際網路連線的問題。 如果您在線上,則問題可能是與 Windows Internet Explorer 中的設定發生衝突所導致。 

解決方案

注意

您必須先結束 Internet Explorer,才能完成這些步驟。 因此,列印或寫下它們,或者將它們複製到另一個檔案,然後將本主題加入書籤以供日後存取。

步驟 1: 重設 Internet Explorer 設定

  1. 結束所有開啟的程式,包括 Internet Explorer。

    注意

    在 Internet Explorer 中重設這些設定,會刪除暫存檔、Cookie、瀏覽歷程記錄,以及您的線上密碼。 但不會刪除 [我的最愛]。

  2. 按一下 [開始],並在 [開始搜尋] 方塊中輸入 inetcpl.cpl,然後按 Enter

  3. 網際網路選項 對話框中,點選 進階 標籤。

  4. 在 [重設 Internet Explorer] 設定下方,按一下 [重設],然後再次按一下 [重設]

  5. 等候 Internet Explorer 完成重設這些設定,然後按一下 [確定]

  6. 開啟 Internet Explorer。

  7. 打開 Microsoft Security Essentials,點選 「更新 」標籤,然後再點 「更新」。 如果問題持續發生,請繼續進行下一個步驟。

步驟 2: 將 Internet Explorer 設定成預設瀏覽器

  1. 結束所有開啟的程式,包括 Internet Explorer。
  2. 按一下 [開始],並在 [開始搜尋] 方塊中輸入 inetcpl.cpl,然後按 Enter
  3. 在 [網際網路選項] 對話方塊中,按一下 [程式] 索引標籤。
  4. 在 [預設網頁瀏覽器]下方,按一下 [設成預設值]。 按一下 [確定]
  5. 開啟 Microsoft Security Essentials。 按一下 [更新] 索引標籤,然後按一下 [更新]。 如果問題持續發生,請繼續進行下一個步驟。

步驟 3: 確認電腦上的日期和時間正確無誤

  1. 開啟 Microsoft Security Essentials。
  2. 如果您收到的錯誤訊息包含錯誤碼 0x80072f8f,則問題最有可能是因為電腦上的日期或時間設定不正確而導致。
  3. 若要重設電腦的日期或時間設定,請依照修復桌面捷徑無法刪除及一般系統維護工作中的步驟執行。

步驟 4: 重新命名電腦上的 [Software Distribution] 資料夾

  1. 停止自動更新服務

    1. 依序按一下 [開始] 和 [執行],輸入 services.msc,然後按一下 [確定]
    2. 以滑鼠右鍵按一下 [自動更新] 服務,然後按一下 [停止]
    3. 將 [服務] 嵌入式管理單元最小化。
  2. 如果您收到的錯誤訊息包含錯誤碼 0x80072f8f,則問題最有可能是因為電腦上的日期或時間設定不正確而導致。

  3. 重新命名 SoftwareDistribution 目錄,如下所示︰

    1. 按一下 [開始],再按一下 [執行],輸入 cmd,然後按一下 [確定]
    2. 輸入 cd %windir%,然後按 Enter
    3. 輸入 ren SoftwareDistribution SDTemp,然後按 Enter
    4. 輸入 exit,然後按 Enter
  4. 啟動自動更新服務,如下所示:

    1. 將 [服務] 嵌入式管理單元最大化。
    2. 以滑鼠右鍵按一下 [自動更新] 服務,然後按一下 [啟動]
    3. 關閉 [服務] 嵌入式管理單元視窗。

步驟 5: 重設電腦上的 Microsoft 防毒更新引擎

  1. 依序按一下 [開始]、[所有程式] 和 [附屬應用程式],接著在 [命令提示字元] 上按一下滑鼠右鍵,然後選取 [以系統管理員身分執行]

  2. 在 [命令提示字元] 視窗中,輸入下列命令,並在每一個命令之後按 Enter

    • CD\
    • Cd program files\microsoft security essentials
    • Mpcmdrun –removedefinitions –all
    • 結束
  3. 重新啟動電腦。

  4. 打開 Microsoft Security Essentials,點選 「更新 」標籤,然後再點 「更新」。 如果問題持續發生,請繼續進行下一個步驟。

步驟 6: 手動安裝病毒及間諜軟體定義更新

按一下 [執行]。 在電腦上手動安裝最新的更新。

步驟 7: 連絡客戶支援

如果這些步驟無法解決問題,請連絡客戶支援。 欲了解更多資訊,請參閱客戶支援。