向工作表窗体添加窗体和 ActiveX 控件后,可能需要对控件进行分组、复制、移动或对齐,以创建设计合理、用户友好的窗体。
若要执行本文中的任何过程,如果一个或多个控件是 ActiveX 控件,则必须首先确保 “开发工具 ”选项卡可用。
显示“开发工具”选项卡
-
- 单击“ 文件>选项”>“自定义功能区”。
- 在 “自定义功能区”下,单击下拉列表中的 “主选项卡” 。
- 选中“ 开发人员 ”复选框,然后单击“ 确定”。
确保处于设计模式。 在 “开发人员 ”选项卡上,单击 “设计模式
”。
对控件进行分组、取消组合或重新组合
对控件进行分组时,可以将它们组合起来,以便可以像使用单个控件一样使用它们。 例如,可以将组中的所有控件调整大小或移动为一个单元。
注意
不能将窗体控件或 ActiveX 控件与绘图工具或 SmartArt 工具对象 (如形状和 SmartArt 图形) 组合在同一组选定内容中。
组控件
- 选择要分组的控件。 有关详细信息,请参阅 选择或取消选择工作表上的控件。
- 右键单击所选内容,指向“ 分组”,然后单击“ 分组”。
取消组合控件
选择要取消组合的组合。 有关详细信息,请参阅 选择或取消选择工作表上的控件。
右键单击所选内容,指向 “分组”,然后单击“ 取消分组”。
- 要继续取消分组,请在消息框出现时单击 “是 ”。
- 若要更改单个控件,请继续选择和取消组合控件,直到所需控件可用。
重新组合控件
- 选择之前分组的任一控件。 有关详细信息,请参阅 选择或取消选择工作表上的控件。
- 右键单击所选内容,指向“ 分组”,然后单击“ 重新组合”。
复制一个或多个控件
注意
不能将窗体控件或 ActiveX 控件与绘图工具或 SmartArt 工具对象 (如形状和 SmartArt 图形) 组合在同一组选定内容中。
通过使用复制和粘贴命令
- 选择一个或多个控件。 有关详细信息,请参阅 选择或取消选择工作表上的控件。
- 要创建控件的单个副本,请依次单击“ 主页”、“ 复制
”和“ 粘贴”
。
若要进行多次复制,请重复粘贴,直到获得所需份数。
通过使用键盘和鼠标
- 选择一个或多个控件。 有关详细信息,请参阅 选择或取消选择工作表上的控件。
- 按 Ctrl 并拖动控件。
若要创建多个副本,请重复拖动,直到获得所需份数。
移动一个或多个控件
注意
不能将窗体控件和 ActiveX 控件与绘图工具或 SmartArt 工具对象 (如形状和 SmartArt 图形) 在同一组选定内容中组合。
通过使用鼠标
- 选择一个或多个控件。 有关详细信息,请参阅 选择或取消选择工作表上的控件。
- 将指针放在控件上,直到指针变为交叉指针,然后将选定的一个或多个控件拖动到另一个位置。
使用键盘
- 选择一个或多个控件。 有关详细信息,请参阅 选择或取消选择工作表上的控件。
- 按箭头键以单个像素增量移动控件。
在对象堆叠顺序中向前或向后移动控件
添加控件和绘图画布上的其他对象时,它们会自动堆叠到各个图层中。 当控件重叠时,可以看到堆叠顺序 - 顶部控件部分覆盖其下方的控件。
注意
窗体和 ActiveX 控件的对象堆叠顺序与绘图工具和 SmartArt 工具对象(如形状和 SmartArt 图形)是分开的。
选择控件。 有关详细信息,请参阅 选择或取消选择工作表上的控件。
右键单击所选内容,指向 “顺序”,然后执行下列操作:
- 要按堆叠顺序将控件向上移动一层,请单击 “向前移动”。
- 要按堆叠顺序将控件移动到顶层,请单击“ 置于顶层”。
- 要在堆叠顺序中将控件向下移动一个图层,请单击“ 向后发送”。
- 要按堆叠顺序将控件移到最底层,请单击“ 发送到底层”。
对齐和分配控件
注意
不能将窗体控件和 ActiveX 控件与 SmartArt 工具对象 (如形状和 SmartArt) 组合在同一组选定内容中。
将所有控件与网格或形状对齐
- 选择控件。 有关详细信息,请参阅 选择或取消选择工作表上的控件。
- 若要将所有对象与单元格的左上角对齐,请单击“绘图工具格式”选项卡,单击“对齐”旁边的箭头,然后单击“对齐
到网格
”。
无论网格线打开还是关闭,“对齐到”功能都可以工作。 移动控件或对象时还可以按住 Alt 键,以使控件与单元格网格线对齐。 - 若要在移动或绘制控件时自动与其他形状的垂直和水平边缘对齐,请单击“绘图工具”的“格式”选项卡,单击“对齐”旁边的箭头,然后单击“对齐
到形状
”。
按边缘对齐控件
重要
对齐控件可能会导致它们堆叠在一起。 在运行命令对齐控件之前,请确保控件彼此相对于放置时按照所需方式放置。
选择控件。 有关详细信息,请参阅 选择或取消选择工作表上的控件。
若要对齐控件,请单击 “绘图工具 格式”选项卡,然后单击“ 对齐”
旁边的箭头。 执行下列操作之一:- 要按最顶部的控件对齐控件,请单击 “顶部
对齐”。 - 若要按最下面的控件对齐控件,请单击 “底部
对齐”。 - 要按最左侧的控件对齐控件,请单击 “左
对齐”。 - 要通过最右边的控件对齐控件,请右 对齐
。
- 要按最顶部的控件对齐控件,请单击 “顶部
水平或垂直对齐控件
选择控件。 有关详细信息,请参阅 选择或取消选择工作表上的控件。
若要对齐控件,请单击 “绘图工具 格式”选项卡,单击“ 对齐
”旁边的箭头,然后执行下列操作之一:- 要通过控件的中间水平对齐控件,请单击“中间
对齐”。 - 若要使控件垂直对齐控件的中心,请单击“ 居中对
齐”。
- 要通过控件的中间水平对齐控件,请单击“中间
水平或垂直分布控件
选择至少三个控件。 有关详细信息,请参阅 选择或取消选择工作表上的控件。
若要分布控件,请单击 “绘图工具 格式”选项卡,单击“ 对齐
”旁边的箭头,然后执行下列操作之一:- 要水平均匀地放置控件,请单击 “水平
分布”。 - 要使控件垂直均匀分布,请单击“ 垂直
分布”。
- 要水平均匀地放置控件,请单击 “水平