重要
Power View 将于 2021 年 10 月 12 日从 Microsoft 365 专属 Excel 和 Excel 2021 中删除。 作为替代方法,你可以使用 Power BI Desktop 提供的交互式视觉体验,你可以免费下载该体验。 还可以轻松地将 Excel 工作簿导入 Power BI Desktop。
图像非常适合为 Excel 中的 Power View 工作表或 SharePoint 中的 Power View 添加视觉吸引力。 你可以:
本文内容
将静态图像添加到 Power View
您可以添加图像和背景图像以用于设计或识别目的。 图片和背景图像不会在工作簿或报表的每个工作表或视图中重复。 您可以使用唯一的图像,也可以在每个工作表或视图上重复使用它们。
添加背景图像
- 如果使用的是 Excel,请确保你使用的是 Power View 工作表。 如果没有, 请插入>Power View。
- 在 Power View 选项卡的“背景图像”部分>>,设置图像。
可以使用 “拉伸”、“ 平铺”或 “居中”来定位图像。 - 设置透明度。 百分比越高,图像 (越透明,) 越不明显。
添加图像
在空白画布上,在 Power View 工作表的 Power View 选项卡>上,插入>图片。
导航到图像,然后单击“ 打开”。
图像位于工作表后,可:
- 移动它:选择它,然后将鼠标悬停在边缘上,直到看到指针光标。
- 调整大小:选择它,然后将鼠标悬停在边缘中间和角落的大小调整手柄上,直到看到双箭头光标。
- 移动它:选择它,然后将鼠标悬停在边缘上,直到看到指针光标。
在 Power View 中使用数据绑定图像
数据绑定图像是数据模型中数据的一部分。 例如,您可以拥有公司员工或产品的照片。
您可以在 Power View 中使用这些图像,使报表更有意义和更具吸引力:
可能需要 在 Power Pivot 中设置属性 ,以便可以在 Power View 中使用图像。 数据绑定图像可以是 数据模型的内部或外部。 它们的来源会影响你如何使用它们。
磁贴容器中选项卡形式的图像
Power View 中的磁贴 是具有动态导航带的容器。 图块可充当筛选器,按在选项卡条中选择的值筛选图块内的内容。 图像在图块中是很好的选项卡。
- 在 Power View 工作表或视图上,创建所需的磁贴可视化效果。
- 将图像字段拖动到 平铺依据 框。
Power View 在选项卡条中创建带有图像的磁贴。
你可以使用磁贴执行更多操作。 了解 Power View 中的图块。
卡中的图像
- 在 Power View 工作表上,在卡中添加所需的字段。
- 在 “设计 ”选项卡 >上,表格>卡片。
Power View 按它们在 “字段” 框中的顺序排列字段,但有两个例外:
- 默认字段显示为标题。
- 默认图像较大且突出显示。
图像作为切片器中的值
在 Power View 工作表或视图上,单击空白画布。
在字段列表中,检查包含图像的字段的框。
Power View 使用这些图像创建一个表。
在 “设计 ”选项卡 >上 切片器。
提示
如果“切片器”灰显,请检查表中是否有多个字段。 只能从具有一个字段的表创建切片器。
现在,当您单击切片器中的图像时,工作表将筛选为与该图像关联的值。
了解 Power View 中的切片器。
在 Power Pivot 中设置图像属性以在 Power View 中使用
在 Power Pivot 中设置默认图像
如果数据位于 Excel 中,则可以在 Power Pivot 中设置默认图像。 添加到卡时,默认图像更大,放置更醒目。 要设置为默认图像,图像 (或指向图像) 链接必须位于它们唯一的表中 - 这意味着每一行包含不同的图像。
- 在 Excel > 的“Power Pivot”选项卡上,“管理数据模型”。
看不到“PowerPivot”选项卡? 启用 PowerPivot。 - 单击 “高级>表行为”。
- 设置 行标识符 – 例如,包含唯一 ID 的列。 “行标识符”列中的值必须是唯一的。
- 将 “默认图像” 设置为图像列的名称。
提示
如果还设置了 默认标签,它将显示在图块容器中的图像下方。
阅读有关 配置 Power View 报表的表行为属性的信息。
控制排序顺序
设置默认图像的另一个优点是您可以控制图像的排序顺序。 默认情况下,切片器和磁贴中的图像按图像的文件名排序,但如果将图像标识为默认图像,则将根据“行标识符”列对其进行排序。 如果您将另一列标识为“默认标签”列,则图像将根据该列中的值进行排序。
如果数据位于 Excel 中,并且图像位于行不唯一的表中,则仍可将排序顺序设置为另一个字段。
- 在“Power Pivot”选项卡>上,“管理数据模型”。
看不到“PowerPivot”选项卡? 启用 PowerPivot。 - 单击包含图像或图像 URL 的列。
- 在“开始”选项卡>上,按列排序。
- 图像列位于 “排序 ”框中。
- 在“ 依据” 框中,选择要作为图像排序依据的列的名称。
- 单击“确定”。
数据绑定图像的源
Power View 报表中的图像可能来自多个来源:
- 在 外部网站上。
- 在 数据模型中。
- 在 SharePoint 网站上。
外部网站上的图像
当图像位于外部站点上时,Power View 匿名访问图像,因此图像必须允许匿名访问。 因此,即使报表读取者具有查看图像的权限,图像仍可能不可见。
外部网站上图像的过程同样适用于 SharePoint 上的图像,当然,除了 URL 是指向外部网站而不是 SharePoint 网站之外。
假设你有权访问外部网站上的一组图像,并且在 Excel 中,表中有一个包含图像名称的列。 管理图像链接的最灵活方法是创建计算列,将图像名称和 URL 引入外部网站上图像的位置。
- 将 URL 复制到外部站点。
- 在 Excel > 的“Power Pivot”选项卡上,“管理数据模型”。
看不到“PowerPivot”选项卡? 启用 PowerPivot。 - 单击“ 添加列 ”列中的空白单元格,键入等号 (=) 、用引号 (“”) 括起的 URL 以及方括号中图像列名称 ([]) 。 例如:
=“http://contoso.com/images” & [ImageNameColumn] - Power Pivot 将使用 URL 和图像名称填充列中的每个单元格。
- 单击列标题,右键单击,单击“ 重命名列”,然后为列指定一个信息名称。
- 要确保这有效,请复制其中一个值并将其粘贴到浏览器的“地址”框中。 它应该会显示图像。
注意
外部图像无法显示在 Microsoft 365 的 Power View 工作表中。 图像需要存储在数据模型的表中。
存储在数据模型中的图像
在数据模型中使用图像具有以下优势:
- 工作簿已完成。 您可以将其脱机,但仍可以看到图像。
- 图像将显示在 Microsoft 365 的 Power View 工作表中。
图像需要位于二进制数据类型的列中。 在 Power Pivot 中看不到图像;列中的每个字段将只显示“二进制数据”。 但是,当你将该字段添加到 Power View 时,图像将显示在此处。
重要
仅当基础表具有“行标识符”列时,二进制列中的图像才会在 Power View 的字段列表中可见。 阅读有关 配置 Power View 报表的表行为属性的信息。
如果您有权访问 SQL Server,则可以将图像导入 SQL Server,然后将它们上传到模型。
重要
Power View 不支持 OLE 对象作为图像。 这意味着无法从 Access 将图像导入模型,因为 Access 会将图像存储为 OLE 对象。
SharePoint 文件夹中的图像
如果使用的是 SharePoint 中的 Power View, (而不是 Excel) 中的 Power View,则可以通过与在外部网站上链接到图像相同的方式链接到 SharePoint 文件夹中的图像。
注意
在桌面版 Excel 中,仅当图像允许匿名访问(大多数 SharePoint 配置不允许)时,Power View 工作表才能显示存储在 SharePoint 网站上的图像。 因此,即使你和你的工作簿读取者有权直接在 SharePoint 网站上查看图像,Excel 中的 Power View 也可能无法显示它们。