管理数据预览 (Power Query)

应用对象
Microsoft 365 专属 Excel Excel 2024 Excel 2021

可以通过设置不同的选项来管理 Power Query 编辑器中数据预览的多个方面。 其中一些选项对性能的影响很有帮助。   

显示用于解释 Merge 命令的示例数据的屏幕截图。

设置后台数据选项

可以控制预览数据的下载方式,无论是直接下载还是在后台下载。

  1. 执行下列操作之一:

    • 在 Excel 中,选择 “数据>获取数据>”查询选项。
    • 在 Power Query 编辑器中,选择“文件>选项”和“设置>”查询选项“。
  2. 在左窗格的 “全局”下,选择 “数据加载”,然后在 “后台数据”下,选择以下选项之一:

    • 始终允许在后台下载数据预览
    • 允许根据每个文件的设置在后台下载数据预览
    • 从不允许在后台下载数据预览
  3. 在左窗格的 “当前工作簿”下,选择“ 数据加载”,然后在 “后台数据”下,选中或清除“ 允许在后台下载数据预览”。

设置查看数据预览的不同方式

可以使用等宽字体查看数据,或显示特殊字符,如换行符。

设置当前预览数据的选项

  1. 在 Power Query 编辑器中,选择“视图”,然后在“数据预览”组中选择或清除以下选项之一:

    • 固定宽度字体 使用固定宽度字体显示预览内容。
    • 显示空格 显示空格和换行符。
    • 列质量 在数据预览中显示列质量详细信息。
    • 列分布 在数据预览中显示列值分布。
    • 列配置文件 在详细信息窗格中显示列配置文件。

为所有工作簿设置选项

  1. 选择“文件>”选项和设置>“查询选项”>Power Query 编辑器>数据预览。

  2. 在左窗格的“全局”下,选择“Power Query 编辑器”。

  3. 在右窗格的 “数据预览”下,选择或清除以下选项:

    • 使用等宽字体显示预览内容
    • 显示空格和换行符

设置列分析

默认情况下,列分析基于前 1,000 行数据,以提高在 Power Query 编辑器中工作时的性能。 如需更完整的统计数据和分析信息,可以切换到基于整个数据集的分析。 对于大型数据集,此选项可能需要更长的时间来计算。

  1. 若要打开查询,请找到之前从 Power Query 编辑器加载的查询,在数据中选择一个单元格,然后选择“查询编辑”>。 有关详细信息,请参阅在 Excel 中创建、加载或编辑查询 (Power Query) 。

  2. 在“数据预览”窗格的右下角,选择列和行计数右侧的命令之一:

    • 基于前 1000 行的列分析
    • 基于整个数据集的列分析

另请参阅

Microsoft Power Query for Excel 帮助