Microsoft Security Essentials 更新问题疑难解答
注意
- Windows 7 支持已于 2020 年 1 月 14 日结束。
- 我们建议你转到 Windows 11 电脑来继续从 Microsoft 接收安全更新。
Microsoft Security Essentials 与 Microsoft 更新自动配合使用,以确保你的病毒和间谍软件定义保持最新状态。
症状
下面是一些有关自动更新的常见问题:
- 你看到指示更新已失败的错误消息。
- 当你检查更新时,收到无法检查、下载或安装病毒和间谍软件定义更新的错误消息。
- 即使你已连接到 Internet,更新仍然失败。
- 更新无法按计划自动安装。
原因
更新问题的最常见原因是 Internet 连接有问题。 如果你处于联机状态,则问题可能由与 Windows Internet Explorer 中的设置之间的冲突所导致。
解决方案
注意
你必须退出 Internet Explorer 才能完成这些步骤。 因此,请将这些步骤打印出来,记录下来,或复制到另一文件中,然后为此主题添加书签以供将来访问。
步骤 1: 重置 Internet Explorer 设置
退出所有打开的程序,包括 Internet Explorer。
注意
在 Internet Explorer 中重置这些设置会删除临时文件、cookie、浏览历史记录和你的联机密码。 但是,不会删除你的收藏夹。
单击“开始”,在“开始搜索”框中键入“inetcpl.cpl”,然后按“Enter”。
在“ Internet 选项 ”对话框中,单击“ 高级 ”选项卡。
在“重置 Internet Explorer”设置下,单击“重置”,然后再次单击“重置”。
等待 Internet Explorer 完成重置设置的操作,然后单击“确定”。
打开 Internet Explorer。
打开Microsoft Security Essentials,单击“ 更新 ”选项卡,然后单击“ 更新”。 如果问题仍然存在,请继续执行下一步。
步骤 2: 将 Internet Explorer 设置为默认浏览器
- 退出所有打开的程序,包括 Internet Explorer。
- 单击“开始”,在“开始搜索”框中键入“inetcpl.cpl”,然后按“Enter”。
- 在“Internet 选项”对话框中,单击“程序”选项卡。
- 在“默认 Web 浏览器”下,单击“设为默认值”。 单击“确定”。
- 打开 Microsoft Security Essentials。 单击“更新”选项卡,然后单击“更新”。 如果问题仍然存在,请继续执行下一步。
步骤 3: 确保在电脑上正确设置日期和时间
- 打开 Microsoft Security Essentials。
- 如果你收到的错误消息包含代码 0x80072f8f,则问题很可能由电脑上的日期或时间设置错误所导致。
- 若要重置电脑的日期或时间设置,请按照修复损坏的桌面快捷方式和常见系统维护任务中的步骤进行操作。
步骤 4: 重命名电脑上的“Software Distribution”文件夹
停止自动更新服务
- 依次单击“开始”、“运行”,键入“services.msc”,然后单击“确定”。
- 右键单击“自动更新”服务,然后单击“停止”。
- 最小化服务管理单元。
如果你收到的错误消息包含代码 0x80072f8f,则问题很可能由电脑上的日期或时间设置错误所导致。
按如下方式重命名“SoftwareDistribution”目录:
- 单击“开始”,单击“运行”,键入 cmd,然后单击“确定”。
- 键入“cd %windir%”,然后按“Enter”。
- 键入“ren SoftwareDistribution SDTemp”,然后按“Enter”。
- 键入 exit,然后按 Enter。
按如下方式启动自动更新服务:
- 最大化服务管理单元。
- 右键单击“自动更新”服务,然后单击“启动”。
- 关闭服务管理单元窗口。
步骤 5: 重置电脑上的 Microsoft 防病毒更新引擎
依次单击“开始”、“所有程序”和“附件”并右键单击“命令提示符”,然后选择“以管理员身份运行”。
在“命令提示符”窗口中,键入以下命令并在每个命令后按“Enter”:
- Cd\
- Cd program files\microsoft security essentials
- Mpcmdrun –removedefinitions –all
- 退出
重启电脑。
打开Microsoft Security Essentials,单击“ 更新 ”选项卡,然后单击“ 更新”。 如果问题仍然存在,请继续执行下一步。
步骤 6: 手动安装病毒和间谍软件定义更新
- 如果运行的是 32 位 Windows 操作系统,请在 http://go.microsoft.com/fwlink/?LinkID=87342 手动下载最新更新。
- 如果运行的是 64 位 Windows 操作系统,请在 http://go.microsoft.com/fwlink/?LinkID=87341 手动下载最新更新。
单击“运行”。 最新更新将手动安装到你的电脑上。
步骤 7: 联系支持人员
如果上述步骤无法解决该问题,请联系支持人员。 有关详细信息,请参阅 客户支持。