简介
SQL Server 2008 Service Pack 3 的累积更新程序包 1 包含 Microsoft SQL Server 2008 Service Pack 3 (SP3) 发布后修复的问题的修补程序。
注意 此累积更新包的内部版本也称为内部版本 10.00.5766.00。
建议在将修补程序部署到生产环境中之前先测试修补程序。 由于版本是累积的,因此每个新更新版本都包含之前 SQL Server 2008 更新版本中包含的所有修补程序和安全更新。 建议考虑应用最新的更新版本。
有关更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
2629969 在 SQL Server 2008 Service Pack 3 发布之后发布的 SQL Server 2008 内部版本
有关此累积更新包的重要说明
- SQL Server 2008 的累积更新包现在支持多种语言。 因此,累积更新包并不特定于一种语言,而是适用于所有受支持的语言。
- 一个累积更新程序包包含所有组件包。 不过,累积更新程序包仅更新安装在系统中的组件。
详细信息
如何获取此累积更新程序包
Microsoft 现在提供了一个受支持的累积更新程序包。 但是,它仅用于更正本文中描述的问题。 仅将其应用于遇到这些特定问题的系统。 此累积更新包可能会接受额外的测试。 因此,如果你没有受到上述任何问题的严重影响,我们建议你等待包含此累积更新包中修补程序的下一个 SQL Server 2008 Service Pack。
如果累积更新可供下载,则本知识库文章顶部的“修补程序下载可用”部分。 如果此部分不存在,请联系 Microsoft 客户服务和支持人员以获取累积更新包。
注意 如果发生其他问题或需要进行任何故障排除,您应该另行创建服务请求。 通常的支持费用将应用于不符合此特定累积更新包条件的其他支持问题和问题。 若要获取 Microsoft 客户服务和支持部门的完整电话号码列表或另行创建服务请求,请访问以下 Microsoft 网站:
/contactus/?ws=support 注意 “修补程序下载可用”窗体显示累积更新的可用语言版本。 如果您找不到您的语言,是因为该语言的累积更新程序包不可用。
此累积更新包中包含的修补程序
讨论这些修补程序的 Microsoft 知识库文章将在可用时进行发布。
有关 SQL Server 问题的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
| VSTS 错误号 | 知识库文章编号 | 说明 |
|---|---|---|
| 810811 | 2344694 | 修复:在 SQL Server 2008 R2 或 SQL Server 2008 中发生自动数据库镜像故障转移后,某些更改跟踪功能和 SQL Server 无法正常工作 |
| 794317 | 2519638 | 修复:在 SQL Server 2008 或 2008 R2 SQL Server中,如果“@sync_type”参数设置为“仅复制支持”,则运行 sp_addsubscription 存储过程时出现错误 6512 |
| 794420 | 2524743 | 修复:对于 SQL Server 2008 或 SQL Server 2008 R2 环境中的数据库来说,恢复所需的时间比预期的要长 |
| 794318 | 2530921 | 修复:在 SQL Server 2008 或 SQL Server 2008 R2 中运行 INSERT SELECT UNION ALL 语句时出现错误结果 |
| 794413 | 2535660 | 修复:即使在 SSAS 2008 或 SSAS 2008 R2 中,即使 SynchronizeSecurity 元素设置为 SkipMembership 值,角色成员身份也会同步 |
| 794300 | 2539378 | 修复:如果存储过程包含超过 4,000 个字符,则 Replmerg.exe 在枚举对 SQL Server 中的语句所做的更改时崩溃 |
| 810756 | 2542225 | 修补程序:针对 SQL Server 2008 或 SQL Server 2008 R2 中具有两个索引的表或视图运行 DML 查询时,会发生断言失败或其他SQL Server |
| 794314 | 2543687 | 修补程序:客户端应用程序向 SQL Server 2008 或 SQL Server 2008 R2 发送注意信号时出现错误 |
| 794312 | 2546715 | 修复:当自定义存储过程传播 SQL Server 2008 或 SQL Server 2008 R2 中事务复制的数据更改时出现不收敛 |
| 794309 | 2562812 | 修复:如果 TVP 在 SQL Server 2008 或 SQL Server 2008 R2 中包含大量文本或图像数据,则跟踪包含 SQL Server 的存储过程时会出现错误代码 17065 |
| 809257 | 2574699 | 修复:即使物理文件在文件系统中标记为非稀疏文件,在 SQL Server 2008 R2 或 SQL Server 2008 中,数据库数据文件也可能被错误地标记为稀疏 |
| 810826 | 2574973 | 修复:在 SQL Server 2008 或 SQL Server 2008 R2 中,通过联机页面压缩提交的数据文件的大小大于通过脱机页面压缩提交的数据文件的大小 |
| 810779 | 2580224 | 修复:在 SSIS 2008 或 SSIS 2008 R2 中将 Unpivot 转换提交到 SSIS 包时,出现错误结果 |
| 810816 | 2588970 | 修复:如果架构版本更新超过五次,则在 SQL Server 2008 或 SQL Server 2008 R2 中运行分布式查询时出现“服务器:消息 7359”错误 |
| 810775 | 2591692 | 修复:如果在 SQL Server 2008 或 SQL Server 2008 R2 中的合并复制期间查询超时,则导致无法收敛或数据丢失 |
| 810773 | 2591902 | 修复:在 SQL Server 2005、SQL Server 2008 或 SQL Server 2008 R2 中,合并复制遇到外键冲突错误时,XML 数据丢失 |
| 810835 | 2605756 | 修复:从 SSAS 2005 升级到 SSAS 2008 或 SSAS 2008 R2 后,运行使用 Descendants 函数的 MDX 查询时出现内部错误 |
| 810772 | 2606301 | 修复:在 SQL Server 2008 或 SQL Server 2008 R2 中运行复制快照代理时,内存使用率过高 SQL Server |
| 810834 | 2608108 | 修复:如果 Me.Value 在用于访问 SSRS 2008 报表中文本框的 Value 属性时,如果报表具有页眉或页脚,则计算不正确 |
累积更新包信息
先决条件
要应用此累积更新程序包,必须运行 SQL Server 2008 SP3。
有关更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
968382 如何获取 SQL Server 2008 的最新 Service Pack
重启信息
应用此累积更新程序包后,可能必须重启计算机。
注册表信息
要使用此程序包中的某个修补程序,不必对注册表进行任何更改。
参考资料
有关 SQL Server 增量服务模型的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
935897
可从 SQL Server 团队获取增量服务模型以提供可以解决所报告问题的修补程序
有关 SQL Server 更新的命名架构的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
822499
Microsoft SQL Server 软件更新包的新命名架构
有关软件更新术语的更多信息,请单击下面的文章编号以查看 Microsoft 知识库中的相应文章:
824684
用于描述 Microsoft 软件更新标准术语的说明