KB2812412 - SQL Server 2012 Service Pack 1 累积更新程序包 3

应用对象
SQL Server 2012 Developer SQL Server 2012 Enterprise SQL Server 2012 Standard SQL Server 2012 Web

简介

本文介绍适用于 Microsoft SQL Server 2012 Service Pack 1 (SP1) 的累积更新包 3。 此更新包含用于解决 SQL Server 2012 SP1 发布后修复的问题的修补程序。

注意 累积更新包的内部版本号为 11.0.3349.0。

建议在将修补程序部署到生产环境中之前先测试修补程序。 由于版本是累积的,因此每个新更新版本都包含之前 SQL Server 2012 更新版本中包含的所有修补程序和安全更新。 建议考虑应用最新的更新版本。

  有关更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:

2772858 在 SQL Server 2012 Service Pack 1 发布之后发布的 SQL Server 2012 内部版本

有关此累积更新包的重要说明

  • SQL Server 2012 SP1 修补程序现在是多语言的。 因此,此累积更新不仅仅特定于一种语言。 它适用于所有支持语言。
  • 一个累积更新程序包包含所有组件包。 不过,累积更新程序包仅更新安装在系统中的组件。

详细信息

如何获取此累积更新程序包

Microsoft 现在提供了一个受支持的累积更新程序包。 但是,它仅用于更正本文中描述的问题。 仅将其应用于遇到这些特定问题的系统。 此累积更新包可能会接受额外的测试。 因此,如果你没有受到上述任何问题的严重影响,我们建议你等待包含此累积更新包中修补程序的下一个 SQL Server 2012 Service Pack。

如果累积更新可供下载,则本知识库文章顶部的“修补程序下载可用”部分。 如果此部分不存在,请联系 Microsoft 客户服务和支持人员以获取累积更新包。

注意 如果发生其他问题或需要进行任何故障排除,您应该另行创建服务请求。 通常的支持费用将应用于不符合此特定累积更新包条件的其他支持问题和问题。 若要获取 Microsoft 客户服务和支持部门的完整电话号码列表或另行创建服务请求,请访问以下 Microsoft 网站:

/contactus/?ws=support 注意 “修补程序下载可用”窗体显示累积更新的可用语言版本。 如果您找不到您的语言,是因为该语言的累积更新程序包不可用。

此累积更新包中包含的修补程序

讨论这些修补程序的 Microsoft 知识库文章将在可用时进行发布。

          有关 SQL Server 问题的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:

VSTS 错误号 知识库文章编号 说明
1158566 2755192 修复:当您执行与 SSRS 2008 R2 或 SSRS 2012 数据库的角色相关的管理操作时,SSMS 冻结
1155742 2761400 修复:在 SSAS 2008 R2 或 SSAS 2012 中,超时后将不完整的数据导入报告为成功
1169525 2764343 修复:在 SSRS 2012 中使用 SharePoint 网站的区域设置格式时不显示 DateTime 参数
1169524 2770635 修复:在对具有多个数据源的 SSAS 2008 R2 或 SSAS 2012 数据库运行 MDX 查询时,出现错误结果
1201576 2772525 改进了用于 SQL Server 2012 的 SQL Server Native Client 中的元数据发现进程性能
1201571 2783983 修复:在 SSDT 的控制流或数据流设计器窗口中拖动组件时,滚动条功能过于敏感
1145230 2791496 修复:在 SQL Server 代理作业中使用代理帐户运行两个以上的 PowerShell 步骤时,会发生安全令牌泄漏
1172950 2791745 修复:在 SQL Server 2008 或 SQL Server 2012 中的 IN 子句中运行包含多个常量值的查询时发生访问冲突
1207361 2794260 修复:在 SSAS 2008 R2 或 SSAS 2012 中使用 Analysis Services 个性化扩展时发生会话死锁
1207371 2800013 修复:在 SQL Server 2008 R2 或 SQL Server 2012 中脱机启用了 FILESTREAM 的数据库时发生访问冲突
1207373 2800797 修复:在 SQL Server 2008 R2 或 SQL Server 2012 中运行使用 CROSS APPLY 子句的 FULL JOIN 查询时出现错误结果
1201575 2800842 修复:SQL Server 2012 PowerPivot for Excel 中 MDX 查询设计器的性能改进
1167499 2801889 修复:安装 SQL Server 2012 SP1 PowerPivot for Excel 后,无法打开 PowerPivot 工作簿
1168983 2803065 修补程序:针对 SQL Server 2012 中的嵌套存储过程中的临时表运行查询时内存泄漏
1170481 2803529 修复:运行 SQL Server 跟踪时,SQL Server 2012 性能不佳
1207379 2803799 修复:针对 DMV 运行的查询在 SQL Server 2008 R2 或 SQL Server 2012 中进入无限循环
1171274 2803911 修复:在升级到 SSAS 2012 后运行 UPDATE CUBE 语句时出现“单元格写回错误”消息
1207381 2803994 修复:将 LOB 数据加载到 SQL Server 2008 R2 或 SQL Server 2008 中的 Transact-SQL 变量中时,发生SQL Server 损坏
1207383 2806244 修补程序:在基于 SQL Server 2008 R2 或 SQL Server 2012 的日志传送环境中还原事务日志备份时发生访问冲突
1174860 2806601 修复:在 SQL Server 2012 中打开表格模型文件时出错
1175459 2806979 修复:在 SQL Server 2012 中对启用 RCSI 的表运行查询时遇到性能低下
1175526 2807487 修复:使用 MSAS 2012 中配置了表格格式的 MDX 查询查询属性时,维度属性无法正确转换
1201573 2807974 修复:在 SQL Server 2012 异步数据库镜像环境中将新文件组添加到主体数据库后出现错误 3456
1150340 2809127 修复:应用 SQL Server 2012 SP1 后,在 Analysis Services 部署向导工具中编辑连接字符串时出错
1183628 2809338 修复:SQL Server 2012 节点上的高“日志写入等待”计数器值
1207367 2809339 修复:在 SSAS 2008 R2 或使用 INT 函数的 SSAS 2012 中运行 MDX 查询时,出现高内存使用率或 OOM 错误
1161808 2811020 修复:当您使用 Microsoft.SqlServer.XEvent.Linq 程序集读取 SQL Server 2012 扩展事件文件中的事件时,不会释放内存
1201572 2811607 修复:行级别安全用户在 SQL Server 2012 中运行 MDX 查询时,MDX 查询不返回任何结果
1165556 2811723 修复:在 SQL Server 2012 中运行 Service Broker 应用程序时出现访问冲突和错误 2905
1186917 2813214 修复:在服务器上安装 SQL Server 2012 后,如果服务器上没有负载,则出现 CPU 峰值
1190509 2814780 修复:在 SQL Server 2012 中重建索引后,分区索引的 NORECOMPUTE 属性的值不会保留
1200058 2818780 修复:如果将 SSRS 2012 报告导出到 Microsoft Excel,则返回的背景色不正确
1195332 2819382 修复:在 SQL Server 2012 中浏览 MDS 中的数据时,使用了不正确的小数分隔符
1195802 2819383 修复:当 SQL Server 2012 中的 MDS 中成员代码包含某些特殊字符时,业务规则不起作用
1136313 2819662 SQL Server 2012 在 NUMA 环境中遇到性能问题
1201432 2821686 修复:当你运行复杂的 DAX 查询时,当计划的数据更新启动时,SSAS 2012 会冻结
1182790 2823086 修复:“MDX 函数失败,因为'AttributeName'属性的坐标包含集合。”消息 在 SQL Server 2012 中运行 MDX 查询时
1207377 2809431 修复:在 SSAS 2008、SSAS 2008 R2 或 SSAS 2012 中生成 MDX 错误消息时,会发生堆损坏

累积更新包信息

先决条件

要应用此累积更新程序包,必须运行 SQL Server 2012 SP1。

        有关更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:

2755533 如何获取 SQL Server 2012 的最新 Service Pack

重启信息

应用此累积更新包后,可能必须重启计算机。

注册表信息

要使用此程序包中的某个修补程序,不必对注册表进行任何更改。

如何卸载此累积更新包

若要卸载此累积更新程序包,请按照下列步骤操作:

  1. 在控制面板中,打开“添加或删除程序”项。

    注意 如果运行的是 Windows 7,请在控制面板中打开“程序和功能”项。

  2. 找到此累积更新包安装的条目。

  3. 右键单击该条目,然后单击“卸载”。

参考资料

有关 SQL Server 增量服务模型的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:

935897 可从 SQL Server 团队获取增量服务模型以提供可以解决所报告问题的修补程序
           有关 SQL Server 更新的命名架构的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:

822499 Microsoft SQL Server 软件更新包的命名架构
           有关软件更新术语的更多信息,请单击下面的文章编号以查看 Microsoft 知识库中的相应文章:

824684 用于描述Microsoft软件更新的标准术语说明