症状
请考虑以下情形:
- 使用 System Center Configuration Manager复制过程。
- 此过程调用大容量复制程序实用工具 (BCP) API,以在服务器之间复制表数据。
- 表包含 XML 数据类型列。
在此方案中,当通过 BCP 加载 XML 文件时,如果 XML 文件中所有属性的内存总和大于 2 MB,则复制过程可能会失败,并且你会收到以下错误消息:
注意
状态 42000 - 错误 6303 - 消息 [Microsoft][ODBC Driver 11 for SQL Server][SQL Server]XML 分析:文档分析需要过多内存
解决方法
此问题在以下SQL Server累积更新中已修复:
SQL Server 2012 Service Pack 3 的累积更新 9
注意 安装此更新后,必须启用跟踪标志 6773 才能启用此修补程序。 若要启用跟踪标志 6773,请参阅 Microsoft 开发人员网络 (MSDN ) 网站上的跟踪标志 (Transact-SQL ) 主题。
建议:为SQL Server安装最新的累积更新
SQL Server的每个新累积更新都包含以前的累积更新中包含的所有修补程序和所有安全修补程序。 查看SQL Server的最新累积更新:
状态
Microsoft 已确认在 "适用于" 部分中所列的 Microsoft 产品中存在问题。
参考资料
了解 Microsoft 用于描述软件更新的术语。