2018 年 2 月 22 日 - KB4077525 (OS 内部版本 14393.2097)

应用对象
Windows 10, version 1607, all editions Windows Server 2016, all editions

改进和修补程序

此更新包含质量改进。 此更新中未引入任何新的操作系统功能。 关键更改包括:

  • 解决了在启用 NIC 组合的情况下设置 Windows Server 2016 故障转移群集时,导致使用 Hyper-V 副本或 Azure Site Recovery 复制的 Hyper-V 虚拟机在 92% 时停止响应的问题。  在停止 VM 时、实时迁移期间、停止 VMMS 服务期间或主机节点关闭期间也会出现此问题。 然后,用户必须在主机上使用硬重启来恢复。

  • 解决了 Citrix XenApp 用户无法通过按 Ctrl+F1 更改密码的问题。

  • 解决了性能日志用户组成员收到错误“拒绝访问。 (HRESULT 异常:0x80070005 (E_ACCESSDENIED) ) “。 尝试计划性能计数器日志记录、启用跟踪提供程序或收集跟踪信息时出现此错误。

  • 解决了 WinRM 事件查询从目标服务器返回错误“0x6c6 (RPC_S_INVALID_BOUND) ”的问题。 当服务器配置为使用订阅将其安全事件日志推送到中央服务器进行分析时,会出现此错误。

  • 解决了使用条件访问时对 Microsoft Outlook 的身份验证失败的问题。

  • 解决了智能卡登录失败并出现错误“你的帐户不支持使用智能卡登录...”的问题。重启身份验证 DC 后。 身份验证 DC 记录系统事件日志中的 KDC 事件 19 和 Kerberos 分发事件 29。 日志指出找不到用于智能卡登录的合适证书。

  • 解决了 certutil.exe -MergePfx 命令无法为多个 V1 证书生成合并的 EPF 文件的问题。

  • 解决了 TPM 设备不支持 SM3 加密哈希算法的问题。 遇到此问题的客户注意到其 TPM 初始化失败。

  • 解决了用户尝试 OS 升级或 LCU 更新时发生0x06d9故障的问题。 系统会自动还原到升级或更新的先前版本。

  • 解决了文件传输过程中偶尔发生服务器错误的问题。 错误为“在 tcpip 中停止 D1!TcpSegmentTcbSend“.

  • 解决了连接到无线网络时 (RADIUS) 服务器名称的远程身份验证拨入用户服务未经过身份验证的问题。

  • 解决了登录期间 iSCSI 目标重定向可能导致停止错误 9f 的问题。

  • 解决了 MPIO 中直通 SCSI 请求在磁盘正在等待删除时可能导致停止错误的问题。

  • 汇报 MPIO 路径选择算法,以便在所有路径均为活动或未优化时匹配文档。

  • 解决了启动应用程序时 StorNVMe 中的延迟函数可能导致 CPU 使用率小幅增加的问题。

  • 通过更彻底地取消映射文件的多个视图来提高 ReFS 性能。 有关其他可调注册表参数,请参阅 KB4090104 以处理大型 ReFS 元数据流。

  • 通过从哈希表中删除空闲容器来提高 ReFS 性能。

  • 解决了 Internet 连接服务 (ICS) 连接在操作系统重新启动或 ICS 服务重启后无法持久化的问题。 还可以使用 KB4055559 中所述的可选 EnableRebootPersistConnection 注册表项激活此解决方案。

  • 使用 SDN 网络管理器的正确信息清理公共 IP。

  • 解决了目录服务更改的审核事件 5136 的值字段中缺少信息的问题。 在 Windows Server 2016 域控制器上修改对象的属性时,会发生这种情况。 如果使用 PowerShell 命令 (Add-ADGroupMemberSet-ADGroup) 使用用户的 SID 而不是可分辨名称将某人添加到组中,则可能会出现此问题。

  • 解决了当 ADFS 场至少有两台服务器使用 WID) 时发生 HTTP 500 错误Windows 内部数据库 (问题。 在这种情况下,Web 应用程序代理 (WAP) 服务器上的 HTTP 基本预身份验证无法对某些用户进行身份验证。 发生此错误时,可能还会在 WAP 事件日志中看到 Microsoft Windows Web 应用程序代理警告事件 ID 13039。 说明显示“Web 应用程序代理无法对用户进行身份验证。 预身份验证为“ADFS For Rich Clients”。 给定用户无权访问给定的信赖方。 需要修改目标信赖方或 WAP 信赖方的授权规则。”

  • 解决了 AD FS 在身份验证期间无法再忽略 prompt=login 的问题。 添加了“ 已禁用” 选项,以支持不使用密码身份验证的方案。 有关详细信息,请参阅 AD FS 在 Windows Server 2016 RTM 中进行身份验证期间忽略“prompt=login”参数

  • 解决了 AD FS 中选择“ 证书” 作为身份验证选项的授权客户 (和信赖方) 无法连接的问题。 如果启用了 Windows 集成身份验证 (WIA) ,并且请求可以执行 WIA,则使用 prompt=login 时会失败。

  • 解决了当标识提供者 (IDP) 与 OAuth 组中的 RP) (信赖方关联时 AD FS 错误地显示“主领域发现 (HRD) ”页面的问题。 除非多个 IDP 与 OAuth 组中的 RP 相关联,否则不会向用户显示 HRD 页面。 相反,用户将直接转到关联的 IDP 进行身份验证。

  • 解决了某些远程桌面协议 (RDP) 客户端使用绝对 URI (而不是相对 URI) 被 Web 应用程序代理 (WAP) 服务器阻止连接到远程桌面网关的问题。 这影响了 iOS、Mac、Android 和 Windows 新式 RDP 客户端应用上的 RDP 客户端。 错误为“由于错误,我们无法连接到网关。 如果这种情况持续发生,请向管理员或技术支持人员寻求帮助。 错误代码:0x03000008。”

  • 解决了在报告中选择链接并出现以下错误之一时 GPMC 报告未显示内容的问题:

    • 错误:“XMLSerializer”未定义。
    • “DOMParser” 未定义。
    • 服务器执行失败。
  • 解决了当文件更新到超过 2.2 TB 时,经过优化且小于 2.2 TB 的文件可能会被重复进程损坏的问题。

  • 解决了在对大于 2.2 TB 的文件运行完整的重复数据删除清理时,文件始终被标记为已损坏(即使并未损坏)的问题。

  • 解决了安装 .NET 4.7 后,在 DFS 管理单元中创建新的 DFS-Replication 组或将成员添加到现有复制组会导致错误的问题。 错误为“该值不在预期范围内”。

  • 解决了安装 .NET 4.7 后,在“选择服务器”页面上选择“ 浏览 ”时,故障转移群集管理 UI 中的“创建群集”向导可能会意外关闭的问题。

  • 解决了日语键盘布局在远程协助会话期间无法正常工作的问题。

  • 解决了在服务器正常运行一段时间后,登录到远程桌面 VDI 集合开始失败的问题。 性能计数器远程桌面连接代理重定向程序重定向器集/RPC 上下文在登录小时内将显示增量增长。 当值达到 40 时,与服务器场的新连接将失败或超时。

  • 解决了连接代理失去对 SQL 数据库的访问权限超过两分钟后,登录到远程桌面 VDI 场失败的问题。 这会导致集合中的虚拟机进入未知状态。 管理员必须重新启动远程桌面连接代理服务才能从故障中恢复。

  • 解决了启用了 Credential Guard 的服务器可能意外重启的问题。 错误为“系统进程 lsass.exe 意外终止,状态代码为 -1073740791”。 系统现在将关闭并重新启动“。

如果已安装较早的更新,那么此程序包中只有新的修补程序会下载并安装到设备上。

有关已解决的安全漏洞的详细信息,请参阅 安全更新指南

注意

  • Windows 更新改进
  • Microsoft 已将更新直接发布到 Windows 更新 客户端以改进可靠性。 任何运行Windows 10配置为从 Windows 更新 自动接收更新的设备(包括企业版和专业版)都会根据设备兼容性和适用于企业的Windows 更新延期策略提供最新的 Windows 10 功能更新。 这不适用于长期服务版本。

此更新中的已知问题

症状 解决方法
由于存在影响某些版本防病毒软件的问题,因此此修补程序仅适用于防病毒 ISV 更新了 ALLOW REGKEY 的计算机。 此问题已在 KB4088787 中得到解决。
由于 AD FS 服务器问题导致 WID AD FS 数据库在重新启动后变得不可用,AD FS 服务可能无法启动。 此问题已在 KB4088787 中得到解决。

如何获取此更新

若要获取此更新的独立程序包,请转到 Microsoft 更新目录网站。

文件信息

有关此更新中提供的文件列表,请下载 累积更新4077525的文件信息