重要
对 Microsoft InfoPath 2013 的支持已于 2026 年 7 月 14 日结束。 建议将现有的 InfoPath 表单和工作流迁移到受支持的 Microsoft 365 解决方案。 了解有关 InfoPath 停用的详细信息。
本文内容
概述
当您设计基于 Microsoft SQL Server 数据库的表单模板时,如果满足以下条件,数据连接向导会启用到数据库的提交数据连接:
- 基于此表单模板的表单必须使用 Microsoft Office InfoPath 填写。 如果将使用 Web 浏览器填写表单,则表单无法直接将数据提交到数据库。 若要配置与浏览器兼容的表单模板以将数据提交到数据库,请使用将数据提交到与该数据库配合使用的 Web 服务的数据连接。
- 主数据连接中使用的主数据库表包含主键、唯一约束或唯一索引。
- 用于此主数据连接的任何其他数据库表与主数据库表具有简单的关系。
如果数据库满足这些要求,InfoPath 将启用提交数据连接,并在 Standard 工具栏中添加“提交”按钮,并在窗体上的“文件”菜单中添加“提交”命令。
设计基于数据库的表单模板时,可以在向导中选择禁用提交数据连接。 如果在向导中禁用了提交数据连接,然后又决定要使用此提交数据连接,则可以通过修改主数据连接来启用提交数据连接。 本文讨论如何启用该提交数据连接。
注意
只能在与数据库的主数据连接中具有提交数据连接。 不能将提交数据连接到表单模板,而表单模板是数据库的辅助数据连接。 如果要将到数据库的提交数据连接用作辅助数据连接,请使用适用于该数据库的 Web 服务,然后将提交数据连接到该 Web 服务。
启用提交数据连接后,还可以通过以下方式自定义表单模板的提交选项:
- 更改 Standard 工具栏上的“提交”按钮和“文件”菜单上的“提交”命令上显示的文本。
- 更改 Standard 工具栏上的 Submit 按钮和 File 菜单上的 Submit 命令的键盘快捷键。
- 创建自定义消息以在用户提交表单时显示给用户。
- 指定在提交表单后是保持窗体打开、关闭窗体还是打开另一个空白窗体。
步骤 1:启用提交数据连接
- 在 “工具 ”菜单上,单击 “数据连接”。
- 在“ 数据连接 ”对话框中,单击主数据连接,然后单击“ 修改”。
- 在“数据连接向导”中,单击 “下一步”。
- 在向导的下一页上,选中“为此连接启用提交”检查框,然后单击“完成”。
步骤 2:配置提交选项
启用提交数据连接后,InfoPath 会将提交按钮添加到 Standard 工具栏,并将提交命令添加到“文件”菜单。 InfoPath 还配置基于此表单模板的表单,以便在用户提交已填妥的表单后向用户显示一条消息。 该消息将说明表单是否已成功提交。 默认情况下,InfoPath 还在用户提交表单后保持表单打开状态。 若要更改“ 提交 ”按钮上显示的文本以及用户提交表单后发生的行为,请执行以下操作:
在 “工具 ”菜单上,单击 “提交选项”。
若要更改用户填写表单时显示在 Standard 工具栏上的“提交”按钮和“文件”菜单上显示的“提交”命令的名称,请在“提交选项”对话框的“标题”框中键入新名称。
提示
如果要为此按钮和命令分配键盘快捷方式,请在要用作键盘快捷方式的字符前面键入一个与号 (&) 。 例如,若要将 ALT+B 指定为“ 提交 ”按钮和命令的键盘快捷方式,请键入 Su&bmit。
如果您不希望人们在填写表单时使用 Submit 命令或 Standard 工具栏上的 Submit 按钮,请清除显示 Submit 菜单项和 Submit 工具栏按钮检查框。
默认情况下,用户提交表单后,InfoPath 将使表单保持打开状态,并显示一条消息以说明表单是否已成功提交。 若要更改此默认行为,请单击“ 高级”,然后执行下列操作之一:
若要在用户提交已完成的表单后关闭窗体或创建新的空白窗体,请在“ 提交后” 列表中单击所需的选项。
若要创建自定义消息以指示窗体是否已成功提交,请选中“使用自定义消息”检查框,然后在“成功时”和“失败时”框中键入消息。
提示
在 失败时 框中使用消息告诉用户如果无法提交表单该怎么做。 例如,您可以建议用户保存其表单并联系某人以获取进一步说明。
如果不想在用户提交表单后显示消息,请清除“显示成功和失败消息”检查框。