修复:在查询中使用命名参数时,DB2 托管提供程序中出现“SQLCODE 80”错误

应用对象
Host Integration Server 2013

症状

使用 Microsoft Host Integration Server 2013 附带的 DB2 托管提供程序功能运行参数化查询时,查询可能会失败。 在这种情况下,你会收到以下错误消息:

注意

SQLCODE 80.

      

原因

当您使用命名参数,并且要插入的参数包含空值时,会出现此问题。

解决方法

累积更新信息

解决此问题的修补程序包含在 Host Integration Server 2013 的累 积更新 1 中。

状态

Microsoft 已确认在 "适用于" 部分中所列的 Microsoft 产品中存在问题。