修复:当 BizTalk Server 尝试连接到 WCF-SAP 源时出现 InvalidUriException 错误

应用对象
BizTalk Server 2013 R2 Branch BizTalk Server 2013 R2 Developer BizTalk Server 2013 R2 Enterprise BizTalk Server 2013 R2 Standard BizTalk Server 2013 Branch BizTalk Server 2013 Developer BizTalk Server 2013 Enterprise BizTalk Server 2013 Standard

症状

当Microsoft BizTalk Server使用包含特殊字符(如双引号 (“) )的密码连接到 WCF-SAP 源或目标时,会生成 InvalidUriException 错误。

原因

出现此问题的原因是 BizTalk Server 2013 WCF-SAP 适配器未正确处理密码中的双引号和反斜杠字符。

解决方法

累积更新信息

解决此问题的修补程序包含在 BizTalk Adapter Pack 2013 的累积更新包 2 中。

状态

Microsoft 已确认在 "适用于" 部分中所列的 Microsoft 产品中存在问题。

参考资料

了解 BizTalk Server 的 Service Pack 和累积更新列表。

了解 BizTalk Server 修补程序和累积更新支持 。