症状
使用 BizTalk WCF-OracleDB 适配器与 Oracle Server 11.2.0.4 配合使用时,你会收到以下错误消息:
注意
“消息传递引擎无法将 URL 为”XXX“的接收位置”XXX“添加到适配器”WCF-OracleDB“。”原因:“System.NotSupportedException:不支持指定的方法。”
原因
出现此问题的原因是 Oracle 在数据库版本 11.2.0.3 和 11.2.0.4 之间对元数据表中 XMLType 数据类型的DATA_TYPE值进行了更改。 此更改会导致 BizTalk 适配器在从 Oracle 类型映射到 .NET 类型时失败。
解决方法
累积更新信息
解决此问题的修补程序包含在 BizTalk Adapter Pack 2013 的累积更新包 2 中。
状态
Microsoft 已确认在 "适用于" 部分中所列的 Microsoft 产品中存在问题。
参考资料
有关 BizTalk Server 的 Service Pack 和累积更新列表的更多信息,请参阅 KB 2555976:BizTalk Server 的 Service Pack 和累积更新列表。
有关BizTalk Server修补程序的更多信息,请参阅 KB 2003907:有关 BizTalk 修补程序和累积更新支持的信息。
第三方信息免责声明
本文中提到的第三方产品由 Microsoft 以外的其他公司提供。 Microsoft 不对这些产品的性能或可靠性提供任何明示或暗示性担保。