以与 Excel 早期版本兼容的方式保存 Excel 工作簿

应用对象
Microsoft 365 专属 Excel Excel 2024 Excel 2021

你已升级到新版本的 Excel,并且需要与尚未升级的人员共享工作簿。 运行兼容性检查器有助于识别早期版本中可能不可用的功能或信息。 你可以在共享工作簿之前解决其中一些问题。

将文件保存为.xls 格式并检查兼容性检查器问题

请按以下步骤操作:

  1. 选择 “文件>导出”更改>文件类型。

    显示在“导出”选项卡上更改文件类型的屏幕截图。

  2. 在 “工作簿文件类型”下,选择一种工作簿文件类型。

    显示文件类型的屏幕截图。

  3. 在“ 另存为” 弹出窗口中,选择工作簿的文件夹位置。

  4. 在 “文件名 ”框中,键入新文件名或使用现有名称。

  5. 选择“保存”。

运行 Excel 兼容性检查器

若要验证工作簿是否兼容,请在首次保存工作簿时手动运行兼容性检查器。 然后将兼容性检查器设置为每次保存该工作簿时自动运行。

请按以下步骤操作:

  1. 选择“文件>信息>”检查问题。

    显示“检查兼容性”的屏幕截图。

  2. 选择 “检查兼容性”。

  3. 要从现在开始自动检查兼容性,请选择 保存此工作簿时检查兼容性 框。

    提示

    还可以指定检查兼容性时要包含的 Excel 版本。 默认情况下会选中所有版本,因此只需取消选中不希望包括的版本。

    显示兼容性检查器的屏幕截图。

    如果检查器发现任何问题,则“ 查找 ”链接将带你到工作表中的该位置,“ 帮助 ”链接将带你到有关问题的信息和可能的解决方案。

使用 Access 合并使用多个表的数据功能的数据源

注意

也可以使用 Excel 中的 VLOOKUP 函数 来解决此问题,但该过程有点复杂,并且随着要合并的数据源数量的增加而变得复杂。

早期版本(如 Excel 2019)不支持分析多个表的数据功能,因为这些版本没有数据模型。 如果您的工作簿包含任何此类功能,则可以通过将功能的数据源合并到单个表中,然后将该新表用作数据源,为在早期版本中使用这些功能做好准备。

执行此任务的一种方法是使用 Access 组合数据源,并将它们复制为查询,然后将其导入到工作簿中。 过程如下所示:

  1. 在 Access 中,将每个原始数据源 作为 新表导入。
  2. 在 Excel 中,单击“ 数据>数据工具>关系 ”打开“关系”对话框,并记下原始数据源之间的关系。
  3. 在 Access 中, 重新创建每个关系。
  4. 在 Access 中, 创建一个包含 Excel 数据功能所需的所有字段的查询。
  5. 在 Excel 中, 将查询作为 表格导入到新工作表中。

数据位于 Excel 中的一个表中后,选择该表作为使用多个表的数据特征的数据源,或重新创建数据特征并选择新表作为其数据源。

需要更多帮助吗?

你随时可以在 Excel 技术社区 中咨询专家,或在 社区中获取支持。

另请参阅

不会传输到其他文件格式的 Excel 格式和功能

工作表兼容性问题