若要使导入的外部数据保持最新,可以刷新它以查看最近的更新和删除。 Excel提供了许多用于刷新数据的选项,包括打开工作簿时和时间间隔。

注意: 若要停止刷新,请按 Esc。 若要刷新工作表,请按 Ctrl + F5。 若要刷新工作簿,请按 Ctrl + Alt + F5。

 了解如何刷新应用Excel数据

下表汇总了刷新操作、快捷键和命令。

可以

刷新工作表中的所选数据

Alt + F5

选择"数据>""全部刷新"旁边的下拉箭头>刷新 鼠标指向功能区上的"刷新"命令

刷新工作簿中的所有数据

Ctrl + Alt + F5

选择"数据>全部刷新 鼠标指针悬停在"全部刷新"按钮上

检查刷新状态

双击状态栏上的"正在检索数据"消息。

消息框:检索数据

停止刷新

Esc

刷新时显示的消息,以及用于停止刷新的命令 (ESC)

停止后台刷新

双击状态栏上的消息。

消息框:后台刷新

然后在"外部 数据刷新状态 "对话框中选择" 停止刷新"。

"外部数据刷新状态"对话框

工作簿中的数据可以直接存储在工作簿中,也可以存储在外部数据源(如文本文件、数据库或云)中。 首次导入外部数据时,Excel 会创建连接信息,有时会保存到 Office 数据连接 (ODC) 文件,该文件介绍如何查找、登录、查询和访问外部数据源。

连接到外部数据源时,可以执行刷新操作来检索更新的数据。 每次刷新数据时,都可以看到最新版本的数据,包括自上次刷新以来对数据进行的任何更改。

详细了解如何刷新数据

这解释了刷新连接到外部数据源的数据时发生的情况的基本过程:

  1. 有人开始刷新工作簿的连接,获取最新数据。

  2. 与工作簿中使用的外部数据源建立连接。

    注意: 可以访问各种数据源,例如 OLAP、SQL Server、OLEDB 提供程序和 ODBC 驱动程序。

  3. 工作簿中的数据会更新。

刷新外部数据的基本流程

了解安全问题

连接到外部数据源并尝试刷新数据时,必须注意潜在的安全问题,并知道可以如何处理任何安全问题。

信任连接    - 您的计算机上当前可能禁用了外部数据。 若要在打开工作簿时刷新数据,必须使用"信任中心"栏启用数据连接,或者必须将工作簿放在受信任的位置。 有关详细信息,请参阅以下文章:

ODC 文件    - 数据连接文件 (.odc) 通常包含一个或多个用于刷新外部数据的查询。 通过替换此文件,具有恶意意图的用户可以设计查询来访问机密信息并将其分发给其他用户或执行其他有害操作。 因此,必须确保连接文件是由可靠的个人创作的,并且连接文件是安全的,并且来自受信任的数据连接库 (DCL) 。

凭据    - 访问外部数据源通常需要凭据 (,例如用于对用户进行身份验证) 用户名和密码。 确保以安全的方式提供这些凭据,并且不会无意中向其他人透露这些凭据。 如果外部数据源需要密码才能访问数据,可以要求每次刷新外部数据范围时都输入密码。

共享 -   您是否正在与可能想要刷新数据的其他人共享此工作簿? 通过提醒同事请求对提供数据的数据源的权限,帮助同事避免数据刷新错误。

有关详细信息,请参阅 管理数据源设置和权限

您可以在打开工作簿时自动刷新外部数据区域。 您也可以保存工作簿而不保存外部数据以缩小文件大小。

  1. 选择外部数据区域中的单元格。

  2. 选择">查询&">连接"选项卡,右键单击列表中的查询,然后选择"属性"。

  3. 在"连接属性"对话框中的"用法"选项卡上的"刷新控件"下,选中"打开文件时刷新数据"复选框。

  4. 如果要在保存工作簿时保存查询定义,但不保存外部数据,请选中“保存工作簿前,删除来自外部数据区域中的数据”复选框。

  1. 选择外部数据区域中的单元格。

  2. 选择">查询&">连接"选项卡,右键单击列表中的查询,然后选择"属性"。

  3. 单击“使用状况”选项卡。

  4. 选中“刷新频率”复选框,然后输入每次刷新操作之间的分钟数。

如果您的工作簿连接到较大数据源,则刷新它所花的时间可能比预期要长。 请考虑运行后台刷新。 这会将 Excel 的控制权返回给您,以便您不必等待数分钟或更长时间来让刷新完成。

注意: 无法在后台运行 OLAP 查询,并且无法针对检索数据模型数据的任何连接类型运行查询。

  1. 选择外部数据区域中的单元格。

  2. 选择">查询&">连接"选项卡,右键单击列表中的查询,然后选择"属性"。

  3. 选择" 使用情况" 选项卡。

  4. 选中“允许后台刷新”复选框以在后台运行查询。 清除此复选框可在您等待时运行查询。

    提示    当你录制包含查询的宏时,Excel 不会在后台运行查询。 若要更改录制的宏以使查询在后台运行,请在 Visual Basic 编辑器中编辑宏。 将查询表对象的刷新方法从 BackgroundQuery := False 更改为 BackgroundQuery := True

存储的密码未经加密,因此我们不建议您使用。 如果您的数据源需要密码才能连接,则可以要求用户在输入密码之后才能刷新外部数据区域。 以下过程不适用于从文本文件或 Web 查询 (.txt) .iqy (检索) 。

提示: 使用由大写字母、小写字母、数字和符号组合的强密码。 弱密码不混合使用这些元素。 例如,强密码:Y6dh!et5。 弱密码:House27。 密码应至少包含 8 个字符。 最好使用包含 14 个或更多字符的密码。

务必记住密码。 如果您忘记了密码,Microsoft 无法为您找回。 请将记好的密码保存在安全位置,远离密码所要保护的信息。

  1. 选择外部数据区域中的单元格。

  2. 选择">查询&">连接"选项卡,右键单击列表中的查询,然后选择"属性"。

  3. 选择" 定义" 选项卡,然后清除" 保存密码 "复选框。

注意: Excel 仅在每个 Excel 会话中首次刷新外部数据区域时提示输入密码。 下次启动 Excel 时,如果打开包含查询的工作簿并尝试进行刷新操作,则会提示您再次输入密码。

刷新数据的详细帮助

在 Power Query 中调整数据时,通常会将更改加载到工作表或数据模型。 了解刷新数据时的差异及其刷新方法非常重要。

注意: 刷新时,自上次刷新操作以来添加的新列将添加到 Power Query。 若要查看这些新列,请重新检查 查询中的"源 "步骤。 有关详细信息,请参阅创建 Power Query 公式。

大多数查询基于一种或另一种外部数据资源。 但是,Excel Power Query 之间存在一个关键差异。 Power Query 将外部数据缓存在本地,以帮助提高性能。  此外,Power Query 不会自动刷新本地缓存,以帮助防止在 Azure 中产生数据源成本。

重要: 如果在窗口顶部的黄色消息栏中收到一条消息,指出"此预览版可能最多为 n 天。",这通常意味着本地缓存已过时。 应选择"刷新 "以将其更新。

在 Power Query 编辑器中刷新查询

从 Power Query 编辑器刷新查询时,不仅会引入来自外部数据源的更新数据,还会更新本地缓存。 但是,此刷新操作不会更新工作表或数据模型中的查询。

  1. 在 Power Query 编辑器中,选择"主页 "

  2. "预览>" () "中,选择"刷新预览" ("刷新预览"或"全部刷新" ("查询"窗格中打开的所有查询   。)

  3. 在右侧 Power Query 编辑器底部,显示一条消息"预览版从 <hh:mm> AM/PM"。 首次导入时以及 Power Query 编辑器中每次后续刷新操作后,会显示此消息。

刷新工作表中的查询

  1. 在Excel中,选择工作表中的查询中的单元格。

  2. 选择功能区中的"查询"选项卡,然后选择"刷新>刷新"。

  3. 工作表和查询从外部数据源和 Power Query 缓存刷新。

注意: 

  • 刷新从表或命名区域Excel的查询时,请注意当前工作表。 如果要更改包含该表的工作表Excel,请确保选择了正确的工作表,而不是包含加载的查询的工作表。

  • 如果要更改表的列标题,这Excel很重要。 它们通常看起来相似,很容易混淆这两者。 建议重命名工作表以反映差异。 例如,可将其重命名为"TableData"和"QueryTable",以强调区别。

您随时可以选择"刷新" 以更新工作簿中数据透视表的数据。 您可以刷新连接到外部数据(例如数据库 (SQL Server、Oracle、Access 或其他) 、Analysis Services 多维数据集、数据源)的数据透视表的数据,以及相同或不同工作簿中源表中的数据。 打开工作簿时,可以手动或自动刷新数据透视表。

手动刷新

  1. 选择数据透视表中的任意位置,以显示功能区中的"数据透视 分析"选项卡。

    注意: 若要刷新数据透视Excel 网页版,请右键单击数据透视表中的任意位置,然后选择"刷新"。

  2. 选择"刷新"或"全部刷新"。
    “分析”选项卡上的“刷新”按钮

  3. 若要检查刷新状态(如果刷新时间超过预期时间),请选择"刷新状态"下的>刷新状态"。

  4. 若要停止刷新,请选择"取消刷新",或按 Esc。

防止调整列宽和单元格格式

如果在刷新数据透视表数据时,数据的列宽度和单元格格式违背你的意愿进行了调整,请确保检查以下选项:

  1. 选择数据透视表中的任意位置,以显示功能区中的"数据透视 分析"选项卡。

  2. 在"数据透视表"组中>"数据透视表分析"选项卡,然后选择"选项"。

    “分析”选项卡上的“选项”按钮

  3. 在"布局&格式"选项卡>选中"更新时自动调整列宽"和"更新时保留单元格格式"复选框

打开工作簿时自动刷新数据

  1. 选择数据透视表中的任意位置,以显示功能区中的"数据透视 分析"选项卡。

  2. 在"数据透视表"组中>"数据透视表分析"选项卡,然后选择"选项"。

    “分析”选项卡上的“选项”按钮

  3. 在"数据"选项卡上,选择"打开文件时刷新数据"。

刷新脱机多维数据集文件(即,使用服务器多维数据集中的最新数据重新创建该文件)不仅耗时,而且需要大量的临时磁盘空间。 请在不需要在 Excel 中立即访问其他文件时启动该过程,并确保有足够的磁盘空间来重新保存文件。

  1. 选择连接到脱机多维数据集文件的数据透视表。

  2. 在"数据"选项卡上的"&连接"组中,单击"全部刷新"下的箭头,然后单击"刷新"。

有关详细信息,请参阅 使用脱机多维数据集文件

  1. 在工作表上,单击映射的单元格以选择要刷新的 XML 映射。

  2. 如果“开发工具”选项卡不可用,请通过执行下列操作来显示该选项卡:

    1. 单击“文件”>“选项”>“自定义功能区”。

    2. “主选项卡”下,选中“开发工具”复选框,然后单击“确定”

  3. “开发工具”选项卡上的“XML”组中,单击“刷新数据”

有关详细信息,请参阅 XML在 Excel。

在 Power Pivot 中刷新数据模型时,还可以查看刷新是成功、失败还是已取消。 有关详细信息,请参阅 Power Pivot:功能强大的数据分析和数据建模Excel。

注意: 添加数据、更改数据或编辑筛选器始终触发依赖于该数据源的 DAX 公式的重新计算。

刷新并查看刷新状态   

  1. 在 Power Pivot中,>"获取外部数据>"刷新"或"全部刷新",刷新数据模型中的当前表或所有表。

  2. 对于数据模型中使用的每个连接,会指示刷新状态。 有三种可能的结果:

  • 成功 - 报告导入到每个表中的行数。

  • 错误 - 如果数据库处于脱机状态、不再具有权限,或者删除或重命名了源中的表或列,则会发生此错误。 验证数据库是否可用,也许可以在不同的工作簿中创建新连接。

  • 已取消- Excel未发出刷新请求,可能是因为连接上已禁用刷新。

使用表属性显示数据刷新中使用的查询

数据刷新只是重新运行最初用于获取数据的同一查询。 可以通过在 Power Pivot 窗口中查看表属性来查看查询,有时还可以修改查询。

  1. 若要查看数据刷新期间使用的查询,请选择"Power Pivot > 管理" 打开 Power Pivot 窗口。

  2. 选择"设计>表属性"。

  3. 切换到查询编辑器以查看基础查询。

查询不针对每种类型的数据源可见。 例如,不会针对数据源导入显示查询。

设置连接属性以取消数据刷新

在Excel中,可以设置用于确定数据刷新频率的连接属性。 如果特定连接上不允许刷新,则运行"全部刷新"或尝试刷新使用该连接的特定表时,将收到取消通知。

  1. 若要查看连接属性,Excel选择">查询"&"连接"以查看工作簿中使用的所有连接的列表。

  2. 选择"连接"选项卡,右键单击某个连接,然后单击"属性"。

  3. 在"用法"选项卡的"刷新控件"下,如果清除"全部刷新"上"刷新此连接"的复选框,则当您在Power Pivot 窗口中尝试"全部刷新"时,您将获得取消。

刷新 SharePoint Server 2013 上的数据

在 SharePoint 服务器上,可以在服务器上计划无人参与的数据刷新,但这样做需要在 SharePoint 环境中安装并配置 Power Pivot for SharePoint 2013。 请与您的 SharePoint 管理员联系,了解计划的数据刷新是否可用。 有关详细信息,请参阅配置 Power Pivot 的计划数据刷新。

当用于地图的数据发生更改时,可以在 3D 地图中手动刷新地图。 更改随后会反映在地图中。 操作方法如下:

  • 在 3D 地图中,选择"主页>刷新数据"。

    “开始”选项卡上的“刷新数据”组

将数据添加到 Power Map

若要将新数据添加到 3D 地图Power Map :

  1. 在 3D 地图中,转到要将数据添加到的地图。

  2. 将 3D 地图窗口保持打开状态。

  3. 在Excel选择要添加的工作表数据。

  4. 在 Excel 功能区上,单击“插入”>“地图”箭头 >“将选定数据添加到 Power Map”。 3D 地图将自动更新以显示其他数据。 有关详细信息,请参阅 获取和准备Power Map 的数据。

    “将选定数据添加到 Power Map”命令

刷新服务中的Excel Services具有独特的要求。

控制数据的刷新方法

可以通过执行下列一项或多项操作来控制如何刷新外部数据源的数据。

使用"打开时刷新Excel Services   

在Excel,您可以创建在打开文件时自动刷新外部数据的工作簿。 在这种情况下,Excel Services始终刷新数据,然后再显示工作簿并创建新会话。 如果希望确保在打开工作簿时始终显示最新数据,请使用 Excel Services 。

  1. 在具有外部数据连接的工作簿中,选择"数据 " 选项卡。

  2. 在"连接"组中,选择"连接>"属性">连接"。

  3. 选择"使用情况"选项卡,然后在打开文件时选择"刷新数据"。

    警告: 如果清除"打开文件时刷新数据"复选框,将显示工作簿中缓存的数据,这意味着当用户手动刷新数据时,用户将在当前会话期间看到最新数据,但数据不会保存到工作簿。

使用 .odc 文件刷新

如果使用 Office.odc (.odc) ,请确保同时设置"始终使用连接文件"复选框:

  1. 在具有外部数据连接的工作簿中,选择"数据 " 选项卡。

  2. 在"连接"组中,选择"连接>"属性">连接"。

  3. 选择"定义"选项卡,然后选择"始终使用连接文件"。

受信任的文件位置站点设置、 短会话超时外部数据缓存生存期也可能对刷新操作产生影响。 有关详细信息,请参阅管理员或帮助系统。

手动刷新   

  1. 在数据透视表中选择一个单元格。

  2. 在 Web Excel工具栏上的"更新"菜单下,选择"刷新所选连接"。

    注意: 

    • 如果此 " 刷新"命令不可见,则Web 部件清除了"刷新所选连接,刷新所有 连接" 属性。 有关详细信息,请参阅 Web Access Excel自定义Web 部件属性 。

    • 任何导致重新查询 OLAP 数据源的交互式操作将启动手动刷新操作。

  • 刷新所有连接- 在 Web Excel工具栏上的"更新"菜单下,单击"刷新所有连接"。

  • 定期 刷新 - 可以指定在工作簿中每个连接打开工作簿后,数据按指定的时间间隔自动刷新。 例如,库存数据库可能每小时更新一次,因此工作簿作者已定义工作簿以每隔 60 分钟自动刷新一次。

    用户Web 部件选择或清除"允许Excel Web访问定期数据刷新"属性,以允许或阻止定期刷新。 默认情况下,当时间间隔过后,Web Access Excel底部会显示Web 部件。 

    Excel Web Access Web 部件还可以设置"显示定期数据刷新提示"属性,以控制 Excel Services 在会话期间执行定期数据刷新时显示的消息的行为:

    有关详细信息,请参阅 Web Access Excel自定义Web 部件属性 。

  • 始终 - 表示消息在每个时间间隔内显示一次提示。

  • (可选 )表示用户可以选择继续定期刷新而不显示消息。

  • 从不- Excel Web Access 执行定期刷新而不显示消息或提示。

  • 取消刷新 - 当工作簿刷新时,Excel Services 显示一条消息并显示提示,因为它可能超过预期。 可以选择" 取消 "以停止刷新,以便稍后在更方便的时间完成刷新。 取消刷新之前查询返回的数据将显示。

在浏览器中使用工作簿时,您将查看直接存储在工作簿或外部数据(数据存储在其他位置)的数据,并且需要连接到源或数据库。

这解释了刷新连接到外部数据源的数据时发生的情况的基本过程:

  1. 有人开始刷新工作簿的连接,获取最新数据。

  2. 与工作簿中使用的外部数据源建立连接。

    注意: 可以访问各种数据源,例如 OLAP、SQL Server、OLEDB 提供程序和 ODBC 驱动程序。

  3. 工作簿中的数据会更新。

刷新外部数据的基本流程

如果您在浏览器窗口中查看工作簿,并且想要刷新数据,那么您通常可以在两种模式下执行此操作:查看模式或编辑模式。

查看模式

当您在查看模式下刷新工作簿时,只会更新工作簿中显示的数据。 可以在浏览器窗口或只读模式下Excel,在只读模式下 (编辑) 操作。

在这种情况下,工作簿不会作为已更改的文件进行跟踪。 这意味着在存储工作簿的位置中,您的用户凭据不显示为最近编辑过工作簿的人员。

编辑模式

当您在编辑模式下刷新工作簿时,您将在浏览器窗口或 (打开工作簿进行编辑Excel) 。 工作簿将作为已更改的文件进行跟踪。 这意味着,您的用户凭据将显示为最近编辑过工作簿的人员。

如果正在编辑工作簿并刷新数据,则数据刷新后会自动保存更改。 任何有权查看该工作簿的用户将在保存工作簿时立即看到您所做的更改。

您必须使用Excel定义工作簿的外部数据连接。 您不能在浏览器窗口中查看工作簿时定义此类设置。 当您将工作簿发布到 Excel库时,将保留使用 SharePoint的设置。

若要指定数据刷新选项,请选择数据刷新中特定数据连接的"属性"Excel。 下表提供了对您可以选择的各个数据刷新选项的简要说明。

  • 每隔 __ 分钟 刷新一次 - 此选项会导致工作簿尝试按指定的时间间隔刷新数据, (分钟)

  • 打开文件时刷新数据 - 此选项会导致工作簿在打开工作簿时尝试自动刷新数据。

  • 在"全部刷新"上 刷新此连接 - 选中此选项后,当您或其他用户单击"全部刷新"按钮时,此选项将 刷新 数据。

    未选中此选项时,当您或其他人单击"全部刷新"按钮时,此选项会阻止此连接 刷新 数据。 如果您想要在 Excel Services 中避免数据刷新错误(例如特定连接的超时错误),此选项非常有用。

数据刷新可能不会发生,具体取决于您的环境的配置方式。 例如,如果有人创建了一个工作簿,该工作簿使用与本地服务器的安全外部数据连接,则这些数据连接可能Microsoft 365。 如果遇到在浏览器窗口中无法刷新数据的情况,请尝试在浏览器中打开Excel。

您也可以与 SharePoint 管理员联系。

对于大多数连接,请单击区域或表中使用该连接的任何单元格,然后执行下列操作之一:

  • 仅更新所选数据   按 Alt+F5,或在"数据"选项卡上的"连接"组中,单击"全部刷新"下的箭头,然后单击"刷新"。

    鼠标指向功能区上的"刷新"命令

  • 更新工作簿中所有数据   按 Ctrl+Alt+F5,或在"数据"选项卡上的"连接"组中,单击"全部刷新"。

    鼠标指针悬停在"全部刷新"按钮上

  • 控制连接刷新方式或时间   在"数据"选项卡上的"连接"组中,单击"全部刷新"下的箭头,然后单击"连接属性"。

    鼠标指向功能区上的"连接属性"命令

    在打开的对话框中,在"用法"选项卡的"刷新控件"下选择想要的选项

某些刷新操作需要执行更多步骤,如以下部分所述。 如果看到数据源已列出,请查看相应的部分。

您可以在打开工作簿时自动刷新外部数据区域。 或者,您可以保存工作簿而不保存外部数据,以缩减文件的大小。

  1. 单击外部数据区域中的某个单元格。

  2. 在“数据”选项卡上的“连接”组中,单击“全部刷新”,然后单击“连接属性”。

    连接属性

  1. 单击“使用状况”选项卡。

  2. 在“刷新控件”下,选中“打开文件时刷新数据”复选框。

  3. 如果要在保存工作簿时保存查询定义,但不保存外部数据,请选中“保存工作簿前,删除来自外部数据区域中的数据”复选框。

  1. 单击外部数据区域中的某个单元格。

  2. 在“数据”选项卡上的“连接”组中,单击“全部刷新”,然后单击“连接属性”。

    连接属性

  3. 单击“使用状况”选项卡。

  4. 选中“刷新频率”复选框,然后输入每次刷新操作之间的分钟数。

存储的密码未经加密,因此我们不建议您使用。 如果您的数据源需要密码才能连接,则可以要求用户在输入密码之后才能刷新外部数据区域。 以下过程不适用于从文本文件或 Web 查询 (.txt) .iqy (检索) 。

使用由大写字母、小写字母、数字和符号组合的强密码。 弱密码不混合使用这些元素。 例如,强密码:Y6dh!et5。 弱密码:House27。 密码应至少包含 8 个字符。 最好使用包含 14 个或更多字符的密码。

务必记住密码。 如果您忘记了密码,Microsoft 无法为您找回。 请将记好的密码保存在安全位置,远离密码所要保护的信息。

  1. 单击外部数据区域中的某个单元格。

  2. 在“数据”选项卡上的“连接”组中,单击“全部刷新”,然后单击“连接属性”。

    连接属性

  3. 单击“定义”选项卡,然后取消选中“保存密码”复选框。

注意: Excel 仅在每个 Excel 会话中首次刷新外部数据区域时提示输入密码。 下次启动 Excel 时,如果打开包含查询的工作簿并尝试进行刷新操作,则会提示您再次输入密码。

对于非常大的数据集,请考虑运行后台刷新。 这会将 Excel 的控制权返回给您,以便您不必等待数分钟或更长时间来让刷新完成。

  1. 单击外部数据区域中的某个单元格。

  2. 在“数据”选项卡上的“连接”组中,单击“全部刷新”,然后单击“连接属性”。

    连接属性

    注意: 不能在后台运行 OLAP 查询。

    注意: 不能为任何连接类型运行检索数据模型数据的查询。

  3. 单击“使用状况”选项卡。

  4. 选中“允许后台刷新”复选框以在后台运行查询。 清除此复选框可在您等待时运行查询。

    当你录制包含查询的宏时,Excel 不会在后台运行查询。 若要更改录制的宏以使查询在后台运行,请在 Visual Basic 编辑器中编辑宏。 将查询表对象的刷新方法从 BackgroundQuery := False 更改为 BackgroundQuery := True

如果您的工作簿连接到较大数据源,则刷新它所花的时间可能比预期要长。 若要检查刷新或将其取消,请执行下列操作之一:

  • 检查查询的状态    Excel 状态栏上将显示一条消息以指明查询正在运行。 双击消息以检查查询的状态。

  • 停止后台刷新    要停止后台运行的查询,请双击状态栏上的查询状态消息以显示“外部数据刷新状态”对话框,然后单击“停止刷新”。

  • 停止查询    若要阻止查询在后台刷新关闭时运行,请按 Esc 键。

如果使用了"&转换"来查询文本文件,则无需执行其他步骤。 如果导入了文本文件,则刷新步骤如下:

  1. 单击包含导入文本文件链接的区域或表格中的任一单元格。

  2. 在"数据"选项卡上的"连接"组中,单击"全部刷新"。

    鼠标指向功能区上的"刷新"命令

    要仅更新所选的数据,请单击“刷新

    您也可以右键单击区域或表格中的某个单元格,然后单击“刷新”。

  3. 在“导入文本文件”对话框中,通过浏览找到你的文本文件,然后单击“导入”。

刷新脱机多维数据集文件(即,使用服务器多维数据集中的最新数据重新创建该文件)不仅耗时,而且需要大量的临时磁盘空间。 请在不需要在 Excel 中立即访问其他文件时启动该过程,并确保有足够的磁盘空间来重新保存文件。

  1. 单击连接到脱机多维数据集文件的数据透视表。

  2. 在"数据"选项卡上的"连接"组中,单击"全部刷新",然后单击"刷新"。

    鼠标指向功能区上的"刷新"命令

  1. 在工作表上,单击映射的单元格以选择要刷新的 XML 映射。

  2. 如果“开发工具”选项卡不可用,请通过执行下列操作来显示该选项卡:

    1. 单击“文件”>“选项”>“自定义功能区”。

    2. “主选项卡”下,选中“开发工具”复选框,然后单击“确定”

  3. “开发工具”选项卡上的“XML”组中,单击“刷新数据”

    “XML”中的“刷新数据”

  • 在"数据"选项卡上的"连接"组中,单击"全部刷新"。

如果有多个连接,并且只想更新特定连接,请选择该数据区域内的任何单元格,单击"全部刷新"旁边的箭头,然后单击"刷新"。

鼠标指向功能区上的"刷新"命令

控制连接刷新方式或时间

  1. 单击包含已连接数据的任何单元格。

  2. 在"数据"选项卡上的"连接"组中,单击"全部刷新"旁边的箭头,然后单击"连接属性"。

    连接属性

  3. 在“用法”选项卡上设置要更改的任何选项。

    对于非常大的数据集,请考虑选中" 启用后台刷新" 选项。 这将在Excel一开始就返回对刷新的控制权,而不是让你等待刷新完成。

取消或检查刷新的状态

如果您的工作簿连接到较大数据源,则刷新它所花的时间可能比预期要长。 若要检查刷新或将其取消,请执行下列操作之一:

  • 检查查询的状态    Excel 状态栏上将显示一条消息以指明查询正在运行。 双击消息以检查查询的状态。

  • 停止后台刷新    要停止后台运行的查询,请双击状态栏上的查询状态消息以显示“外部数据刷新状态”对话框,然后单击“停止刷新”。

  • 停止查询    若要阻止查询在后台刷新关闭时运行,请按 Esc 键。

使用 Power Pivot 刷新以前导入的数据时,可以看到刷新是成功、失败还是已取消。

在 Power Pivot 中,单击"开始>"获取外部数据>"刷新"或"全部刷新"以重新导入数据模型中的当前表或所有表。

对于数据模型中使用的每个连接,会指示刷新状态。 有三种可能的结果。

PowerPivot 中的数据刷新状态消息

"成功"报告导入每个表中的行数。

如果数据库处于脱机状态、不再具有权限,或者删除或重命名了源中的表或列,则可能会发生"错误"。 验证数据库是否可用,也许可以在不同的工作簿中创建新连接。

"已取消"表示Excel未发出刷新请求,这可能是因为连接上已禁用刷新。

提示: 您是否正在与可能想要刷新数据的其他人共享此工作簿? 通过提醒同事请求对提供数据的数据源的权限,帮助同事避免数据刷新错误。

表属性显示数据刷新中使用的查询

数据刷新只是重新运行最初用于获取数据的同一查询。 可以通过在查询窗口中查看表属性来查看查询,有时 Power Pivot 查询。

  1. 要查看数据刷新期间使用的查询,请单击“Power Pivot”>“管理”以打开 Power Pivot 窗口。

  2. 单击"设计>表属性"。

  3. 切换到查询编辑器以查看基础查询。

查询不针对每种类型的数据源可见。 例如,不会针对数据源导入显示查询。

取消数据刷新的连接属性

在 Excel 中,可以设置用于确定数据刷新频率的连接属性。 如果特定连接上不允许刷新,则运行"全部刷新"或尝试刷新使用该连接的特定表时,将收到取消通知。

  1. 若要查看连接属性,请在 Excel 中单击">连接"以查看工作簿中使用的所有连接的列表。

  2. 选择连接,然后单击"属性"。

  3. "使用情况"中,在"刷新控件"下,如果清除"全部刷新"上"刷新此连接"的复选框,则当你在"刷新全部"窗口中尝试"全部刷新"时 Power Pivot 取消。

刷新 SharePoint Server 2013 或更高版本上的数据

在 SharePoint Server 上,您可以在服务器上计划无人参与的数据刷新,但这样做需要在 SharePoint Power Pivot 安装并配置 SharePoint 2013 的 Power Pivot 。 请与您的 SharePoint 管理员联系,了解计划的数据刷新是否可用。

注意:  Power Query 编辑器是"获取&的一部分。 若要了解详细信息,请参阅在 Excel 2016 中获取和转换

使用 Power Query 编辑器,可以刷新查询以将最新数据导入表中,而无需重新创建查询。

刷新查询:

  1. 单击"获取&转换>显示查询"。

  2. 在" 工作簿查询" 窗格中,选择要刷新的查询。

  3. "Power Query 编辑器"功能区中,单击"开始>查询>刷新预览"。

查询编辑器功能区

当用于地图的数据发生更改时,可以在 3D 地图中手动刷新它。 更改随后会反映在地图中。 操作方法如下:

  • 在 3D 地图中,单击"开始>刷新数据"。

“开始”选项卡上的“刷新数据”组

将数据添加到 Power Map

若要向 3D 地图添加新数据,Power Map :

  1. 在"3D 地图"中,转到要将数据添加到的地图。

  2. 使"3D 地图"窗口打开,在 Excel 中单击,然后选择要添加的工作表数据。

  3. 在 Excel 功能区上,单击“插入”>“地图”箭头 >“将选定数据添加到 Power Map”。

“将选定数据添加到 Power Map”命令

3D 地图将自动更新以显示其他数据。

已显示在 Microsoft Office Excel 工作簿中Excel Services可能来自两个不同的位置。 数据可以直接存储在工作簿中,也可以存储在外部数据源中,例如存储在数据库或联机分析处理中, (OLAP) 多维数据集。

如果数据来自外部数据源,则工作簿作者或管理员已定义连接信息,通常位于 Office 数据连接 (.odc) 文件中,该文件描述如何查找、登录、查询和访问外部数据源。

连接到外部数据源时,可以执行刷新操作来检索更新的数据。 每次刷新数据时,都可以看到最新版本的数据,包括自上次刷新以来对数据进行的任何更改。

了解如何刷新数据

下图说明了刷新连接到外部数据源的数据时发生的情况的基本过程。

刷新外部数据的基本流程

  1. 刷新操作获取最新数据。

  2. 连接通常保存到连接文件,用于定义从外部数据源访问和检索数据所需的全部信息。

  3. 可以访问各种数据源,例如 OLAP、SQL Server、OLEDB 提供程序和 ODBC 驱动程序。

  4. 最新数据将添加到当前工作簿。

了解安全问题

连接到外部数据源并尝试刷新数据时,必须注意潜在的安全问题,并知道可以如何处理任何安全问题。

数据连接文件通常包含用于刷新外部数据的一个或多个查询。 通过替换此文件,具有恶意意图的用户可以设计查询来访问机密信息并将其分发给其他用户或执行其他有害操作。 因此,必须确保连接文件是由可靠的个人创作的,并且连接文件是安全的,并且来自受信任的数据连接库 (DCL) 。

有关管理员如何创作连接文件、创建受信任位置和安全连接文件Microsoft Office Excel 帮助和 Office SharePoint Server 管理中心帮助。

注意: 访问外部数据源通常需要凭据 (例如用户名和密码) 用于对用户进行身份验证。 确保以安全的方式提供这些凭据,并且不会无意中向其他人透露这些凭据。

控制数据的刷新方法

可以通过执行以下一项或多项操作来控制如何从外部数据源刷新数据:

  • 打开时刷新   在 Excel 中,工作簿作者可以通过选中"连接属性"对话框中的"打开文件时刷新数据"复选框,创建在打开工作簿时自动刷新外部数据的工作簿。 ("数据"选项卡上的"连接"组中,单击"连接",选择连接,单击"属性",单击"用法"选项卡,然后在打开文件时单击"刷新数据") 在这种情况下,Excel Services始终刷新数据,然后再显示工作簿并创建新会话。 如果工作簿作者清除了"打开文件时刷新数据"复选框,则会显示与工作簿一起缓存的数据,这意味着当用户手动刷新数据时,用户将看到当前会话期间刷新的、最新的数据,但数据不会保存到工作簿。 如果要确保在 Excel Services 中显示工作簿时始终显示最新数据,请通过使用 Office Excel 选中"打开文件时刷新数据"复选框。

    如果使用的是 Office 数据连接文件 (.odc) ,请确保还设置了"连接属性"对话框中的"始终使用连接文件"复选框 (在"数据"选项卡上的"连接"组中,单击"连接",选择连接,单击"属性",单击"定义"选项卡,然后单击"始终使用连接文件) "。

    受信任的文件位置站点设置、 短会话超时外部数据缓存生存期也可能对刷新操作产生影响。 有关详细信息,请参阅您的管理员或 Microsoft Office SharePoint Server 管理中心帮助系统。

  • 手动刷新   

    注意: 只能手动刷新数据透视表。

    1. 选择数据透视表中的单元格。

    2. 在"Excel Web Access"工具栏上的"更新"菜单下,单击"刷新所选连接"。

      注意: 

      • 任何导致重新查询 OLAP 数据源的交互式操作将启动手动刷新操作。

      • 如果此 " 刷新"命令不可见,则Web 部件清除了"刷新所选连接,刷新所有 连接" 属性。 有关详细信息,请参阅自定义Excel Web Access Web 部件属性 。

  • 刷新所有连接   在"Excel Web Access"工具栏上的"更新"菜单下,单击"刷新所有连接"。

  • 定期刷新   通过使用 Excel,工作簿作者可以指定在工作簿中每个连接打开工作簿后,按指定时间间隔自动刷新数据。 例如,库存数据库可能每小时更新一次,因此工作簿作者已定义工作簿以每隔 60 分钟自动刷新一次。

    如果Web 部件工作簿作者定义了该属性,则Excel Web Access用户可选择或清除"允许定期数据刷新"属性来启用或禁用此定期刷新操作。 默认情况下,当时间间隔经过时,以下刷新警报提示显示在Excel Web Access Web 部件:

    刷新连接<列表>? (") (") ("不要再次询问我)

    用户Excel Web Access Web 部件还可以设置"显示定期数据刷新 提示 "属性来控制在会话期间执行定期数据刷新Excel Services显示的消息的行为:

    • 始终      表示消息在每个时间间隔内显示一次提示。

    • (可选)      表示用户可以选择继续定期刷新而不显示消息。

    • 从不      意味着Excel Web Access定期刷新,而不显示消息或提示。

    有关详细信息,请参阅自定义Excel Web Access Web 部件属性 。

  • 取消刷新   由于刷新操作所花的时间可能超过预期,因此可以取消它。 执行刷新操作时, Excel Services 显示一条包含提示的消息。 单击 " 取消"中断操作,以便可以在更方便的时间完成刷新操作。 取消刷新操作之前查询返回的数据将显示。

  1. 单击包含外部数据链接的区域或表格中的任一单元格。

  2. 在"数据"选项卡上的"连接"组中,单击"全部刷新"。

    刷新数据连接

    要仅更新所选的数据,请单击“刷新”。

    您也可以右键单击区域或表格中的某个单元格,然后单击“刷新”。

    注意: 如果有多个打开的工作簿,则需要在每个工作簿中重复上述操作。

  1. 单击包含导入文本文件链接的区域或表格中的任一单元格。

  2. 在"数据"选项卡上的"连接"组中,单击"全部刷新"。

    刷新数据连接

    要仅更新所选的数据,请单击“刷新

    您也可以右键单击区域或表格中的某个单元格,然后单击“刷新”。

  3. 在“导入文本文件”对话框中,通过浏览找到你的文本文件,然后单击“导入”。

刷新脱机多维数据集文件(即,使用服务器多维数据集中的最新数据重新创建该文件)不仅耗时,而且需要大量的临时磁盘空间。 请在不需要在 Excel 中立即访问其他文件时启动该过程,并确保有足够的磁盘空间来重新保存文件。

  1. 单击连接到脱机多维数据集文件的数据透视表。

  2. 在"数据"选项卡上的"连接"组中,单击"全部刷新",然后单击"刷新"。

    刷新数据连接

  1. 在工作表上,单击映射的单元格以选择要刷新的 XML 映射。

  2. 如果“开发工具”选项卡不可用,请通过执行下列操作来显示该选项卡:

    1. 单击“文件”>“选项”>“自定义功能区”。

    2. “主选项卡”下,选中“开发工具”复选框,然后单击“确定”

  3. “开发工具”选项卡上的“XML”组中,单击“刷新数据”

    “XML”中的“刷新数据”

  • 在"数据"选项卡上,单击"全部刷新"。

如果有多个连接,并且只想更新特定连接,请选择该数据区域内的任何单元格,单击"全部刷新"旁边的箭头,然后单击"刷新"。

刷新数据连接

控制连接刷新方式或时间

  1. 单击包含已连接数据的任何单元格。

  2. 在"数据"选项卡上,单击"全部刷新"旁边的箭头,然后单击"连接属性"。

    连接属性

  3. 在“用法”选项卡上设置要更改的任何选项。

    对于非常大的数据集,请考虑选中" 启用后台刷新" 选项。 这会返回对Excel的控制,而不是让你等待刷新完成。

取消或检查刷新的状态

如果您的工作簿连接到较大数据源,则刷新它所花的时间可能比预期要长。 若要检查刷新或将其取消,请执行下列操作之一:

  • 检查查询的状态    Excel 状态栏上将显示一条消息以指明查询正在运行。 双击消息以检查查询的状态。

  • 停止后台刷新    要停止后台运行的查询,请双击状态栏上的查询状态消息以显示“外部数据刷新状态”对话框,然后单击“停止刷新”。

  • 停止查询    若要阻止查询在后台刷新关闭时运行,请按 Esc 键。

使用 Power Pivot 刷新以前导入的数据时,可以看到刷新是成功、失败还是已取消。

  • 在 Power Pivot 中,单击"开始>获取外部数据>"刷新"或"全部刷新"以重新导入数据模型中的当前表或所有表。

    对于数据模型中使用的每个连接,会指示刷新状态。 有三种可能的结果。

    PowerPivot 中的数据刷新状态消息

"成功"报告导入每个表中的行数。

如果数据库处于脱机状态、不再具有权限,或者删除或重命名了源中的表或列,则可能会发生"错误"。 验证数据库是否可用,也许可以在不同的工作簿中创建新连接。

"已取消"表示Excel未发出刷新请求,这可能是因为连接上已禁用刷新。

提示: 您是否正在与可能想要刷新数据的其他人共享此工作簿? 通过提醒同事请求对提供数据的数据源的权限,帮助同事避免数据刷新错误。

表属性显示数据刷新中使用的查询

数据刷新只是重新运行最初用于获取数据的同一查询。 可以通过在查询窗口中查看表属性来查看查询,有时 Power Pivot 查询。

  1. 要查看数据刷新期间使用的查询,请单击“Power Pivot”>“管理”以打开 Power Pivot 窗口。

  2. 单击"设计>表属性"。

  3. 切换到查询编辑器以查看基础查询。

查询不针对每种类型的数据源可见。 例如,不会针对数据源导入显示查询。

取消数据刷新的连接属性

在Excel中,可以设置用于确定数据刷新频率的连接属性。 如果特定连接上不允许刷新,则运行"全部刷新"或尝试刷新使用该连接的特定表时,将收到取消通知。

  1. 若要查看连接属性,Excel单击">连接"以查看工作簿中使用的所有连接的列表。

  2. 选择连接,然后单击"属性"。

  3. "使用情况"中,在"刷新控件"下,如果清除"全部刷新"上"刷新此连接"的复选框,则当你在"刷新全部"窗口中尝试"全部刷新"时 Power Pivot 取消。

刷新 SharePoint Server 2013 上的数据

在 SharePoint Server 2013 中,您可以在服务器上安排无人参与的数据刷新,但是这样做需要在 SharePoint 环境中安装和配置 Power Pivot for SharePoint 2013。 请与您的 SharePoint 管理员联系,了解计划的数据刷新是否可用。

使用 Power Query,可以刷新查询以将最新数据导入表中,而无需重新创建查询。

重要: 

  • Excel 2010   Power Query 在 2010 Excel中,但您可以下载、安装和激活Power Query 加载项。

  • 若要激活Power Query加载项,请单击"文件">">加载项"。 在底部的“管理”部分中,从下拉列表中选择“COM 加载项”选项,然后单击“Go”。 单击“Power Query”复选框,再单击“确定”。 Power Query 功能区应会自动显示,但如果未显示,请关闭并重启Excel。

刷新查询:

  1. 在"查询编辑器"功能区中,单击"刷新预览"。

查询编辑器功能区

注意: 仅当您使用 Power Query 加载、编辑或创建新查询时,“查询编辑器”才会显示。 以下视频显示在 Excel 工作簿中编辑查询后显示的“查询编辑器”窗口。 若要查看查询编辑器而不加载或编辑现有工作簿查询,请从"Power Query"功能区选项卡的"获取外部数据"部分选择"从其他源">"空白查询"。 以下视频介绍一种显示查询编辑器的方法。

如何在 Excel 中查看查询编辑器

如果您的 Excel 工作簿具有到 Access 数据库中的表或查询的连接,您可以确保其显示最新信息。 使用“刷新”命令(在“数据”选项卡上)执行此操作。

  1. 在工作表上,单击包含 Access 数据的任意单元格。

  2. 在“数据”选项卡上的“连接”组中,单击“全部刷新”旁边的箭头,然后单击“刷新”。

刷新数据连接

要控制刷新连接的方式或频率,请执行以下操作:

  1. 单击包含 Access 数据的任意单元格。

  2. 在“连接”组中,单击“全部刷新”旁边的箭头,然后单击“连接属性”。

对于非常大的数据集,请考虑运行后台刷新。 这会将 Excel 的控制权返回给您,以便您不必等待数分钟或更长时间来让刷新完成。

连接属性

  1. 在“用法”选项卡上设置要更改的任何选项。

检查状态或取消刷新

如果您的工作簿连接到较大数据源,则刷新它所花的时间可能比预期要长。 若要检查或取消刷新,请执行下列一项或多项操作:

  • 检查查询的状态    Excel 状态栏上将显示一条消息以指明查询正在运行。 双击消息以检查查询的状态。

  • 停止后台刷新    要停止后台运行的查询,请双击状态栏上的查询状态消息以显示“外部数据刷新状态”对话框,然后单击“停止刷新”。

  • 停止查询    若要阻止查询在后台刷新关闭时运行,请按 Esc 键。

如果 Excel 工作簿连接到了 SQL Server 数据库中的表或查询,则可确保其显示最新信息。 请使用“数据”选项卡上的“刷新”命令执行此操作。

  1. 在工作表上,单击包含 SQL Server 数据的任意单元格。

  2. 在“数据”选项卡上的“连接”组中,单击“全部刷新”旁边的箭头,然后单击“刷新”。

刷新数据连接

要控制刷新连接的方式或频率,请执行以下操作:

  1. 单击包含 SQL Server 数据的任意单元格。

  2. 在“连接”组中,单击“全部刷新”旁边的箭头,然后单击“连接属性”。

对于非常大的数据集,请考虑运行后台刷新。 这会将 Excel 的控制权返回给您,以便您不必等待数分钟或更长时间来让刷新完成。

连接属性

  1. 在“用法”选项卡上设置要更改的任何选项,例如启用后台刷新。

取消或检查刷新的状态

如果您的工作簿连接到较大数据源,则刷新它所花的时间可能比预期要长。 若要检查刷新或将其取消,请执行下列操作之一:

  • 检查查询的状态    Excel 状态栏上将显示一条消息以指明查询正在运行。 双击消息以检查查询的状态。

  • 停止后台刷新    要停止后台运行的查询,请双击状态栏上的查询状态消息以显示“外部数据刷新状态”对话框,然后单击“停止刷新”。

  • 停止查询    若要阻止查询在后台刷新关闭时运行,请按 Esc 键。

如果 Excel 工作簿连接到了 OLE DB 数据源中的表或查询,则可确保其显示最新信息。 请使用“数据”选项卡上的“刷新”命令执行此操作。

  1. 在工作表上,单击包含 OLE DB 数据的任意单元格。

  2. 在“数据”选项卡上的“连接”组中,单击“全部刷新”旁边的箭头,然后单击“刷新”。

刷新数据连接

要控制刷新连接的方式或频率,请执行以下操作:

  1. 单击包含 OLE DB 数据的任意单元格。

  2. 在“连接”组中,单击“全部刷新”旁边的箭头,然后单击“连接属性”。

对于非常大的数据集,请考虑运行后台刷新。 这会将 Excel 的控制权返回给您,以便您不必等待数分钟或更长时间来让刷新完成。

连接属性

  1. 在“用法”选项卡上设置要更改的任何选项。

检查或取消刷新

如果您的工作簿连接到较大数据源,则刷新它所花的时间可能比预期要长。 若要检查或取消刷新,请执行下列操作之一:

  • 检查查询的状态    Excel 状态栏上将显示一条消息以指明查询正在运行。 双击消息以检查查询的状态。

  • 停止后台刷新    要停止后台运行的查询,请双击状态栏上的查询状态消息以显示“外部数据刷新状态”对话框,然后单击“停止刷新”。

  • 停止查询    若要阻止查询在后台刷新关闭时运行,请按 Esc 键。

当用于地图的数据发生更改时,可以在 3D 地图中手动刷新地图。 更改随后会反映在地图中。 操作方法如下:

  • 在 3D 地图中,单击"开始>刷新数据"。

“开始”选项卡上的“刷新数据”组

将数据添加到 Power Map

若要将新数据添加到 3D 地图Power Map :

  1. 在 3D 地图中,转到要将数据添加到的地图。

  2. 使 3D 地图窗口打开,单击Excel并选择要添加的工作表数据。

  3. 在 Excel 功能区上,单击“插入”>“地图”箭头 >“将选定数据添加到 Power Map”。

“将选定数据添加到 Power Map”命令

3D 地图将自动更新以显示其他数据。

手动刷新

  1. 单击数据透视表中的任意位置。

    此时会显示" 数据透视表工具",添加 "选项" 和"设计 " 选项卡。

  2. 在" 选项 "选项卡上的"数据 " 组中,执行下列操作之一:

  3. 若要更新信息以匹配数据源,请单击"刷新 " 按钮,或按 Alt+F5。

    也可以右键单击数据透视表,然后单击"刷新"。

  4. 若要刷新工作簿中所有数据透视表,请单击"刷新"按钮箭头,然后单击"全部刷新"。

    Excel 功能区图像

    如果刷新时间超过预期,请单击"选项">"刷新>"刷新状态"检查刷新状态。

    要停止刷新,请单击“取消刷新”。

防止调整列宽和单元格格式

如果在刷新数据透视表数据时,数据的列宽度和单元格格式违背你的意愿进行了调整,请确保检查以下选项:

  1. 单击"选项>选项"。

    “数据透视表工具”下“选项”选项卡上的“数据透视表”组
  2. 在“布局和格式”选项卡上,选中“更新时自动调整列宽”和“更新时保留单元格格式”框。

打开工作簿时自动刷新数据透视表数据

  1. 单击数据透视表中的任意位置。

  2. 在“选项”选项卡的“数据透视表”组中,单击“选项”。

    “数据透视表工具”下“选项”选项卡上的“数据透视表”组

  3. 在" 数据透视表选项 "对话框中的" 数据" 选项卡上,选中"打开 文件时刷新数据 "复选框。

已显示在Microsoft Office Excel工作簿中Excel Services数据可能来自两个不同的位置。 数据可以直接存储在工作簿中,也可以存储在外部数据源中,例如存储在数据库或联机分析处理中, (OLAP) 多维数据集。

如果数据来自外部数据源,则工作簿作者或管理员已定义连接信息,通常位于 Office 数据连接 (.odc) 文件中,该文件介绍如何查找、登录、查询和访问外部数据源。

连接到外部数据源时,可以执行刷新操作来检索更新的数据。 每次刷新数据时,都可以看到最新版本的数据,包括自上次刷新以来对数据进行的任何更改。

了解如何刷新数据

下图说明了刷新连接到外部数据源的数据时发生的情况的基本过程。

刷新外部数据的基本流程

  1. 刷新操作获取最新数据。

  2. 连接通常保存到连接文件,用于定义从外部数据源访问和检索数据所需的全部信息。

  3. 可以访问各种数据源,例如 OLAP、SQL Server、OLEDB 提供程序和 ODBC 驱动程序。

  4. 最新数据将添加到当前工作簿。

了解安全问题

连接到外部数据源并尝试刷新数据时,必须注意潜在的安全问题,并知道可以如何处理任何安全问题。

数据连接文件通常包含用于刷新外部数据的一个或多个查询。 通过替换此文件,具有恶意意图的用户可以设计查询来访问机密信息并将其分发给其他用户或执行其他有害操作。 因此,必须确保连接文件是由可靠的个人创作的,并且连接文件是安全的,并且来自受信任的数据连接库 (DCL) 。

若要详细了解管理员如何创作连接文件、创建受信任位置和安全连接文件,请参阅 Microsoft Office Excel 2007 帮助和 Office SharePoint Server 管理中心帮助。

安全说明: 访问外部数据源通常需要凭据 (例如用户名和密码) 用于对用户进行身份验证。 确保以安全的方式提供这些凭据,并且不会无意中向其他人透露这些凭据。

控制数据的刷新方法

可以通过执行以下一项或多项操作来控制如何从外部数据源刷新数据:

  • 打开时刷新   在 Microsoft Office Excel 2007 中,工作簿作者可以通过在"连接属性"对话框中选中"打开文件时刷新数据"复选框,创建在打开工作簿时自动刷新外部数据的工作簿。 ("数据"选项卡上的"连接"组中,单击"连接",选择连接,单击"属性",单击"用法"选项卡,然后在打开文件时单击"刷新数据") 在这种情况下,Excel Services始终刷新数据,然后再显示工作簿并创建新会话。 如果工作簿作者清除了"打开文件时刷新数据"复选框,则会显示与工作簿一起缓存的数据,这意味着当用户手动刷新数据时,用户将看到当前会话期间刷新的、最新的数据,但数据不会保存到工作簿。 如果要确保在 Excel Services 中显示工作簿时始终显示最新数据,请选中"打开文件时刷新数据"复选框,使用 Office Excel。

    如果使用 Office 数据连接文件 (.odc) ,请确保还设置了"连接属性"对话框中的"始终使用连接文件"复选框 (在"数据"选项卡上的"连接"组中,单击"连接",选择连接,单击"属性",单击"定义"选项卡,然后单击"始终使用连接文件) "。

    受信任的文件位置站点设置、 短会话超时外部数据缓存生存期也可能对刷新操作产生影响。 有关详细信息,请参阅管理员或 Microsoft Office SharePoint Server 管理中心帮助系统。

  • 手动刷新   

    注意: 只能手动刷新数据透视表。

    1. 选择数据透视表中的单元格。

    2. 在 Web Excel工具栏上的"更新"菜单下,单击"刷新所选连接"。

      注意: 

      • 任何导致重新查询 OLAP 数据源的交互式操作将启动手动刷新操作。

      • 如果此 " 刷新"命令不可见,则Web 部件清除了"刷新所选连接,刷新所有 连接" 属性。 有关详细信息,请参阅 Web Access Excel自定义Web 部件属性 。

  • 刷新所有连接   在 Web Excel工具栏上的"更新"菜单下,单击"刷新所有连接"。

  • 定期刷新   通过使用 Office Excel 2007 ,工作簿作者可以指定在工作簿中每个连接打开工作簿后,按指定的时间间隔自动刷新数据。 例如,库存数据库可能每小时更新一次,因此工作簿作者已定义工作簿以每隔 60 分钟自动刷新一次。

    如果Web 部件工作簿作者定义了该属性,则用户作者可以选择或清除"允许Excel Web Access定期数据刷新"属性来启用或禁用此定期刷新操作。 默认情况下,当时间间隔过后,Web Access Excel底部会显示以下Web 部件:

    刷新连接<列表>? (") (") ("不要再次询问我)

    Excel Web Access Web 部件还可以设置"显示定期数据刷新提示"属性,以控制 Excel Services 在会话期间执行定期数据刷新时显示的消息的行为:

    • 始终      表示消息在每个时间间隔内显示一次提示。

    • (可选)      表示用户可以选择继续定期刷新而不显示消息。

    • 从不      这意味着,Excel Web Access 执行定期刷新而不显示消息或提示。

    有关详细信息,请参阅 Web Access Excel自定义Web 部件属性 。

  • 取消刷新   由于刷新操作所花的时间可能超过预期,因此可以取消它。 执行刷新操作时, Excel Services 显示一条包含提示的消息。 单击 " 取消"中断操作,以便可以在更方便的时间完成刷新操作。 取消刷新操作之前查询返回的数据将显示。

您可以在打开工作簿时自动刷新外部数据区域。 或者,您可以保存工作簿而不保存外部数据,以缩减文件的大小。

  1. 单击外部数据区域中的某个单元格。

  2. 在“数据”选项卡上的“连接”组中,单击“全部刷新”,然后单击“连接属性”。

    连接属性

  1. 单击“使用状况”选项卡。

  2. 在“刷新控件”下,选中“打开文件时刷新数据”复选框。

  3. 如果要在保存工作簿时保存查询定义,但不保存外部数据,请选中“保存工作簿前,删除来自外部数据区域中的数据”复选框。

  1. 单击外部数据区域中的某个单元格。

  2. 在“数据”选项卡上的“连接”组中,单击“全部刷新”,然后单击“连接属性”。

    连接属性

  3. 单击“使用状况”选项卡。

  4. 选中“刷新频率”复选框,然后输入每次刷新操作之间的分钟数。

存储的密码未经加密,因此我们不建议您使用。 如果您的数据源需要密码才能连接,则可以要求用户在输入密码之后才能刷新外部数据区域。 以下过程不适用于从文本文件或 Web 查询 (.txt) .iqy (检索) 。

使用由大写字母、小写字母、数字和符号组合的强密码。 弱密码不混合使用这些元素。 例如,强密码:Y6dh!et5。 弱密码:House27。 密码应至少包含 8 个字符。 最好使用包含 14 个或更多字符的密码。

务必记住密码。 如果您忘记了密码,Microsoft 无法为您找回。 请将记好的密码保存在安全位置,远离密码所要保护的信息。

  1. 单击外部数据区域中的某个单元格。

  2. 在“数据”选项卡上的“连接”组中,单击“全部刷新”,然后单击“连接属性”。

    连接属性

  3. 单击“定义”选项卡,然后取消选中“保存密码”复选框。

注意: Excel 仅在每个 Excel 会话中首次刷新外部数据区域时提示输入密码。 下次启动 Excel 时,如果打开包含查询的工作簿并尝试进行刷新操作,则会提示您再次输入密码。

对于非常大的数据集,请考虑运行后台刷新。 这会将 Excel 的控制权返回给您,以便您不必等待数分钟或更长时间来让刷新完成。

  1. 单击外部数据区域中的某个单元格。

  2. 在“数据”选项卡上的“连接”组中,单击“全部刷新”,然后单击“连接属性”。

    连接属性

    注意: 不能在后台运行 OLAP 查询。

    注意: 不能为任何连接类型运行检索数据模型数据的查询。

  3. 单击“使用状况”选项卡。

  4. 选中“允许后台刷新”复选框以在后台运行查询。 清除此复选框可在您等待时运行查询。

    当你录制包含查询的宏时,Excel 不会在后台运行查询。 若要更改录制的宏以使查询在后台运行,请在 Visual Basic 编辑器中编辑宏。 将查询表对象的刷新方法从 BackgroundQuery := False 更改为 BackgroundQuery := True

如果您的工作簿连接到较大数据源,则刷新它所花的时间可能比预期要长。 若要检查刷新或将其取消,请执行下列操作之一:

  • 检查查询的状态    Excel 状态栏上将显示一条消息以指明查询正在运行。 双击消息以检查查询的状态。

  • 停止后台刷新    要停止后台运行的查询,请双击状态栏上的查询状态消息以显示“外部数据刷新状态”对话框,然后单击“停止刷新”。

  • 停止查询    若要阻止查询在后台刷新关闭时运行,请按 Esc 键。

另请参阅

Microsoft Power Query for Excel 帮助

在 SharePoint Server 中刷新工作簿中的外部数据

更改公式重新计算、迭代或精度(以Excel

需要更多帮助?

扩展你的技能
了解培训

此信息是否有帮助?

你对翻译质量的满意程度如何?
哪些因素影响了你的体验?

谢谢您的反馈意见!

×