在 Office 中检查拼写和语法

所有 Microsoft Office 程序都可检查拼写,大部分程序可以检查语法。 

如果发现拼写或语法检查没有按预期的方式工作,请参阅拼写和语法检查器无法正常工作。 如果需要检查不是默认语言的拼写或语法,请参阅使用不同语言检查拼写和语法

使用 Office 365? 你可能希望了解 Word 编辑器强大的新功能! 有关详细信息,请参阅编辑器 - 你的写作助手

手动运行拼写和语法检查

若要在文件中开始拼写和语法检查,只需按 F7 或按以下步骤操作:

  1. 打开大多数 Office 程序,单击功能区上的“审阅”选项卡。 在 Access​​ 或 InfoPath​​ 中可以跳过此步骤。 在 Project 中,转到“项目”选项卡。

  2. 单击“拼写”或“拼写和语法”。

    “审阅”功能区上的“拼写和语法”按钮

  3. 如果程序发现拼写错误,则会显示一个对话框,其中包含拼写检查器发现的第一个拼错的单词。

  4. 确定了如何解决拼写错误(忽略、添加到程序字典或者更改)后,程序会移到下一个拼写错误的单词。

单击下面的标题了解详细信息

大多数 Office 程序会在用户键入内容时自动检查可能存在的拼写和语法错误,这样无需执行任何操作即可在工作时显示错误。 

注意: 

  • Access、Excel​​ 和 Project 中不提供自动拼写和语法检查功能。 可以通过按 F7 手动启动拼写检查。

  • 自动语法检查仅在 Outlook、Word、PowerPoint 2013(或更高版本)中提供。

Office 用红色波浪线标记可能存在的拼写错误,并使用蓝色波浪线标记可能存在的语法错误。

如果未标记拼写或语法错误,自动检查可能已关闭。 可打开自动拼写和语法检查

看到需要辅助修复的拼写或语法错误时,右键单击有下划线的单词或短语并选择其中一个选项修复错误。

如果 Office 将某词标记为拼写错误但是你是按照自己所需方式拼写的,则选择“添加到词典”使 Office 以后不再将该词标记为拼写错误。 有关详细信息,请参阅:在拼写检查字典中添加或编辑单词

如果不希望 Office 在你工作时使用波浪线标记可能存在的错误,可关闭自动拼写和语法检查:

  1. 打开拼写和语法选项:

    • 在 OneNote、PowerPoint、Publisher、Visio 和 Word 中:在“文件”菜单上,单击“选项”,然后单击“校对​​”。

    • 在 InfoPath​​ 中:在“开始”选项卡上,单击“拼写检查”旁边或下面的箭头,然后单击“拼写检查选项”。

    • 在 Outlook 中:在“文件”菜单上,依次单击“选项”、“邮件”和“拼写检查和自动更正”。

  2. 选中或清除“键入时检查拼写”复选框。 在某些有自动语法检查的程序中,可能还需选中或清除“键入时标记语法错误”复选框。

    “键入时检查拼写”复选框

    注意: 在 Word 中,可对正在处理的文档或所有新文档打开或关闭拼写检查。 在“例外项”列表选择一个选项,然后选中或清除“只隐藏此文档中的拼写错误”和“只隐藏此文档中的语法错误”复选框。

如果完全不希望 Office 检查语法(无论是在运行拼写检查时还是键入时进行自动检查),可将其关闭:

  1. 打开拼写和语法选项:

    • 在 OneNote、PowerPoint、Publisher、Visio 和 Word 中:在“文件”菜单上,单击“选项”,然后单击“校对​​”。

    • 在 InfoPath​​ 中:在“开始”选项卡上,单击“拼写检查”旁边或下面的箭头,然后单击“拼写检查选项”。

    • 在 Outlook 中:在“文件”菜单上,依次单击“选项”、“邮件”和“拼写检查和自动更正”。

  2. 清除“键入时标记语法错误”和“随拼写检查语法”复选框。

    “语法检查”复选框

    注意: 并非所有 Office 程序都有这两个选项。

在 Word、Outlook、PowerPoint 2013(或更高版本)中,通过执行下列操作,可强制重新检查之前跳过的单词和语法:

  1. 打开要检查的文档或项目。

  2. 在“文件”菜单上,单击“选项”>“校对”>“重新检查文档”。 在 Outlook 中,将在“文件”>“选项”>“邮件”>“拼写和自动更正”下找到此选项

  3. 显示重置拼写和语法检查的警告消息时,单击“”。

  4. 在对话框中单击“确定”返回到文档中,然后再次运行拼写和语法检查

我们将认真倾听!

本文最后由 Ben2019 年 10 月 28 日更新。 如果你觉得本文有用,或者觉得本文没有用(特别是这种情况),请使用下方的反馈控件为我们留一些我们如何做得更好的建议性意见。

另请参阅

测试文档的可读性

拼写和语法检查无法正常工作

选择 Office 2013 及更早版本中的语法和写作风格选项

向拼写检查词典添加单词

拼写或语法检查无法正确检查其他语言的文字

针对大写、拼写和符号选择“自动更正”选项

在 Outlook 中发送邮件前检查拼写

Office for Mac 应用程序会在你键入时自动检查可能存在的拼写和语法错误。 如果希望在完成撰写后检查拼写和语法,可以关闭自动检查,或者集中检查拼写和语法。

Word

在键入的同时,自动检查拼写和语法。

Word 用红色波浪线标记可能存在的拼写错误,并使用绿色波浪线标记可能存在的语法错误。

提示: 如果未标记语法错误,可能需要启用自动拼写和语法检查,具体详情将在下一过程中说明。

看到拼写或语法错误时,请按住 Control 并单击相应单词或短语,然后选择其中一个选项。

如果 Word 错误地将某个字词标记为拼写错误,并且你想要将该单词添加到词典中,以便 Word 以后正确识别,请参阅“ 在拼写检查词典中添加或编辑单词

  1. 在“Word”菜单上,单击“首选项”>“拼写和语法”。

  2. 在“拼写和语法”对话框中的“拼写”下,选中或清除“键入时检查拼写”框。

  3. 在“语法”下,选中或清除“键入时检查语法”复选框。

  4. 关闭对话框保存所做更改。

  1. 在“审阅”选项卡上,单击“拼写和语法”。

  2. 如果 Word 找到了潜在错误,将打开“拼写和语法”对话框,而拼写错误将显示为红色文本,语法错误则显示为绿色文本。

  3. 要修正错误,请执行下列操作之一:

    • 在框中键入更正内容,然后单击“更改”。

    • 在“建议”下,单击要使用的单词,然后单击“更改”。

    要跳过错误,请执行下列操作之一:

    • 单击“忽略”仅跳过该错误的此实例。

    • 单击“全部忽略”跳过该错误的所有实例。

    • 对于语法错误,单击“下一句”跳过该错误的此实例,移动到下一个错误。

    要在所有文档中跳过某个拼写错误的单词,请单击“添加”将其添加到词典。 这仅适用于拼写错误的单词。 不能向词典添加自定义语法。

  4. 更正、忽略或跳过错误后,Word 将移至下一项。 Word 审阅完文档后,你将看到一条消息,说明已完成了拼写和语法检查。

  5. 请单击“确定”返回到文档。

可清除或重新设置忽略的字词和语法列表,使 Word 可以检查你之前选择忽略的拼写和语法问题。

注意: 当你重置忽略的字词和语法列表时,将仅清除当前打开的文档的列表。 你在其他文档中指示 Word 忽略的任何拼写或语法问题不会受到影响。

  1. 打开需要检查的文档。

  2. 在“工具”菜单上,指向“拼写和语法“,然后单击“重置忽略的字词和语法”。

    要清除 Word 忽略的字词和语法的列表,请单击“重置忽略的字词和语法”。

    Word 会显示一条有关重置拼写检查和语法检查的操作的警告。

    通过单击“是”,让 Word 检查你之前指示 Word 忽略的拼写和语法。
  3. 单击“ ” 继续操作。

  4. 单击“审阅”选项卡,然后单击“拼写和语法”以检查拼写和语法。

Outlook

在键入的同时,自动检查拼写和语法。

默认情况下,键入时,Outlook 会检查拼写错误。 Outlook 使用红色虚线下划线指示可能的拼写错误,使用绿色虚线表示可能的语法错误。

  1. 当看到带虚线下划线的单词时,按住 Control 并单击相应单词或短语,然后选择其中一个选项。

  2. 在快捷菜单上,执行下列操作之一:

    • 单击快捷菜单顶部的其中一个猜测。

    • 单击“忽略拼写”忽略该单词的一个实例。

    • 单击“学习拼写”,将单词添加到拼写词典。

打开电子邮件后:

  • 若要让 Outlook 自动更正拼写错误,请在 Outlook 菜单上,单击“首选项”。 在 "个人设置" 下单击“拼写和语法 ”。 单击“键入时检查拼写”旁的复选框。

  • 若要打开或关闭自动语法检查,请在 "Outlook" 菜单上,单击 "首选项"。 在 "个人设置" 下单击“拼写和语法 ”。 单击 "键入时检查语法"旁的复选框。

根据输入偏好检查拼写

可以在撰写完邮件或其他项之后,集中更正所有拼写和语法错误。

  1. 在“编辑”菜单上,指向“拼写和语法”,然后单击“拼写和语法”。

  2. 请执行以下任一操作:

    • 在建议列表中,单击要使用的单词,或在顶部的框中输入新的拼写,然后单击 "更改”。

    • 单击 "忽略"忽略这个单词并移到下一个拼写错误的单词。

    • 单击“添加”,将单词添加到拼写词典。

提示: 用于跳至下一个拼写或语法错误的键盘快捷方式是 命令 + ;。

PowerPoint

可在 PowerPoint 中检查拼写,但不能检查语法。

键入时自动检查拼写

PowerPoint 自动检查并使用红色波浪下划线标记潜在的拼写错误。

提示: 如果未标记拼写错误,可能需要启用自动拼写检查,具体详情将在下一过程中说明。

看到拼写错误时,按住 Ctrl 键单击或右键单击该字词或短语并选择其中一个建议的选项。

  1. 在“PowerPoint”菜单上,单击“首选项”>“拼写检查”。

  2. 在“拼写检查”对话框中,选中或清除“键入时检查拼写”框。

  1. 在“审阅”选项卡上,单击“拼写检查”。

  2. 如果 PowerPoint 查找潜在的错误,“拼写检查”窗格将会打开,并会显示拼写错误。

  3. 要修正错误,请执行下列操作之一:

    • 更正幻灯片上的错误。

    • 在“拼写检查”窗格中单击建议的单词之一,然后单击“更改”。

    要跳过错误,请执行下列操作之一:

    • 单击“忽略”仅跳过该错误的此实例。

    • 单击“全部忽略”跳过该错误的所有实例。

    • 单击“添加”可在所有文档中跳过某个拼写错误的单词,并将其添加到词典。

  4. 更正、忽略或跳过错误后,PowerPoint 将移至下一项。 PowerPoint 完成审阅演示文稿时,你将看到一则消息,通知你拼写检查已完成。

  5. 请单击“确定”返回到演示文稿。 

Excel

可在 Excel 中检查拼写,但不能检查语法。

集中检查拼写

  1. 在“审阅”选项卡上,单击“拼写检查”。

    注意: 如果未检测到拼写错误,或者字典中已经包含你在尝试的单词,将不打开“拼写检查”对话框。

  2. 请执行以下任一操作。

    若要

    执行此操作

    更改单词

    在“建议”下,单击要使用的单词,然后单击“更改”。

    更改这个文档中出现的所有该单词

    在“建议”下,单击要使用的单词,然后单击“全部更改”。

    忽略该单词,移动到下一个拼写错误的单词

    单击“ 忽略一次”。

    忽略此文档中出现的所有此单词,移动到下一个拼写错误的单词

    单击“全部忽略”。

另请参阅

使用不同语言检查拼写和语法

需要更多帮助?

扩展你的 Office 技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×