重要
2026 年 10 月之后,将不再支持 Microsoft Publisher。 Microsoft 365 订阅者将不再具有访问权限。 了解有关 Publisher 停用的详细信息。
如果希望创建大量基本相同但包含一些唯一信息的文档,可以使用邮件或电子邮件合并。 例如,可以使用邮件合并创建具有个性化备注或唯一地址和称呼的单独自定义出版物。 还可使用邮件合并创建要自定义的产品公告,然后再发送给特定人员。 出版物的文本始终相同,但每个收件人的姓名和地址不同。
本文内容
选择 Mail Merge 或 Email Merge
首先要做的是选择是创建用于打印的邮件合并还是创建用于联机分发的电子邮件合并。
- 单击 “邮件 ”选项卡,然后选择“ 邮件合并” 或“ 电子邮件合并”。
创建或连接到收件人列表
若要执行邮件合并,需要打开新的或现有出版物,然后连接到包含要包含在) 的唯一信息 (文件的数据源。 数据文件可能包含名称和地址、产品数据或图片列表。 数据文件可以有多种格式,包括:
- Outlook 联系人列表
- Excel 工作表
- Word 表格
- Access 数据库表
- 制表符或逗号分隔列,段落返回分隔行的文本文件
可以连接到现有列表或数据源,也可以创建新的收件人列表。 如果您只想在列表中使用某些条目,您可以按特定条件筛选您的列表。 还可以按字母顺序对项目进行排序。
注意
如果要将图片合并到发布页中,则数据源必须包含要合并的图片文件的文件名或路径。 不要在数据源中包含实际的图片或图像。
使用现有列表
- 单击 邮件>选择收件人使用>现有列表。
默认情况下,Publisher 将数据源存储在“ 我的数据源 ”文件夹中。 可能需要浏览以找到数据源。 - 在 “选择数据源” 对话框中,单击所需的数据源,然后单击“ 打开”。
根据所选数据源的类型,可能会出现要求提供特定信息的其他对话框。 例如,如果数据源是一个包含多个工作表中信息的 Excel 工作簿,则需要选择包含所需信息的工作表。
从 Outlook 联系人中选择
- 单击 邮件>选择收件人>从 Outlook 联系人中选择。
如果系统提示您选择邮件配置文件,请单击所需的配置文件,然后单击“ 确定”。 - 在 “选择联系人” 对话框中,单击所需的联系人列表,然后单击“ 确定”。
文件夹中的所有联系人都将显示在“ 邮件合并收件人 ”对话框中,从中可以筛选和排序要包含在合并中的收件人列表。
键入新列表
如果没有要连接到的现有列表,可以创建新列表。
单击 邮件>选择收件人>键入新列表。
在“ 新建地址列表 ”对话框中,在与邮件相关的字段中键入第一个条目的信息。
注意
要更改默认列,请单击“ 自定义列” ,然后添加、删除、重命名和重新排序列表中的列。
输入完第一个条目的信息后,单击 “新建条目”。
重复步骤 2 和步骤 3,直到完成添加条目,然后单击 “确定”。
在“ 保存地址列表 ”对话框的“ 文件名 ”框中键入地址列表的名称,然后将其保存。
注意
默认情况下,Publisher 将地址列表保存在“ 我的数据源 ”文件夹中。 最好将地址列表保留在此处,因为这也是 Publisher 在其中查找数据源的默认文件夹。
新列表中的所有联系人都将显示在“ 邮件合并收件人” 对话框中,从中可以筛选和排序要包含在合并中的收件人列表。
选择收件人
在 “邮件合并收件人” 对话框中,可以选择要包含在合并中的收件人。 选中要包含的收件人旁边的复选框,清除要排除的收件人旁边的复选框。
如果您只想在列表中使用某些条目,则可以按特定字段或条件筛选列表。 筛选列表后,可以使用检查框包括和排除记录。
筛选列表中的项目:
单击要作为筛选依据的项的列标题旁边的箭头。
单击以下任一选项:
(空白) 显示相应字段为空白的所有记录。
(非空白) 显示相应字段包含信息的所有记录。
(高级) 打开“ 筛选和排序 ”对话框,您可以使用该对话框根据多个条件进行筛选。 您也可以单击下面的 筛选 在“邮件合并收件人”对话框中的“优化收件人列表”下,以打开“筛选和排序”对话框。
若要快速选择或清除所有项目,请选中或清除检查框列标题。
提示
如果数据源包含共享相同信息的记录,并且列中只有 10 个或更少的唯一值,则可以按特定信息进行筛选。 例如,如果有多个地址将澳大利亚列为国家/地区,则可以使用 澳大利亚进行筛选。
“ 邮件合并收件人 ”对话框仅显示指定的记录。 若要再次显示所有记录,请单击“ (所有记录) ”。
如果要按字母顺序查看项目,可以对列表中的项目进行排序。
对列表中的项目进行排序:
- 在“ 邮件合并收件人” 对话框中,单击要充当排序依据的项目的列标题。 例如,如果要按姓氏的字母顺序显示列表,请单击“ 姓氏 ”列标题。
- 若要使用多个条件进行排序,请在“ 邮件合并收件人” 对话框中单击“ 排序”。 在显示的 “筛选和排序 ”对话框中,选择要作为排序依据的条件。
准备出版物
邮件合并使用占位符信息和添加到每个文档的占位符信息中的唯一信息,从单个模板创建许多文档。 收集好收件人列表后,您就可以准备好主模板了。
插入文本框
- 单击“插入>”“绘制文本框
。 - 在出版物中,指向文本框一角要显示的位置,然后沿对角线拖动,直到获得所需文本框大小。
在每个版本中添加所需的文本
- 在文本框内单击,然后键入要在每个版本的邮件合并出版物中显示的文本。
向出版物添加数据字段
在邮件合并出版物中,在要插入数据字段的文本框内单击。
插入以下任一内容:
包含名称、地址和其他信息的地址块:
在 “写入 & 插入字段 ”组中,单击 “地址块”。
在“ 插入地址块 ”对话框中,单击要包含的地址元素,然后单击“ 确定”。
注意
如果数据源中数据字段的名称与 Publisher 用于地址块的字段名称不一致,则可能需要单击“插入地址块”对话框中的“匹配字段”。 在 匹配字段对话框 中,使用下拉列表从数据源中选择与发布者字段对应的字段。
问候语
在 “写入 & 插入字段 ”组中,单击 “问候语”。
在“ 问候语 ”对话框中,选择问候语格式,其中包括称呼语、姓名格式和标点符号。
选择在 Publisher 无法解释收件人姓名的情况下显示的文本;例如,当数据源不包含收件人的名字或姓氏,而只包含公司名称时,请单击 “确定”。
注意
如果数据源中数据字段的名称与 Publisher 用于问候语的字段名称不匹配,则可能需要单击“问候语”对话框中的“匹配字段”。 在 匹配字段对话框 中,使用下拉列表从数据源中选择与发布者字段对应的字段。
图片
- 在 “写入 & 插入字段 ”组中,单击 “图片”,然后单击 “插入图片字段”。
- 在“ 插入图片域 ”对话框中,选择要插入的图片域。
-
注意
如果要将图片合并到发布页中,则数据源必须包含要合并的图片文件的文件名或路径。 不要在数据源中包含实际的图片或图像。
各个信息字段
- 在 “写入 & 插入字段 ”组中,选择“ 插入合并域”,然后单击要包括在文本框中的字段。
设置数据字段的格式
可以将格式应用于数据字段和已添加 (的任何其他文本(例如“你好”的问候语或“亲爱的...) ”之类的称呼,以更改合并数据的外观。 若要设置合并数据的格式,你需要设置邮件合并出版物中的数据字段的格式。
在邮件合并出版物中,选择包含要设置格式的信息的字段。
- 如果字段是地址块或问候语,请在“ 写入”&“插入字段 ”组中选择 “格式”。
- 如果该字段是单独的数据字段,请在“ 文本框工具 格式”菜单上单击“ 字体”,然后选择所需的选项。
- 如果 Publisher 将所选字段识别为数字、货币、日期或时间,请单击 “格式” 并更改这些类型字段的显示方式的格式。
在出版物的数据域中预览收件人数据
您可以查看您的出版物将如何与合并域中的实际数据一起显示。
若要预览出版物,请单击“ 预览结果”,然后执行下列操作之一:
- 要按顺序预览条目,请单击导航按钮
”
,以查看每个条目在合并出版物中的显示方式。
来自数据源的第一条记录的信息填充合并域。 不能编辑发布页上的数据源条目,但可以在其中设置格式、移动或删除数据字段。 - 若要查找和预览数据源中的特定条目,请单击“ 查找收件人”,然后在 “查找条目” 对话框中输入搜索条件。
如果需要,可以更改收件人列表。 请执行以下任一操作:
- 要从合并中排除特定收件人,请单击“ 排除此收件人”。
- 若要更改收件人列表,请单击“ 编辑收件人列表”,然后在“ 邮件合并收件人 ”对话框中进行更改。
完成邮件合并发布并插入所有合并域后,单击“ 文件> ”单击 “另存为”,为发布命名,然后单击“ 保存”。
创建合并的出版物
若要创建合并的出版物,请单击 “完成 & 合并 ”按钮,然后按照以下说明打印、预览、保存、将合并的页面添加到其他出版物,或通过电子邮件发送。
打印已合并的出版物
单击 “合并到打印机”。
在 “打印 ”区域中,选择所需的选项,然后单击 “确定”。
重要
若要在每张纸上打印不同的合并数据集(例如,不同的名称和地址),请单击“打印选项”部分中的“每张纸多页”。 如果选择 “每张纸多份副本”,则每张纸张将包含相同数据的多个副本。
保存合并的出版物供以后使用
如果要编辑合并的页面、保存它们以供以后使用或日后打印它们,您可以将所有合并的页面收集并保存为包含实际数据而不是合并域的单个新合并出版物。
- 单击 “合并到新出版物”。
- 在新出版物的“ 邮件合并 ”任务窗格中,单击“ 保存此出版物”。 为新出版物命名,然后单击 “保存”。
将合并的页面添加到现有出版物
如果计划将合并的页面添加到现有出版物的末尾,请确保邮件合并出版物通过以下方式与现有出版物匹配:
- 页面大小 (高度和宽度)
- 页面视图 (单页跨页或两页跨页)
- 发布类型 (Web 或打印)
- 页面顺序 (从左到右或从右到左)
Publisher 将合并的页面添加到新的或现有的出版物,但无法将其添加到打开的出版物。 如果要合并到的出版物处于打开状态,请务必先保存并关闭该出版物,然后再完成合并。
- 单击 添加到现有出版物。
- 在“ 打开的出版物 ”对话框中,找到要添加合并页的出版物,然后单击“ 打开”。
- 在现有出版物中,单击“邮件合并”任务窗格中的“保存此出版物”保存更新。
发送电子邮件
如果要创建电子邮件合并,则“完成 & 合并”下唯一可用的选项是“发送Email邮件”。
- 单击 Send Email Message。
- 在 Merge to Email 对话框中,从“收件人”下拉列表中选择收件人字段。 在大多数情况下,这将是 Email Address。
- 在 “主题”下,键入主题行。 在 “要插入的项”下,单击要在主题行中插入的任何数据字段。
- 单击 “选项” 以指定任何其他所需选项,如抄送或密件抄送收件人或邮件附件,然后单击“ 发送”。
保存邮件合并发布
如果还保存包含合并字段的出版物,则可以返回并编辑字段并创建新的合并出版物。 若要保存合并的出版物,请执行下列操作:
- 单击 “文件>保存”。
- 为发布命名,然后单击 “保存”。
取消合并
可取消合并以断开邮件合并发布或目录合并模板与其数据源的连接。
单击“邮件”选项卡>,选择收件人,然后单击“取消合并”。
当系统询问是否要取消合并时,单击 “是”。
注意
如果取消邮件合并,则“地址字段”、“问候语”和“地址块”以外的字段将转换为常规文本。