KB3213703 - 修复:Always On辅助副本 (replica) 进入断开连接状态

应用对象
SQL Server 2016 Developer - duplicate (do not use) SQL Server 2016 Enterprise - duplicate (do not use) SQL Server 2016 Enterprise Core - duplicate (do not use) SQL Server 2014 Service Pack 2 - duplicate (do not use) SQL Server 2014 Developer - duplicate (do not use) SQL Server 2014 Enterprise - duplicate (do not use) SQL Server 2014 Enterprise Core - duplicate (do not use) SQL Server 2014 Standard - duplicate (do not use) SQL Server 2012 Developer SQL Server 2012 Enterprise SQL Server 2012 Enterprise Core SQL Server 2012 Standard

症状

使用 SQL Server Always On 可用性组时,Always On辅助副本 (replica) 可能会进入断开连接状态。 此外,以下错误消息记录在 SQL Server 错误日志中:

注意

尝试建立与 ID 为 availability_replica_id 的可用性副本 (replica) availability_replica_name的连接时出现连接超时。 存在网络或防火墙问题,或者为副本 (replica) 提供的终结点地址。

尝试重新建立连接时,可能会收到以下错误消息:

注意

此次要副本 (replica) 未连接到主副本 (replica) 。 连接状态为“已断开连接”。

出现此行为时,直到在次要副本 (replica) 上重新启动 SQL Server 服务后,问题才会修复。 在极少数情况下,可能需要在主副本 (replica) 上重启 SQL Server 服务才能恢复 Always On 数据移动。

注意:此问题可能仅发生在功能非常强大的计算机上以及 SQL Server 非常繁忙时。 例如,在一个方案中,此问题发生在具有 24 个内核的非常繁忙的系统上。

原因

问题的发生是因为内部争用条件。

解决方法

此问题已在 SQL Server 的以下累积更新中修复。

关于 SQL Server 的累积更新

SQL Server 的每个新累积更新都包含上一个累积更新中包含的所有修补程序和所有安全修补程序。 查看 SQL Server 的最新累积更新:

SQL Server 2016 的最新累计更新

SQL Server 2014 的最新累计更新

SQL Server 2012 SP3 的最新累计更新

状态

Microsoft 已确认在 "适用于" 部分中所列的 Microsoft 产品中存在问题。

参考资料

了解 Microsoft 用于描述软件更新的 术语 。