KB2142496 - 修复:使用共享 SQL 配置表时,SQL Server 2008 R2 或 SQL Server 2008 SQL Server 2008 Integration Services 包不能在 Business Intelligence Development Studio 中运行

应用对象
SQL Server 2008 R2 Enterprise SQL Server 2008 R2 Datacenter SQL Server 2008 R2 Developer SQL Server 2008 R2 Standard SQL Server 2008 R2 Standard Edition for Small Business SQL Server 2008 R2 Workgroup SQL Server 2008 Developer SQL Server 2008 Enterprise SQL Server 2008 Standard SQL Server 2008 Standard Edition for Small Business SQL Server 2008 Workgroup

Microsoft 将 Microsoft SQL Server 2008 R2 和 Microsoft SQL Server 2008 修复程序作为一个可下载的文件分发。 由于修补程序是累积的,因此每个新版本都包含之前的 SQL Server 2008 R2 和 Microsoft SQL Server 2008 修补程序版本中包含的所有修补程序和安全修补程序。

症状

请考虑以下情形:

  • 在 Microsoft SQL Server 2008 R2 或 Microsoft SQL Server 2008 中创建 SQL Server Integration Services (SSIS) 包。

  • 您可以使用执行包任务在 SSIS 包中运行子包。

    注意 本文的其余部分将此 SSIS 包作为父包引用。

  • 您可以使用 SQL Server 配置类型为父包创建配置表。

  • 您与子包共享相同的配置表。

  • 配置表包含父包中现有对象的许多配置条目。 但是,某些配置表条目中的对象路径在子包中不存在。 例如,对父包使用共享配置表时,共享配置表中引用的某些变量、连接管理器、任务或其他对象并非存在于所有子包中。

  • 在 SQL Server Business Intelligence Development Studio (BIDS) 中运行父包。

在此方案中,父包不会运行。 此外,你还会收到以下错误消息之一:

  • 注意

    找不到连接“<连接名称>”。 找不到特定连接元素时,Connections 集合将引发此错误。

  • 注意

    包路径引用了找不到的对象:“<路径>”。 当尝试解析找不到的对象的包路径时,将发生这种情况。

便笺

  • 除了“症状”部分中提到的错误消息外,还可能出现其他错误消息。
  • 即使将 SupressConfigurationWarnings 设置为 True,此问题仍会出现。
  • Microsoft SQL Server 2005 Integration Services 中不会出现此问题。

        
      

原因

出现此问题的原因是 SQL Server 2008 R2 Integration Services 中出现错误。

具体而言,当通过“执行包”任务将共享配置应用于子包时,包中必须存在所有已配置对象。 否则,执行包任务将引发错误。 通常将此错误视为警告。 但在此情况下,此警告会导致执行包任务报告失败。 因此,父包的执行失败。

解决方法

累积更新信息

SQL Server 2008 Service Pack 2

此问题的修补程序首次在 SQL Server 2008 Service Pack 2 的累积更新 3 中发布。 有关此累积更新包的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:

2498535 SQL Server 2008 Service Pack 2 累积更新包 3 注意 由于版本是累积的,因此每个新的修复版本都包含之前 SQL Server 2008 修复版本中包含的所有修补程序和所有安全修补程序。 Microsoft 建议考虑应用包含此修补程序的最新修补程序版本。 有关更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:

2402659 2008 Service Pack 2 发布之后发布的 SQL Server 2008 内部版本SQL Server Microsoft为特定的 SQL Server Service Pack 创建SQL Server 2008 修补程序。 必须将 SQL Server 2008 Service Pack 2 修补程序应用于 SQL Server 2008 Service Pack 2 的安装。 默认情况下,SQL Server Service Pack 中提供的任何修补程序都包含在下一个 SQL Server Service Pack 中。

SQL Server 2008 Service Pack 1

此问题的修补程序首次在 SQL Server 2008 Service Pack 1 的累积更新 12 中发布。 有关此累积更新包的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:

2467236 SQL Server 2008 Service Pack 1 累积更新程序包 12 注意 由于版本是累积的,因此每个新的修补程序版本都包含之前 SQL Server 2008 修补程序版本中包含的所有修补程序和所有安全修补程序。 Microsoft 建议考虑应用包含此修补程序的最新修补程序版本。 有关更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:

970365 发布 SQL Server 2008 Service Pack 1 之后发布的 SQL Server 2008 内部版本,Microsoft为特定的 SQL Server Service Pack 创建SQL Server 2008 修补程序。 必须将 SQL Server 2008 Service Pack 1 修补程序应用于 SQL Server 2008 Service Pack 1 的安装。 默认情况下,SQL Server Service Pack 中提供的任何修补程序都包含在下一个 SQL Server Service Pack 中。

此问题的修补程序已在累积更新 3 中首次发布。 有关如何获取 SQL Server 2008 R2 的此累积更新程序包的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:

2261464 SQL Server 2008 R2 累积更新包 3 注意 由于版本是累积的,因此每个新的修补程序版本都包含之前 SQL Server 2008 R2 修补程序版本中包含的所有修补程序和安全修补程序。 建议应用包含此修补程序的最新修补程序版本。 有关更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:

981356 在 SQL Server 2008 R2 发布之后发布的 SQL Server 2008 R2 内部版本

解决方法

若要解决此问题,请使用以下某种方法:

方法 1

不要在多个包的共享配置表中使用相同的配置筛选器。 为每个包指定不同的配置筛选器。 当您这样做时,仅为配置表中的一个包引用包对象。

方法 2

将虚拟对象添加到有问题的包。 当您执行此操作时,对象的包路径存在于包中。

例如,假设您有一个名为 Pkg1 的 SSIS 包。 Pkg1 包含名为 CM1 的连接管理器。 您还有一个名为 Pkg2 的 SSIS 包。 Pkg2 包含名为 CM2 的连接管理器。 在这种情况下,这些程序包在共享配置表中共享相同的配置筛选器。 若要避免此问题,请将名为 CM2 的虚拟连接管理器添加到 Pkg1。 还可向 Pkg2 添加名为 CM1 的虚拟连接管理器。

详细信息

应用此修补程序后,在设计时从 Business Intelligence Development Studio (BIDS) 中 DtsDebugHost.exe 调试器本身运行包时,BIDS 仍返回“症状”部分中描述的相同警告消息。 但是,程序包将成功。

使用 DTExec.exe 或其他运行时在调试器外部运行包时,包将成功,而不会显示任何警告消息。 此外,您还会收到以下消息,这意味着配置已成功应用于子包:

程序包正在尝试使用配置字符串从 SQL Server 进行配置
“”ServerName.DbName“;”[dbo]。[SSIS 配置]“;”Connections“;”.

有关了解集成服务包配置的更多信息,请访问以下 Microsoft 网站:

了解 Integration Services 包配置
        
如果你在 SQL Server 2008 中遇到类似问题,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:

974559 修复:运行使用 SQL Server Business Intelligence Development Studio 中的配置表的 SQL Server 2008 Integration Services 包时出现错误消息:“找不到连接”连接名称<>“”

状态

Microsoft 已确认在 "适用于" 部分中所列的 Microsoft 产品中存在问题。

参考资料

有关 SQL Server 增量服务模型的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:

935897 可从 SQL Server 团队获取增量服务模型以提供可以解决所报告问题的修补程序

有关 SQL Server 更新的命名架构的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:

822499 Microsoft SQL Server 软件更新包的新命名架构
有关软件更新术语的更多信息,请单击下面的文章编号以查看 Microsoft 知识库中的相应文章:

824684 用于描述Microsoft软件更新的标准术语说明