Microsoft 将 Microsoft SQL Server 2008 Service Pack 3 修补程序作为一个可下载的文件分发。 由于修补程序是累积的,因此每个新版本都包含之前 SQL Server 2008 Service Pack 3 修补程序版本中包含的所有修补程序和安全修补程序。
症状
使用 dtexec 实用工具并行运行 Microsoft SQL Server 2012 Integration Services (SSIS 2012) 、Microsoft SQL Server 2008 Integration Services (SSIS 2008) 或 Microsoft SQL Server 2008 R2 Integration Services (SSIS 2008 R2) 包时,可能会收到以下一条或多条错误消息。
错误消息 1
注意
无法加载数据流对象。 检查 Microsoft.SqlServer.PipelineXml.dll 是否已正确注册。
错误消息 2
注意
无法加载任务 “TaskName”,键入 “SSIS.Pipeline.2“。 该任务的联系信息是“执行高性能数据提取、转换和加载;Microsoft Corporation;Microsoft SQL Server v10; (C) 2007 Microsoft Corporation;保留所有权利;http://www.microsoft.com/sql/support/default.asp;1“。
错误消息 3
注意
SSIS 错误代码 DTS_E_OLEDBERROR。 发生 OLE DB 错误。 错误代码:0x800736B1。
OLE DB 记录可用。 源:“Microsoft OLE DB 服务组件” Hresult: 0x800736B1 说明:“由于应用程序配置不正确,此应用程序无法启动。 重新安装应用程序可能会解决此问题。”
注意 当计算机遇到高内存压力时,更有可能出现此问题。
原因
出现此问题的原因是 SSIS 不检查 SSIS 组件是否已成功加载。 如果 SSIS 组件未成功加载,SSIS 将验证并执行空数据流任务。
注意:dtexec 实用工具返回值为 0 的退出代码。 此值表示 SSIS 包已成功执行。
解决方法
累积更新信息
SQL Server 2012 SP1 累积更新 2
此问题的修补程序在累积更新 2 中首次发布。 有关如何获取 SQL Server 2012 SP1 的此累积更新程序包的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
2790947 SQL Server 2012 Service Pack 1 累积更新包 2 注意 由于版本是累积的,因此每个新的修复版本都包含之前 SQL Server 2012 SP1 修复版本中包含的所有修补程序和所有安全修补程序。 建议应用包含此修补程序的最新修补程序版本。 有关更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
2772858 在 SQL Server 2012 Service Pack 1 发布之后发布的 SQL Server 2012 内部版本
SQL Server 2012 累积更新 5
此问题的修补程序已在累积更新 5 中首次发布。 有关如何获取 SQL Server 2012 的此累积更新程序包的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
2777772 SQL Server 2012 累积更新包 5注意 由于版本是累积的,因此每个新的修补程序版本都包含之前 SQL Server 2012 修补程序版本中包含的所有修补程序和所有安全修补程序。 建议应用包含此修补程序的最新修补程序版本。 有关更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
2692828 2012 SQL Server 发布之后发布的 SQL Server 2012 内部版本
SQL Server 2008 R2 SP2 的累积更新 4
此问题的修补程序已在累积更新 4 中首次发布。 有关如何获取 SQL Server 2008 R2 SP 2 的此累积更新程序包的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
2777358 SQL Server 2008 R2 Service Pack 2 的累积更新程序包 4
注意:由于版本是累积的,因此每个新的修复程序版本都包含之前 SQL Server 2008 R2 SP 2 修复版本中包含的所有修补程序和安全修补程序。 建议应用包含此修补程序的最新修补程序版本。 有关更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
2730301 在 2008 R2 Service Pack 2 发布之后发布的 SQL Server 2008 R2 内部版本SQL Server
SQL Server 2008 R2 Service Pack 1 累积更新程序包 10
此问题的修补程序已在累积更新 10 中首次发布。 有关如何获取 SQL Server 2008 R2 SP1 的此累积更新程序包的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
2783135 SQL Server 2008 R2 SP1 累积更新程序包 10
注意 由于版本是累积的,因此每个新的修复程序版本都包含之前 SQL Server 2008 R2 SP1 修补程序版本中包含的所有修补程序和安全修补程序。 建议应用包含此修补程序的最新修补程序版本。 有关更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
2567616 在 SQL Server 2008 R2 Service Pack 1 发布之后发布的 SQL Server 2008 R2 内部版本
SQL Server 2008 Service Pack 3
此问题的修补程序首次在 SQL Server 2008 Service Pack 3 的累积更新 7 中发布。 有关如何获取 SQL Server 2008 Service Pack 3 的此累积更新程序包的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
2738350 SQL Server 2008 Service Pack 3 的累积更新程序包 7 注意 由于版本是累积的,因此每个新的修补程序版本都包含之前 SQL Server 2008 Service Pack 3 修复版本中包含的所有修补程序和安全修补程序。 建议应用包含此修补程序的最新修补程序版本。 有关更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
2629969 在 SQL Server 2008 Service Pack 3 发布之后发布的 SQL Server 2008 内部版本
状态
Microsoft 已确认在 "适用于" 部分中所列的 Microsoft 产品中存在问题。
解决方法
要解决此问题,请不要同时运行太多的 SSIS 包。 例如,不要同时运行几百个 SSIS 包。
详细信息
有关 dtexec 实用工具的更多信息,请转到以下 MSDN 网站: