此修补程序也适用于 Microsoft SQL Server 2012 Reporting Services (SSRS 2012) 和 SQL Server 2014 Reporting Services (SSRS 2014) 。
症状
请考虑以下情形:
- 安装 Microsoft SQL Server 2008 R2 Reporting Services (SSRS 2008 R2) 、SQL Server 2012 Reporting Services (SSRS 2012) 或 SQL Server 2014 Reporting Services 的实例在运行 Windows Server 2003、Windows Server 2008、Windows Vista 或更高版本的 Windows 的计算机上 (SSRS 2014) 。
- 在另一台计算机上运行应用程序。 应用程序尝试远程检索 SQL Server Reporting Services 实例的性能计数器数据。
在这种情况下,远程注册表服务在安装了 SQL Server Reporting Services 的计算机上崩溃。 此外,类似下面这样的错误消息将记录在安装了 SQL Server Reporting Services 实例的计算机的应用程序日志中:
注意
故障应用程序名称:svchost.exe_RemoteRegistry,版本:6.1.7600.16385,时间戳:0x4a5bc3c1
故障模块名称:perf-ReportServer$INSTANCENAME-rsctr._unloaded 版本:0.0.0.0,时间戳:0x4bb67a29 异常代码:0xc0000005
错误偏移量:0x0000000069c5b507
错误进程 ID:0x1ad0
故障应用程序启动时间:0x01ce2f154b19923b
故障应用程序路径:Drive:\Windows\system32\svchost.exe
故障模块路径: perf-ReportServer$INSTANCENAME-rsctr
报告编号: 489cdf90-9b0d-11e2-b6ac-005056b63f2a
此外,在安装了 SQL Server 实例的计算机的 Windows 系统日志中,会记录一个类似下面这样的错误消息:
注意
Date,Time,Error,ServerName,7034,Service Control Manager,N/A,N/A,“远程注册表服务意外终止。 它已经完成了这个 数字 () 。
原因
出现此问题的原因是 SQL Server Reporting Services 性能计数器使用了错误的方法调用 RegQueryValueEx API 来访问注册表项。 此行为会导致远程注册表服务崩溃。
注意 远程注册表服务加载 SQL Server Reporting Services 性能计数器。
解决方法
累积更新信息
此问题已首先在 SQL Server 的以下累积更新中修复。
SQL Server 2014 累积更新 1 /en-us/help/2931693
SQL Server 2012 累积更新 11 /en-us/help/2908007
SQL Server 2012 SP1 累积更新 7 /en-us/help/2894115
SQL Server 2008 R2 SP2 的累积更新 8 /en-us/help/2871401
关于 SQL Server 的累积更新
SQL Server 的每个新累积更新都包含上一个累积更新中包含的所有修补程序和所有安全修补程序。 查看 SQL Server 的最新累积更新:
- SQL Server 2014 的最新累计更新
- SQL Server 2012 的最新累计更新
- SQL Server 2012 SP1 的最新累计更新
- SQL Server 2008 R2 SP2 的最新累计更新
状态
Microsoft 已确认在 "适用于" 部分中所列的 Microsoft 产品中存在问题。
参考资料
请参阅 Microsoft 用于描述软件更新的术语 。