KB2645648 - 修复:将包含多个级别文档映射的 64 位 SSRS 2008 R2 报告、SSRS 2012 报告或 SSRS 2008 报告导出为 PDF 格式时,导出过程失败

应用对象
SQL Server 2012 Developer SQL Server 2012 Enterprise SQL Server 2012 Express SQL Server 2012 Standard SQL Server 2012 Web SQL Server 2012 Enterprise Core

Microsoft 在一个可下载的文件中分发 Microsoft SQL Server 2008 R2 Service Pack 1 (SP1) 或Microsoft SQL Server 2008 修补程序。 由于修补程序是累积的,因此每个新版本都包含之前的 SQL Server 2008 R2 Service Pack 1 (SP1) 或 SQL Server 2008 更新版本中包含的所有修补程序和安全更新。

症状

请考虑以下情形:

  • 在 Microsoft SQL Server 2008 R2 Reporting Services (SSRS 2008 R2) 64 位实例中、在 Microsoft SQL Server 2008 Reporting Services (SSRS 2008) 实例或 Microsoft SQL Server 2012 中有一个报表Reporting Services (SSRS 2012) 实例。
  • 报表包含文档结构图的多个级别。
  • 尝试将报表导出为 PDF 格式。

在此方案中,导出过程失败,并收到以下错误消息:

注意

远程服务器返回了错误: (500) 内部服务器错误。

此外,SSRS 日志文件中还记录了以下错误:

注意

rshost!rshost!bb8!<Date><Time>:: e 错误:无法处理请求 0x80131014,pipeline=0x0000000002B99080。
UI!ReportManager_0-84!ee8!<日期><时间>:: 未处理的异常: Microsoft.Reporting.WebForms.ReportServerException: 远程服务器返回了错误: (500) 内部服务器错误。 ---> System.Net.WebException:远程服务器返回了错误: (500) 内部服务器错误。

        
便笺

  • 您仍然可以成功地呈现 HTML 格式的报表。
  • 如果在运行 32 位操作系统的计算机上安装了 SSRS 2008 R2,则不会发生此问题。

原因

出现此问题的原因是 SSRS PDF 呈现器的限制。

解决方法

累积更新信息

SQL Server 2012 Service Pack 1 累积更新程序包 1

此问题的修补程序首次在累积更新 1 中发布。 若要详细了解如何获取 SQL Server 2012 Service Pack 1 的此累积更新程序包,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:

2765331 SQL Server 2012 Service Pack 1 累积更新包 1 注意 由于版本是累积的,因此每个新的修复版本都包含之前 SQL Server 2012 修复版本中包含的所有修补程序和所有安全修补程序。 建议应用包含此修补程序的最新修补程序版本。 有关更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:

2772858 在 SQL Server 2012 Service Pack 1 发布之后发布的 SQL Server 2012 内部版本

SQL Server 2012

此问题的修补程序首次在 SQL Server 2012 的累积更新 3 中发布。 有关此累积更新包的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:

2723749 SQL Server 2012 累积更新包 3注意 由于版本是累积的,因此每个新的修补程序版本都包含之前 SQL Server 2012 修补程序版本中包含的所有修补程序和所有安全修补程序。 Microsoft 建议考虑应用包含此修补程序的最新修补程序版本。 有关更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:

2692828 SQL Server 2012 发布之后发布的 SQL Server 2012 内部版本 必须将 SQL Server 2012 修补程序应用于 SQL Server 2012 的安装。

SQL Server 2008 Service Pack 3

此问题的修补程序首次在 SQL Server 2008 Service Pack 3 的累积更新 6 中发布。 有关此累积更新包的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:

2715953 SQL Server 2008 Service Pack 3 的累积更新包 6 注意 由于版本是累积的,因此每个新的修补程序版本都包含之前 SQL Server 2008 修补程序版本中包含的所有修补程序和所有安全修补程序。 Microsoft 建议考虑应用包含此修补程序的最新修补程序版本。 有关更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:

2629969 SQL Server 2008 Service Pack 3 发布后发布的 SQL Server 2008 内部版本Microsoft为特定的 SQL Server Service Pack 创建 SQL Server 2008 修补程序。 必须将 SQL Server 2008 Service Pack 3 修补程序应用于 SQL Server 2008 Service Pack 3 的安装。 默认情况下,SQL Server Service Pack 中提供的任何修补程序都包含在下一个 SQL Server Service Pack 中。

SQL Server 2008 Service Pack 2

此问题的修补程序首次在 SQL Server 2008 Service Pack 2 的累积更新 8 中发布。 有关此累积更新包的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:

2648096 SQL Server 2008 Service Pack 2 的累积更新包 8 注意 由于版本是累积的,因此每个新的修补程序版本都包含之前 SQL Server 2008 修补程序版本中包含的所有修补程序和所有安全修补程序。 Microsoft 建议考虑应用包含此修补程序的最新修补程序版本。 有关更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:

2402659 2008 Service Pack 2 发布之后发布的 SQL Server 2008 内部版本SQL Server Microsoft为特定的 SQL Server Service Pack 创建SQL Server 2008 修补程序。 必须将 SQL Server 2008 Service Pack 2 修补程序应用于 SQL Server 2008 Service Pack 2 的安装。 默认情况下,SQL Server Service Pack 中提供的任何修补程序都包含在下一个 SQL Server Service Pack 中。

SQL Server 2008 R2 SP1 累积更新程序包 4

此问题的修补程序已在累积更新 4 中首次发布。 有关如何获取 SQL Server 2008 R2 SP1 的此累积更新程序包的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:

2633146 SQL Server 2008 R2 SP1 累积更新程序包 4 注意 由于版本是累积的,因此每个新的修补程序版本都包含之前 SQL Server 2008 R2 SP1 修补程序版本中包含的所有修补程序和安全修补程序。 建议应用包含此修补程序的最新修补程序版本。 有关更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:

2567616 在 SQL Server 2008 R2 SP1 发布之后发布SQL Server 2008 R2 内部版本

解决方法

要解决此问题,请使用较少级别的文档结构图。

状态

Microsoft 已确认在 "适用于" 部分中所列的 Microsoft 产品中存在问题。