KB2899945 - 修复:在 SharePoint 网站上查看 SSRS 2012 或 SSRS 2014 报告时,出现“报告服务器无法处理报告”错误

应用对象
SQL Server 2012 Developer SQL Server 2012 Enterprise SQL Server 2012 Standard SQL Server 2014 Developer - duplicate (do not use) SQL Server 2014 Enterprise - duplicate (do not use) SQL Server 2014 Standard - duplicate (do not use)

症状

尝试在 Microsoft SharePoint 网站上查看 Microsoft SQL Server 2012 Reporting Services (SSRS 2012) 或 SQL Server 2014 Reporting Services (SSRS 2014) 报告时,可能会收到以下错误消息:

注意

Microsoft.ReportingServices.Diagnostics.Utilities.InvalidDataSetReferenceException:报表服务器无法处理报告。 共享数据集 'DataSet' 的引用无效。

在这种情况下,你发现此报表的数据集和数据源集合信息已从 SSRS 报表服务器目录数据库中删除。 但是,不会删除集合信息。

此外,以下错误消息将记录在 SharePoint 日志中:

注意

< 日期><Time>w3wp.exe (0x2D54) 0x2C5C SQL Server Reporting Services Report Server Catalog 0000 High 目录项 /... /在 SharePoint 网站中找不到 MyReport.rdl。 它将从目录中删除。

注意 当 SharePoint 内容数据库存在某些连接问题时,会出现此问题。

原因

出现此问题的原因是,当 SharePoint 配置数据库处于联机状态时,报表被视为无效报表,并且可以在内容数据库出现连接问题时连接到该数据库。

解决方法

此问题已首先在 SQL Server 的以下累积更新中修复。

SQL Server 2014 累积更新 1 /en-us/help/2931693

SQL Server 2012 SP1 累积更新 7 /en-us/help/2894115

关于 SQL Server 的累积更新

SQL Server 的每个新累积更新都包含上一个累积更新中包含的所有修补程序和所有安全修补程序。 查看 SQL Server 的最新累积更新:

      

状态

Microsoft 已确认在 "适用于" 部分中所列的 Microsoft 产品中存在问题。