症状
请考虑以下情形:
- 在 SharePoint 集成模式下使用 Microsoft SQL Server 2012 Reporting Services (SSRS 2012) 或 SSRS 2014。
- 将数据刷新选项设置为“使用缓存数据”,并将“缓存选项”设置为“根据共享计划”或“根据自定义计划”。
- 您可以配置 SSRS 使缓存无效并刷新掉缓存的计划。
在此方案中,将记录类似于以下内容的异常:
注意
w3wp!schedule!e!<日期>-<Time>:: i INFO: 处理包含数据 4248182a-16b1-4c6a-b630-298cd24ae152 的事件 CacheInvalidateSchedule。
w3wp!library!e!<日期>-<Time>:: i INFO: Schedule 591b959d-5754-4dc6-95b6-a988d8c4587a 执行时间: 04/24/2014 20:30:07。
w3wp!schedule!e!<日期>-<Time>:: i INFO: Invalidating report cache for report /{59ee4a21-c7c4-49f7-b812-29f060672d08}/<Item Path>'
w3wp!library!e!<日期>-<Time>:: i INFO: 调用 FlushCacheAction () 。
w3wp!library!e!<日期>-<Time>:: e 错误:引发 Microsoft.ReportingServices.Diagnostics.Utilities.InvalidItemPathException: , Microsoft.ReportingServices.Diagnostics.Utilities.InvalidItemPathException: 项目“/{59ee4a21-c7c4-49f7-b812-29f060672d08}/<项目路径>”的路径无效。 完整路径的长度必须少于 260 个字符;其他限制适用。 如果报表服务器处于本机模式,则路径必须以斜杠开头。;
w3wp!library!e!<日期>-<Time>:: e 错误:计划 591b959d-5754-4dc6-95b6-a988d8c4587a 失败。 错误 Microsoft.ReportingServices.Diagnostics.Utilities.InvalidItemPathException: The path of the item '/{59ee4a21-c7c4-49f7-b812-29f060672d08}/<Item Path>' is not valid. 完整路径的长度必须少于 260 个字符;其他限制适用。 如果报表服务器处于本机模式,则路径必须以斜杠开头。
发生异常后,不会清理报表缓存。 这会迅速增加数据库大小,并且永远不会被清理。
原因
出现此问题是因为产品存在已知限制。
解决方法
此问题已首先在 SQL Server 的以下累积更新中修复。
SQL Server 2014 累积更新 4 /en-us/help/2999197
SQL Server 2012 SP2 累积更新 2 /en-us/help/2983175
SQL Server 2012 SP1 累积更新 11 /en-us/help/2975396
关于 SQL Server 的累积更新
SQL Server 的每个新累积更新都包含上一个累积更新中包含的所有修补程序和所有安全修补程序。 查看 SQL Server 的最新累积更新:
状态
Microsoft 已确认在 "适用于" 部分中所列的 Microsoft 产品中存在问题。