在 Excel 中刷新数据表时出现 "无法找到可安装的 ISAM" 错误

症状

当您尝试刷新链接到 Microsoft Access 数据库的 Microsoft Excel 工作簿中的数据时,可能会收到以下错误消息:

找不到可安装的 ISAM

如果工作簿以前是在较新版本的 Excel 中打开和刷新的,则会出现此问题。

原因

当链接到 Access 数据库的 Excel 工作簿在较新版本的 Excel 中打开时,可以将参数添加到连接字符串。 如果早期版本的 Excel 不能识别这些参数,它会触发错误消息。

解决方案

若要解决此问题,请从连接字符串中删除新参数。 为此,请按照下列步骤操作:

  1. 打开 Excel 工作簿。

  2. 在 " 数据 " 功能区上,单击 " 连接 " 按钮。

  3. 在 " 工作簿连接" 对话框中,选择到 Access 数据库的连接,然后单击 "属性"。

  4. 在 " 连接属性 " 对话框中,单击 " 定义 " 选项卡。

  5. 从连接字符串中删除以下参数:

    Jet OLEDB:绕过用户验证 = False;Jet OLEDB:受限 DB 缓存 = False;Jet OLEDB:旁路 ChoiceField 验证 = False

  6. 在 " 连接属性 " 对话框中,单击 "确定"。 此时应刷新您的数据。

  7. 在 " 工作簿连接 " 对话框中,单击 " 关闭",然后保存已更新的工作簿。

更多信息

如果在较新版本的 Excel 中刷新和保存工作簿,则会出现此问题。

需要更多帮助?

扩展你的技能
了解培训
抢先获得新功能
加入 Microsoft 内部人员

此信息是否有帮助?

谢谢您的反馈意见!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×