症状

在 Microsoft Dynamics SL 或 Microsoft Dynamics GP 中使用业务门户时,Web 部件中收到以下错误消息:

CurrentPrincipal 未进行身份验证

原因

如果为业务门户网站或 BusinessPortal 虚拟目录启用了匿名访问,则会出现此问题。

解决方法

若要解决此问题,请执行以下步骤:

  1. 在Microsoft Internet Information Services (IIS) 管理器中,右键单击"业务门户"网站。 然后单击"属性"。

  2. 在"目录安全性"选项卡上的"身份验证和访问控制"部分中,单击"编辑"。

  3. 单击可清除" 启用匿名访问 "复选框(如果已选中)。

  4. 单击“应用”,然后单击“确定”。注意 如果系统提示将更改向下滚动到所有子节点,请单击"全",然后单击"确定"。

  5. 展开"业务门户网站",右键单击"BusinessPortal"虚拟目录,并单击"属性"。

  6. 在"目录安全性"选项卡上的"身份验证和访问控制"部分中,单击"编辑"。

  7. 单击可清除" 启用匿名访问 "复选框(如果已选中)。

  8. 单击“应用”,然后单击“确定”。注意 如果系统提示将更改向下滚动到所有子节点,请单击"全",然后单击"确定"。

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