症状
假定您部署的服务器运行 Microsoft Exchange Server 2016,2013 和 2010年的混合。 运行以下 cmdlet 在 Exchange Server 2010年管理外壳 (EMS) 中删除此服务器作为代理终结点:
Set-ClientAccessServer -Identity <server_name> -IsOutofService $True
注意 您可以 restart MSExchangeADTopology 服务和Internet Information Services(IIS)应用程序池在 Exchange Server 2016 以确保更改将立即生效。若要确定是否此更改已经生效,尝试访问登录到 OWA Exchange Server 2010年承载的邮箱。如果登录尝试不成功这意味着更改已经生效。
然后,您通过在 Exchange Server 2010年客户端访问服务器 (CAS) 上运行以下 cmdlet 还原为False的IsOutofService值:
Set-ClientAccessServer -Identity <server_name> -IsOutofService $False
在这种情况下,您需要登录到您的邮箱从 OWA 而无任何问题。 但是,您无法登录到 OWA。 此外,如果您尝试登录到Exchange Server 2010 中,尝试存在一个邮箱的 Exchange Server 2016年环境从 OWA 可能会继续一天或更多会失败。
原因
出现此问题是因为IsOutofService值中的 IIS 和Microsoft Exchange 活动目录拓扑服务不更新时间Exchange Server 2016年和2013年环境。
解决方案
Exchange Server 2016
若要解决此问题,请为 Exchange Server 2016 Exchange Server 2016年或以后累积更新安装累积更新 10 。
Exchange Server 2013
若要解决此问题,请为 Exchange Server 2013 Exchange Server 2013年或以后累积更新安装累积更新 21 。
解决方法
要变通解决此问题,请重新启动 Microsoft Exchange 活动目录拓扑服务和 IIS 中的Exchange Server 2016年和2013年环境。
若要重新启动 Microsoft Exchange 活动目录拓扑服务,运行以下 cmdlet PowerShell:
Restart-Service -Name MSExchangeADTopology -Force
要重新启动 IIS,请单击开始,单击运行,键入IISReset ,然后单击确定。
命令提示符窗口将打开并显示 IISReset 命令的状态。 您应阅读在命令提示符下以确保 IIS 停止并随后重新启动的状态。
参考
了解 Microsoft 用于描述软件更新的术语。