症状
尝试更改用户的默认公司时,会收到以下错误消息:
Internet Explorer脚本 错误 此页上的脚本中发生错误。 行:127 个字符:3 错误:访问被拒绝代码:0 URL:http://XXX/businessportal/portal/administration/AC_DefaultCompany.aspx?UserID=GUID
在此错误消息中,GUID 表示尝试更改默认公司的用户的GUID。此问题出现在 Microsoft Dynamics GP 中的 Business Portal 3.0、Microsoft Dynamics SL 中的 Business Portal 3.0 和 Microsoft Business Solutions Business Portal 2.5 中。注意 只有在尝试更改未分配管理员角色的用户的默认公司时,你才能收到此错误消息。
原因
发生此问题的原因是" 默认公司" 字段是用户定义的字段,而不是管理员定义的字段。 因此,由于用户未分配"管理员"角色,因此无法在 Business Portal 3.0 或 Microsoft Business Portal 2.5 的"站点设置"选项卡上更改该用户的默认公司。
解决方法
若要解决此问题,请使用以下方法之一。
方法 1:让用户更改默认公司
单个用户可以使用业务门户 3.0、Microsoft Business Portal 2.5 或 Microsoft Business Portal 2.5 功能包中的"我的设置"选项更改其默认公司。
方法 2:暂时将管理员角色分配给用户
重要:这些步骤可能会增大安全风险。 这些步骤还可能导致计算机或网络更容易受到恶意用户或恶意软件(如病毒)的攻击。 我们建议采用本文介绍的过程,使程序能够按其设计运行,或实现特定的程序功能。 在做出这些更改之前,建议评估与在特定的环境中实施此过程相关的风险。 如果选择实施此过程,请执行任何适当的附加步骤来帮助保护系统。 建议仅在确实需要此过程时使用此过程。若要修改非管理用户的默认公司,请执行以下步骤:
-
将"管理员"角色分配给要为其更改默认公司的用户:
-
登录到 Business Portal 3.0 或 Microsoft Business Portal 2.5。
-
单击"设置",然后单击"用户和权限"下的"管理业务门户用户"。
-
在 "用户列表"中,单击要更改其默认公司的非管理用户。
-
在" 用户属性" 窗格中, 单击" 门户角色"列表旁边的 "修改 "。
-
在出现的"修改角色 --网页"对话框中,单击以选中"管理员"复选框,然后单击"确定"。
-
-
在 Business Portal 3.0 或 Microsoft Business Portal 2.5 中更改该用户的默认公司。
-
从此用户中删除管理员角色。
更多信息
重现行为的步骤
-
登录到 Business Portal 3.0 或 Microsoft Business Portal 2.5。
-
单击"网站设置选项卡,然后单击"管理业务门户用户"。
-
单击非管理用户,然后尝试修改该用户的默认公司。
将收到"症状"部分中提到的错误消息。