使用 Microsoft 登录
登录或创建帐户。
你好,
使用其他帐户。
你有多个帐户
选择要登录的帐户。

症状

尝试在 Microsoft Dynamics GP 10.0 或 Microsoft Dynamics GP 9.0 中打开业务门户中的"订单管理设置"页面时,收到以下错误消息:

"/"应用程序访问路径

"c:\inetpub\wwwroot\bin\~privatefile.dbauthentication.config服务器错误"被拒绝。 异常详细信息
:ASP.NET 无权访问请求的资源。 请考虑向请求标识授予对资源 ASP.NET 权限。 ASP.NET 应用程序未模拟时,会使用基本进程标识。 如果应用程序 <通过标识 imprersonate="true"/>模拟,则标识将是匿名用户或经过身份验证的请求用户。

原因

出现此问题的原因是GPReg.dll文件缺失或未注册。

解决方法

若要解决此问题,请执行以下步骤:

  1. 验证GPReg.dll文件是否位于用于安装业务门户的网站的根目录的 bin 文件夹中。

    注意 默认情况下,bin 文件夹位于以下位置:

    C:\Inetpub\wwwroot\bin

  2. 手动注册GPReg.dll文件。 为此,请使用下列方法之一:

    • 使用命令提示符:

      1. 单击"开始",单击"运行",在"打开"框中键入 cmd,然后单击"确定"。

      2. 更改为包含文件GPReg.dll目录。


        注意 若要更改为默认位置,请在命令提示符下键入 CD inetpub\wwwroot\bin,然后按 Enter。

      3. 在命令提示符下,键入 Regsvr32 GPReg.dll,然后按 Enter。

    • 使用 Microsoft Windows资源管理器:

      1. 右键单击"开始",然后单击"浏览"。

      2. 找到并右键单击GPReg.dll文件,指向"使用打开",然后单击"选择程序"。

      3. 在"打开时"对话框中,单击"浏览"。

      4. 在"查找位置"列表中,单击C:\Windows\System32文件夹,单击Regsvr32.exe文件,然后单击"打开"。

更多信息

重现问题的步骤

  1. 在业务门户中,单击"站点设置",单击"应用程序设置",然后单击"订单管理设置"。

  2. 如果系统提示输入用户名和密码,请输入用户名和密码。

  3. 单击“确定”。

需要更多帮助?

需要更多选项?

了解订阅权益、浏览培训课程、了解如何保护设备等。

社区可帮助你提出和回答问题、提供反馈,并听取经验丰富专家的意见。

此信息是否有帮助?

你对语言质量的满意程度如何?
哪些因素影响了你的体验?
按“提交”即表示你的反馈将用于改进 Microsoft 产品和服务。 你的 IT 管理员将能够收集此数据。 隐私声明。

谢谢您的反馈!

×